Bug 62491 - [PATCH]alx 0000:02:00.0: invalid PHY speed/duplex: 0xffff
Summary: [PATCH]alx 0000:02:00.0: invalid PHY speed/duplex: 0xffff
Status: RESOLVED CODE_FIX
Alias: None
Product: Networking
Classification: Unclassified
Component: Other (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: Stephen Hemminger
URL:
Keywords:
: 62501 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-03 17:21 UTC by vaniaz
Modified: 2015-04-15 18:45 UTC (History)
8 users (show)

See Also:
Kernel Version: 3.12-rc3
Tree: Mainline
Regression: No


Attachments
Patch to fix this bug (969 bytes, patch)
2013-11-12 17:23 UTC, Jonas Hahnfeld
Details | Diff

Description vaniaz 2013-10-03 17:21:27 UTC
Hardware: lenovo g780 using alx network driver; software - opensuse tambleweed with kernel 3.12-rc3.
After entering sleep mode and waking up console at alt + f is flooding with messages like:
[672.000000] alx 0000:02:00.0: invalid PHY speed/duplex: 0xffff
Comment 1 Johannes Berg 2013-10-11 14:00:00 UTC
This is the second report I see of this, but I have no idea. I can't even easily run my machine that has this driver with 3.12-rc, it's in production now.

Maybe you can bisect?
Comment 2 Jonas Hahnfeld 2013-10-20 12:35:43 UTC
hardware: ASUS N56VZ, Qualcomm Atheros AR8161 Gigabit Ethernet (rev 10)
software: ArchLinux with GNOME

Have the same Bug on 3.12-rc6 and had it on 3.11.x before.
On 3.10.x-lts everything is working correctly, even now...

I can try to bisect it. On the main tree by Linus, correct?
Comment 3 Jonas Hahnfeld 2013-10-28 09:04:19 UTC
I tried it last week and yesterday and got weird results (a commit containing changes on nouveau, changes in the USB-core...)
I have now found out that this problem occurs only when causing the suspend from GNOME with a shortcut on my keyboard or when closing the lid.
However, it does NOT happen when using "sudo pm-suspend" in the terminal!
Comment 4 Jonas Hahnfeld 2013-10-28 20:47:24 UTC
I finally found and verified it:
It is commit bc2bebe8de8ed4ba6482c9cc370b0dd72ffe8cd2 ("alx: remove WoL support") by you...
Simply reverting it did the trick on 3.12.0-rc7. And my laptop isn't resuming at once. Everything working correctly like in 3.10.x...
Comment 5 Martin McGreal 2013-11-06 19:54:57 UTC
Confirming this problem under Fedora 19 with KDE on Asus N56VZ, Qualcomm Atheros AR8161 Gigabit Ethernet (rev 10). 

After closing the lid and then resuming, a kworker thread pegs the CPU and the "invalid PHY speed/duplex: 0xffff" messages flood the kernel ring buffer.

Also this problem is happening for me even if I just use "sudo pm-suspend", unlike reported in comment 3.

One workaround is to never suspend, only shut down.
Comment 6 Romain Bezut 2013-11-11 16:47:52 UTC
Also confirming what is said in comment 4, reverting bc2bebe8de8ed4ba6482c9cc370b0dd72ffe8cd2 fixed the suspend/resume issue on a fresh 3.12.0 kernel.
Comment 7 Jonas Hahnfeld 2013-11-12 17:23:12 UTC
Created attachment 114381 [details]
Patch to fix this bug

I have finally found the necessary lines from the whole commit. The patch is attached
Comment 8 Alan 2013-11-13 14:17:56 UTC
*** Bug 62501 has been marked as a duplicate of this bug. ***
Comment 9 Jonas Hahnfeld 2013-11-15 12:29:00 UTC
Patch has been applied to the net subsystem
Comment 10 Charles R. Anderson 2013-11-16 16:32:32 UTC
(In reply to Jonas Hahnfeld from comment #7)
> Created attachment 114381 [details]
> Patch to fix this bug
> 
> I have finally found the necessary lines from the whole commit. The patch is
> attached

This patch fixes the problem for me on an Asus X202E.
Comment 11 Jonas Hahnfeld 2013-11-30 13:49:36 UTC
3.12.2 and 3.11.10 have been released which both include this patch. So I think this bug can be marked as fixed!
Comment 12 Christ Jan Wijtmans 2015-04-15 18:42:30 UTC
Probably i will be hated for posting this here but i am getting desperate. Is there any ALX driver maintainer left? Or someone that can propose the patch to be included. Basically multiple people want to have WOL functionality back in the ALX driver. Also some people claim the reason(bug) for taking the functionality out no longer applies to recent kernels. https://bugzilla.kernel.org/show_bug.cgi?id=61651
Comment 13 Christ Jan Wijtmans 2015-04-15 18:43:58 UTC
I would like to note that WOL functionality is the main reason i got this hardware. And it could be extremely useful to me for being away and working on distance.
Comment 14 Stephen Hemminger 2015-04-15 18:45:33 UTC
To get involved, please submit details of what is broken to Network Developers mailing list <netdev@vger.kernel.org> 

Bugzilla is only used as a proxy to forward bugs to the mailing list.
It is not actively used by the kernel developers.

Note You need to log in before you can comment on or make changes to this bug.