Bug 6240 - SATA drive with VT6420/8237 (timeout; failed to set xfermode, disabled )
SATA drive with VT6420/8237 (timeout; failed to set xfermode, disabled )
Status: REJECTED UNREPRODUCIBLE
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
i386 Linux
: P2 high
Assigned To: Jeff Garzik
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-17 14:33 UTC by lkml
Modified: 2007-07-09 11:58 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.16.13
Tree: Mainline
Regression: ---


Attachments
kernel config 2.6.16 (30.07 KB, text/plain)
2006-03-21 22:22 UTC, lkml
Details
boot log for 2.6.16 (11.13 KB, text/plain)
2006-03-21 22:23 UTC, lkml
Details
results of lspci -vvvv (9.45 KB, text/plain)
2006-03-21 22:23 UTC, lkml
Details
config for 2.6.16.2 kernel repro (30.65 KB, text/plain)
2006-04-11 23:24 UTC, lkml
Details
boot log for 2.6.16.2 (11.26 KB, text/plain)
2006-04-11 23:25 UTC, lkml
Details
boot log for 2.6.16.13 (15.16 KB, text/plain)
2006-05-07 21:36 UTC, lkml
Details

Description lkml 2006-03-17 14:33:38 UTC
Most recent kernel where this bug did not occur: unknown
Distribution: Slackware 10.2
Hardware Environment: MSI KT6V LSR motherboard, AMD cpu, Via VT6420/8237 chips,
Hitachi 7K250 250GB SATA drive (SINGLE DRIVE)
Software Environment: libata version 1.20
Problem Description: Can't get drive to work

vanilla 2.6.15.6 kernel, no patches:

Able to partition, but [c]fdisk takes a long time to start up.  Trying
mkreiserfs gets past the journal initialization, and the drive seems to be
spinning, but an hour can go by with no progress (have to reboot to stop the
process) -- no filesystem created.  Booting gives the following.

ata1: slow completion (cmd ef)
 sda1 sda2 <<3>ata1: command 0x25 timeout, stat 0x50 host_stat 0x4
 sda5<3>ata1: command 0x25 timeout, stat 0x50 host_stat 0x4
 sda6<3>ata1: command 0x25 timeout, stat 0x50 host_stat 0x4
 sda7<3>ata1: command 0x25 timeout, stat 0x50 host_stat 0x4
 sda8<3>ata1: command 0x25 timeout, stat 0x50 host_stat 0x4
 sda9<3>ata1: command 0x25 timeout, stat 0x50 host_stat 0x4
 sda10<3>ata1: command 0x25 timeout, stat 0x50 host_stat 0x4
 sda11 >


2.6.15 with libata1 patch (Current Setup):

No device created.  Can't access the drive at all.  Boot log:

libata version 1.20 loaded.
sata_via 0000:00:0f.0: version 1.1
PCI: Via IRQ fixup for 0000:00:0f.0, from 10 to 1
sata_via 0000:00:0f.0: routed to hard irq line 1
ata1: SATA max UDMA/133 cmd 0xEC00 ctl 0xE802 bmdma 0xDC00 irq 17
ata2: SATA max UDMA/133 cmd 0xE400 ctl 0xE002 bmdma 0xDC08 irq 17
ata1: SATA link up 1.5 Gbps (SStatus 113)
ata1: qc timeout (cmd 0xec)
scsi0 : sata_via
ata2: SATA link down (SStatus 0)
scsi1 : sata_via


Steps to reproduce:
download, compile, install, reboot

I've turned off all of my smartctl/smartd and disabled all the IDE DMA to no effect.

Other info for 2.6.15 with libata1 patch (current setup):

00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID
Controller (rev 80)
        Subsystem: Micro-Star International Co., Ltd.: Unknown device 5901
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 32
        Interrupt: pin B routed to IRQ 17
        Region 0: I/O ports at ec00 [size=8]
        Region 1: I/O ports at e800 [size=4]
        Region 2: I/O ports at e400 [size=8]
        Region 3: I/O ports at e000 [size=4]
        Region 4: I/O ports at dc00 [size=16]
        Region 5: I/O ports at d800 [size=256]
        Capabilities: <available only to root>

config from the patched 2.6.15:
#
# SCSI support type (disk, tape, CD-ROM)
#
CONFIG_BLK_DEV_SD=y
CONFIG_BLK_DEV_SR=m
CONFIG_CHR_DEV_SG=y
#
# Some SCSI devices (e.g. CD jukebox) support multiple LUNs
#
CONFIG_SCSI_CONSTANTS=y
CONFIG_SCSI_LOGGING=y
#
# SCSI low-level drivers
#
CONFIG_SCSI_SATA=y
CONFIG_SCSI_PATA_VIA=y
CONFIG_SCSI_SATA_VIA=y
CONFIG_SCSI_QLA2XXX=y
Comment 1 lkml 2006-03-21 22:22:49 UTC
Created attachment 7630 [details]
kernel config 2.6.16
Comment 2 lkml 2006-03-21 22:23:19 UTC
Created attachment 7631 [details]
boot log for 2.6.16
Comment 3 lkml 2006-03-21 22:23:47 UTC
Created attachment 7632 [details]
results of lspci -vvvv
Comment 4 lkml 2006-04-11 23:24:43 UTC
Created attachment 7841 [details]
config for 2.6.16.2 kernel repro
Comment 5 lkml 2006-04-11 23:25:13 UTC
Created attachment 7842 [details]
boot log for 2.6.16.2
Comment 6 lkml 2006-05-07 21:36:58 UTC
Created attachment 8036 [details]
boot log for 2.6.16.13
Comment 7 Timo Gurr 2006-07-18 04:33:36 UTC
Just was about to report probably the same bug, before finding this one.
(searched for VT8237 before) I have the same problem:

Most recent kernel where this bug did not occur: Not known
Tested Kernel Versions: 2.6.16.x, 2.6.17.5 and 2.6.18_rc2
Distribution: Gentoo Linux
Hardware Environment:
Mainboard: ASUS A7V600-X
Onboard SATA Chipset: VIA VT6420 (00:0f.0 RAID bus comtroller: VIA Technologies,
Inc. VIA VT6420 SATA RAID Controller (rev 80)
HDD: Samsung HD800HJ Single Drive

Software Environment:
Compiler: GCC 4.1.1
Filesystem: XFS
Boot Loader: LiLo 22.7.1

Problem Description:
The problem occurs only when trying to use a Serial ATA disk with the VT8237,
the onboard PATA worked fine so far (before the HDD gas gone bad).

With kernel 2.6.17 I got:
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
ata1: qc timeout (cmd 0xef)
ata1: failed to set xfermode (err_mask=0x4)
...
VFS: Cannot open root device "803" or unknown-block(8,3)
Please append a correct "root=" boot option
Kernel panicc - not syncing: VFS: Unable to mount root fs on unknown-block(8,3)
 <6>Time: tsc clocksource has been installed.

so I googled for "Can't set xfermode" and found
http://www.linuxquestions.org/questions/showthread.php?t=448934

So I tested with 2.6.18_rc2 and now I get:
scsi0 : sata_via
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
ata1.00: qc timeout (cmd 0xec)
ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4)
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
ata1.00: qc timeout (cmd 0xec)
ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4)
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
scsi0 : sata_via
ata2: SATA link down (SStatus 0 SControl 310)
ATA: abnormal status 0x7F on port 0xB807
...
VFS: Cannot open root device "803" or unknown-block(8,3)
Please append a correct "root=" boot option
Kernel panicc - not syncing: VFS: Unable to mount root fs on unknown-block(8,3)
 <6>Time: tsc clocksource has been installed.

Notes:
I can boot the system and mount the filesystem fine with a Gentoo Live CD (2006
release) It comes with kernel 2.6.15

Now thinking about it, I thought the PATA disk has gone bad because of I/O error
warnings and system crashing, but perhaps this problem is related and was
introduced with the upgrade to kernel 2.6.17?
But then again, the SATA boot problem is there with kernel 2.6.16, too. I'm kind
of clueless here what to try next.
Comment 8 Natalie Protasevich 2007-07-08 17:16:10 UTC
lkml, Timo,
Have you tested with latest kernels? Is the problem still there?
Thanks.
Comment 9 lkml 2007-07-08 18:42:54 UTC
lkml: I ended up getting a new motherboard.

Note You need to log in before you can comment on or make changes to this bug.