Bug 6237 - A21m 2.6.16-rc6 after second sleep freeze
Summary: A21m 2.6.16-rc6 after second sleep freeze
Status: REJECTED DUPLICATE of bug 6749
Alias: None
Product: ACPI
Classification: Unclassified
Component: EC (show other bugs)
Hardware: i386 Linux
: P2 low
Assignee: Alexey Starikovskiy
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-16 15:18 UTC by Daniel Smolik
Modified: 2008-10-17 21:44 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.16-rc6
Tree: Mainline
Regression: ---


Attachments

Description Daniel Smolik 2006-03-16 15:18:44 UTC
Most recent kernel where this bug did not occur:2.6.15.6
Distribution: Debian Sarge
Hardware Environment:Thinkpad A21m
Software Environment:2.6.16-rc6
Problem Description: I can sleep and resume my notebook one time. If I try sleep
a second time thinkpad freeze after Stoping tasks ..... With 2.6.15.6 all work OK.

Steps to reproduce:
Compile 2.6.16-rc6 and press lid switch two times
Comment 1 Luming Yu 2006-03-16 17:35:55 UTC
Is it related to bug# 5989.
Please try unload thermal, processor module before suspend.
Comment 2 Daniel Smolik 2006-03-16 23:57:38 UTC
Thanks, this helps. But if I after suspend/resume try poweroff notebook sometime
didn't poweroff. Kernel print Shutdown hda: and system freeze.
Thank for your help.
Comment 3 Luming Yu 2006-03-20 18:46:11 UTC
Please drill down to the place the system is freeze.
Comment 4 Daniel Smolik 2006-03-20 22:23:42 UTC
I have new info to this. Problem is snd-cs46xx related. This diver after suspend
and resume stop working. If I reload module  sound start working but if I do
this often and  reboot system freeze in shutdown after 
Shutdown hda:

I report this bug to ALSA.

Dan
Comment 5 Len Brown 2006-03-22 18:55:43 UTC
Please confirm that I undestand the problems(s) here:
1. suspend to ram, resume from ram, system freezes on resume
   this problem goes away if you first unload the thermal module.
   this is a known bug 5989

2. once thermal is out of the way...
   suspend to ram, resume from ram, shutdown
   but shutdown does not poweroff the system.

3. sound does not come back after suspend/resume from RAM
   (comment #4) this is being filed with the ALSA guys.

If true, lets focus on problem #2, the poweroff problem.
Is poweroff reliable if you do NOT suspend/resume,
and it is intermittant only AFTER a suspend/resume?

Comment 6 Daniel Smolik 2006-03-22 22:57:05 UTC
ad 1) I don't use thermal module now, yes
ad 3) I try modify cs46xx driver and found if I reinitialize dsp sound start working

ad 2) I think that problem is cs46xx related If I don't load cs46xx module and
susp/ resume poweroff working but this is not 100% but it is much better then
sound module loaded. I must investigate.

Comment 7 Daniel Smolik 2006-04-19 08:14:42 UTC
I will test 2.6.17rc and drop an info.
Comment 8 Luming Yu 2006-08-03 18:01:42 UTC
please test patch at http://bugzilla.kernel.org/show_bug.cgi?id=6749#c8

*** This bug has been marked as a duplicate of 6749 ***
Comment 9 Daniel Smolik 2006-08-04 00:02:55 UTC
Yes I test this patch an it works. My comments are  in bug 6749.
Thanks Dan.

Note You need to log in before you can comment on or make changes to this bug.