Bug 6214 - USB Media (usb storage weird error)
USB Media (usb storage weird error)
Status: REJECTED DUPLICATE of bug 6489
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 high
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2006-03-11 08:24 UTC by David
Modified: 2006-08-30 01:19 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.15
Tree: Mainline
Regression: ---


Attachments
dmesg output (doing modprobe ohci_hcd, etc..) (134.90 KB, text/plain)
2006-03-28 16:26 UTC, David
Details

Description David 2006-03-11 08:24:16 UTC
Kernel: 2.6.15-r7
Dist: gentoo 2006.0

I get the error: 
usb 1-6: new high speed USB device using ehci_hcd and address 6
usb 1-6: unable to read config index 0 descriptor/start
usb 1-6: can't read configurations, error -75
usb 1-6: new high speed USB device using ehci_hcd and address 7
usb 1-6: unable to read config index 0 descriptor/start
usb 1-6: can't read configurations, error -75
usb 1-6: new high speed USB device using ehci_hcd and address 8
usb 1-6: device descriptor read/all, error -75
usb 1-6: new high speed USB device using ehci_hcd and address 9
usb 1-6: device descriptor read/all, error -75
If I connect my Airis 40 GB MP3 Usb into my computer.
This worked before with same config (I only installed kde) and now I get this
error..

If this is not a bug.. what tries to tell this error (in english)? 'Cause
neither I know what is -75 neither I know what is this error about.. (it doesn't
make much sense..)

Thanks.
Comment 1 Greg Kroah-Hartman 2006-03-11 14:05:30 UTC
Can you test 2.6.16-rc5 please?  This should be fixed there, but if not,
we really need to know.
Comment 2 Alan Stern 2006-03-11 17:40:32 UTC
Here's an explanation of those error messages:

-75 is the numeric code for -EOVERFLOW, which means the device sent more data
than the computer asked for.

"unable to read config index 0 descriptor/start" means that the -EOVERFLOW error
occurred while the computer was trying to read the device's first configuration
descriptor.  This happened twice because the computer retries after a failure.

Then the computer switched to a different strategy.  "device descriptor
read/all" means that the -EOVERFLOW error occurred while the computer was trying
the read the device's device descriptor.  This also happened twice and then the
computer gave up.

I can't think of any reason why installing KDE should cause these errors to
suddenly start happening.
Comment 3 David 2006-03-11 22:42:45 UTC
Two things:

First: how can I get 2.6.16-r5? (I downloaded latest and aplied patch and
results in an compilation error)

Second: (recomendation): COuld the error messages be more explicit? (explain
better the problem instead of just -75 for example?)

Thanks..

P.D. If I could get that version of kernel I could try the device and report..
(isn't a full version download prepaired?)
Comment 4 Alan Stern 2006-03-12 07:24:53 UTC
First:  http://www.kernel.org/pub/linux/kernel/v2.6/testing/linux-2.6.16-rc5.tar.bz2
Note also that 2.6.16-rc6 is out now.

Second: Error messages could be more explicit.  But there are thousands of error
messages in the kernel; making them all more explicit would add a tremendous
amount of bloat, with no benefit at all to the vast majority of people who never
get those errors.
Comment 5 David 2006-03-27 16:06:03 UTC
I have tested it with 2.6.16 and I get exactly same error.

uname -a:
Linux StormByte 2.6.16-gentoo #1 SMP Tue Mar 28 01:54:43 CEST 2006 x86_64 AMD
Athlon(tm) 64 X2 Dual Core Processor 3800+ AuthenticAMD GNU/Linux

If you need more info, just reply and tell me how to get that info (I am not
much advance user) and I will post it.

Thank you.

P.D. I wonder why it worked once and why not now (and wich features are involved
in this issue).

Thaks again.
Comment 6 Alan Stern 2006-03-28 09:00:00 UTC
Maybe the device will work okay at full speed instead of high speed if you rmmod ehci-hcd.

It might also be interesting to try booting in single-user mode, so that none of the KDE programs are 
running when you plug in the device.  Does that make any difference?

P.S.: I also wonder why it stopped working.  Could it be that your device suddenly broke?  Have you tried 
plugging it into other computers?
Comment 7 David 2006-03-28 16:26:33 UTC
Created attachment 7695 [details]
dmesg output (doing modprobe ohci_hcd, etc..)

This is whole output of my probes (first don't detect correctly device and
after, finally all is working good) (but isn't the output a bit extrange?)
Comment 8 David 2006-03-28 16:30:41 UTC
I fixed it with linux--gentoo-r7.

I had usb-storage, ohci_hcd, uhci_hcd and ehci_hcd builtin in kernel (and it
didn't work). Now I changed this config as a modules (all mentioned before).

If modprobing ehci_hcd and usb-storage it works well with the dmesg output (very
large) wich is posted above as attachment.

Could this be a bug? (not working when builtin)?

If need more info, reply this.

Thanks again!
Comment 9 Petri Kivim 2006-05-08 05:11:16 UTC
In attached dmesg output ehci_hcd is first loaded and mass storage device
connected which results in:
usb 1-6: new high speed USB device using ehci_hcd and address 2
usb 1-6: unable to read config index 0 descriptor/all
usb 1-6: can't read configurations, error -75

Then when ehci_hcd is unloaded and ohci_hcd loaded instead:
usb 1-6: new full speed USB device using ohci_hcd and address 2
usb-storage: USB Mass Storage device detected

And everything is working but it's ohci_hcd which is naturally very slow as USB
2.0 is not used. This is a problem with ehci_hcd and mass storage devices, I
have the same problem with my ipod, using 2.6.15.
Comment 10 Petri Kivim 2006-05-08 05:20:41 UTC
It seems that this is very related to Bug 6489 if not even a duplicate.
Comment 11 Greg Kroah-Hartman 2006-08-30 01:19:18 UTC

*** This bug has been marked as a duplicate of 6489 ***

Note You need to log in before you can comment on or make changes to this bug.