Bug 6195 - USB sound does not work with ALSA, works okay with OSS
Summary: USB sound does not work with ALSA, works okay with OSS
Status: REJECTED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks: USB
  Show dependency tree
 
Reported: 2006-03-08 15:05 UTC by Pavel Machek
Modified: 2007-01-31 05:24 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.16-rc5
Tree: Mainline
Regression: ---


Attachments

Description Pavel Machek 2006-03-08 15:05:51 UTC
With ALSA, I can't get sound from USB speakers, nor can I get meaningful sound
from wireless USB dongle. (Plus I get oops on unplug, but that's separate bug).

mpg123 seems to work but produces no sound on ALSA. On OSS, it says

pavel@amd:/data/big/READ-ONLY/mp3.other/weird$ mpg123 mbrola/xmass.mp3
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layer 1, 2, and 3.
Version 0.59q (2002/03/23). Written and copyrights by Joe Drew.
Uses code from various people. See 'README' for more!
THIS SOFTWARE COMES WITH ABSOLUTELY NO WARRANTY! USE AT YOUR OWN RISK!

Directory: mbrola/
Playing MPEG stream from xmass.mp3 ...
MPEG 1.0 layer III, 128 kbit/s, 44100 Hz joint-stereo
libao - OSS cannot set rate to 44100
Can't find a suitable libao driver. (Is device in use?)
pavel@amd:/data/big/READ-ONLY/mp3.other/weird$

...probably because USB wireless dongle only supports 48kHz. Is it possible that
ALSA fails to return error somewhere? I do not think we resample in kernel.

xmms plays audio just fine on OSS. Have not yet tested it with ALSA.
Comment 1 Pavel Machek 2006-03-08 15:23:04 UTC
Okay, so with ALSA mpg123 pretends it is playing (like below), but nothing can
be heard. ALSA with xmms works.

pavel@amd:/data/big/READ-ONLY/mp3.other/weird$ mpg123 -D/dev/dsp1 mbrola/xmass.mp3
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layer 1, 2, and 3.
Version 0.59q (2002/03/23). Written and copyrights by Joe Drew.
Uses code from various people. See 'README' for more!
THIS SOFTWARE COMES WITH ABSOLUTELY NO WARRANTY! USE AT YOUR OWN RISK!

Directory: mbrola/
Playing MPEG stream from xmass.mp3 ...
MPEG 1.0 layer III, 128 kbit/s, 44100 Hz joint-stereo

[0:01] Decoding of xmass.mp3 finished.
pavel@amd:/data/big/READ-ONLY/mp3.other/weird$
Comment 2 Pavel Machek 2006-03-08 15:37:31 UTC
Heh, spoke too soon. xmms with ALSA works -- with USB wireless, but not with USB
speakers. Perhaps it is because USB speakers advertise 44100 and 48000?
Comment 3 Andrew Morton 2007-01-31 00:02:57 UTC
Pavel, is this bug still happening?

If so, you should be bugging people ;)
Comment 4 Pavel Machek 2007-01-31 05:24:36 UTC
I do not have that hardware any more :-(. I'll try to debug the other usb audio
problem -- bug #6576.

Note You need to log in before you can comment on or make changes to this bug.