Bug 6151 - The ASLTS test b129 falls into an infinitive loop in a 32-bit slack mode
The ASLTS test b129 falls into an infinitive loop in a 32-bit slack mode
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: ACPICA-Core
i386 Linux
: P2 high
Assigned To: Robert Moore
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-02 07:08 UTC by Valery A Podrezov
Modified: 2006-09-28 13:13 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6
Tree: Mainline
Regression: ---


Attachments
AML code to reproduce bug (infinite loop) (16.54 KB, application/octet-stream)
2006-03-02 07:26 UTC, Valery A Podrezov
Details
Proposed patch (1008 bytes, patch)
2006-03-02 07:33 UTC, Valery A Podrezov
Details | Diff

Description Valery A Podrezov 2006-03-02 07:08:26 UTC
Most recent kernel where this bug did not occur:
Distribution:
Hardware Environment:
Software Environment:
Problem Description:

The Linux kernel ACPI interpreter fails the following
AML test when it is compiled into a simulator. So if an
OEM BIOS includes this code, Linux would fail.

Steps to reproduce:

Run interpreter with the attached b129.aml AML code test of ASLTS.
Comment 1 Valery A Podrezov 2006-03-02 07:26:41 UTC
Created attachment 7497 [details]
AML code to reproduce bug (infinite loop)

AML code of ASLTS test b129 to reproduce bug (infinite loop).
Comment 2 Valery A Podrezov 2006-03-02 07:33:25 UTC
Created attachment 7498 [details]
Proposed patch


The ASLTS testing in a slack mode is blocked because
of this bug - the ACPICA AML Interpreter falls into an
infinitive loop on b129 test attached.

The root cause (similar to 6028) is an invalid
non-zero value of some pointer in FAILURE case.

The patch sets that pointer to NULL in FAILURE case.

INTERNAL BUG NUMBER

   202
Comment 3 Robert Moore 2006-03-10 12:36:30 UTC
Patch integrated into version 20060310

Comment 4 Len Brown 2006-06-25 21:55:35 UTC
ACPICA 20060608 shipped in Linux-2.6.17-git9, closed. 

Note You need to log in before you can comment on or make changes to this bug.