Bug 61231 - Backlight off (set to lowest level) on boot
Summary: Backlight off (set to lowest level) on boot
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Video (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Aaron Lu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-12 10:01 UTC by erno
Modified: 2013-11-15 06:11 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.11
Tree: Mainline
Regression: No


Attachments
Lenovo Ideapad Z510 acpidump (320.72 KB, text/plain)
2013-10-30 15:56 UTC, Shuduo Sang
Details
Patches to quirk initial backlight level 0 problem (1.19 KB, application/x-bzip)
2013-10-31 01:57 UTC, Aaron Lu
Details

Description erno 2013-09-12 10:01:02 UTC
The hardware is Acer Aspire V5-573G with Intel (Haswell) video + Nvidia GPU. I can increase brightness normally with the keyboard fn + arrow keys.

Happened on the stock kernel from Ubuntu 13.10 Beta and the latest mainline kernel from ubuntu kernel-ppa: linux-image-3.11.0-999.
-generic_3.11.0-999.201309110406_amd64.deb

The brightness levels show up correctly under /sys/class/backlight/acpi_video0
and respond to the brightness controls so it's using the acpi video driver.

Another using reporting same problem: http://www.linuxquestions.org/questions/linux-newbie-8/black-screen-when-trying-to-install-linux-on-acer-aspire-v5-573g-4175472954/
Comment 1 erno 2013-09-12 11:14:26 UTC

*** This bug has been marked as a duplicate of bug 60682 ***
Comment 2 Christopher M. Penalver 2013-09-13 10:42:18 UTC
erno, this wouldn't be a duplicate of 60682. As well, 60682 is a "catch all" trash bug that wouldn't be efficient in getting any problem solved. If you have the permissions, you would want to unmark the duplication, and continue to work downstream at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1224415 .
Comment 3 Felipe Contreras 2013-10-03 17:10:58 UTC
While blacklisting this machine (bug #60682) would solve the problem, that is a temporary solution. Eventually all these machines would use the Intel backlight driver, so this problem would happen again.

Either way, other people that don't have their machine blacklisted would still have this problem. So I suggest keeping this bug open for the Intel driver.
Comment 4 erno 2013-10-03 18:03:48 UTC
Ok, seems I bugzilla lets me reopen this.
Comment 5 Aaron Lu 2013-10-14 08:53:59 UTC
Please show:
$ ls /sys/class/backlight

And if there is intel_backlight, does it work?
Comment 6 Aaron Lu 2013-10-24 07:04:00 UTC
Please also attach acpidump, thanks.
Comment 7 Shuduo Sang 2013-10-30 15:44:53 UTC
Lenovo Ideapad Z510 has same issue
Comment 8 Shuduo Sang 2013-10-30 15:56:28 UTC
Created attachment 112811 [details]
Lenovo Ideapad Z510 acpidump
Comment 9 Aaron Lu 2013-10-31 00:34:56 UTC
Hi Shuduo,

Your laptop is a win8 system, so can you please try Rafael's linux-next branch?
http://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git linux-next
And please add video.use_native_backlight=1 when testing that tree, thanks.
Comment 10 Aaron Lu 2013-10-31 01:57:12 UTC
Created attachment 112871 [details]
Patches to quirk initial backlight level 0 problem

Here are two patches, please apply on top of Rafael's linux-next branch:
http://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git linux-next
And see if it helps, thanks.
Comment 11 Aaron Lu 2013-11-05 04:28:46 UTC
Ping, please test patches mentioned in comment #10, ignore comment #9.
Comment 12 erno 2013-11-05 17:24:46 UTC
It works, screen is set to max brightness on boot now. Thanks!
Comment 13 Aaron Lu 2013-11-15 06:11:57 UTC
commit 2c62333a408f5badd2d2ffd7177f95deeccc5ca4
Author: Aaron Lu <aaron.lu@intel.com>
Date:   Wed Nov 6 09:07:10 2013 +0800

    ACPI / video: Quirk initial backlight level 0

Entered Linus' tree.

Note You need to log in before you can comment on or make changes to this bug.