Bug 6099 - 2 times IO slowdown in APIC enabled mode
Summary: 2 times IO slowdown in APIC enabled mode
Status: CLOSED DUPLICATE of bug 3927
Alias: None
Product: ACPI
Classification: Unclassified
Component: Config-Other (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: acpi_config-other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-18 11:41 UTC by Eugene Seppel
Modified: 2008-01-10 19:58 UTC (History)
0 users

See Also:
Kernel Version: 2.6.16-rc4
Tree: Mainline
Regression: ---


Attachments
Kernel .config (8.35 KB, application/gzip)
2006-02-18 11:42 UTC, Eugene Seppel
Details
kernel dmesg for this situation (4.25 KB, application/gzip)
2006-02-18 11:43 UTC, Eugene Seppel
Details
/proc/interrupts (482 bytes, text/plain)
2006-02-18 11:44 UTC, Eugene Seppel
Details

Description Eugene Seppel 2006-02-18 11:41:50 UTC
Hardware Environment: AMD64, ATI Xpress 200 chipset (Motherboard MS482M4-L)
Software Environment:Linux 2.6.16-rc4, 32 bit

Problem Description:
When ACPI, APIC, Local APIC are enabled in kernel, 2 times Network slowdown
occured. (for example, 80Kb internet connection via 100 Mb NIC, produces only 40
Kb download speed.
Comment 1 Eugene Seppel 2006-02-18 11:42:53 UTC
Created attachment 7400 [details]
Kernel .config

This is my kernel configuration
Comment 2 Eugene Seppel 2006-02-18 11:43:38 UTC
Created attachment 7401 [details]
kernel dmesg for this situation
Comment 3 Eugene Seppel 2006-02-18 11:44:08 UTC
Created attachment 7402 [details]
/proc/interrupts
Comment 4 Shaohua 2006-02-20 18:09:34 UTC
Please check if timer interrupt runs double speed in APIC mode.
you can do:
cat /proc/interrupts; sleep 1; cat /proc/interrupts
and see the timer interrupt difference between this period.
Comment 5 Eugene Seppel 2006-02-21 04:50:35 UTC
On Intel P4 with HT the timer interrupt difference equals 101. (This PC works
good in APIC mode, kernel 2.4.26-std-smp-alt13 (From ALTLinux))
On Intel P3 it equals 101 too (This PC works good, without APIC, kernel ~2.2.20)

Today I can't access to that AMD64 PC with troubles.
What should I do if the timer interrupt difference equals 50?

Thank you!
Comment 6 Shaohua 2006-02-22 18:29:09 UTC
Yes, you can look at:
http://bugzilla.kernel.org/show_bug.cgi?id=3927
Comment 7 Fu Michael 2007-11-07 00:30:20 UTC
this is clearly a dup of bug# 3927..

*** This bug has been marked as a duplicate of bug 3927 ***

Note You need to log in before you can comment on or make changes to this bug.