Bug 60881 - Dell XPS 13 (L322X) display does not work anymore with kernel 3.10
Dell XPS 13 (L322X) display does not work anymore with kernel 3.10
Status: RESOLVED DUPLICATE of bug 59841
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 high
Assigned To: intel-gfx-bugs@lists.freedesktop.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-07 11:38 UTC by Dennis Jacobfeuerborn
Modified: 2013-09-10 06:58 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.10
Tree: Fedora
Regression: Yes


Attachments
xrandr --verbose output (3.85 KB, text/plain)
2013-09-09 11:44 UTC, Dennis Jacobfeuerborn
Details
lspci output for vga device (379 bytes, text/plain)
2013-09-09 11:45 UTC, Dennis Jacobfeuerborn
Details
boot log with drm.debug=0xe (189.00 KB, text/plain)
2013-09-09 11:45 UTC, Dennis Jacobfeuerborn
Details
Load Legacy Option ROM => disabled (8.00 KB, application/octet-stream)
2013-09-09 13:22 UTC, Dennis Jacobfeuerborn
Details
Load Legacy Option ROM => enabled (8.00 KB, application/octet-stream)
2013-09-09 13:23 UTC, Dennis Jacobfeuerborn
Details

Description Dennis Jacobfeuerborn 2013-09-07 11:38:28 UTC
I updated my Dell XPS 13 (aka "Sputnik") and after the reboot I only got a completely garbled display as if the display frequency isn't right for the monitor.
Once I boot into the previous 3.9 kernel things start working again as expected. It seems the driver got broken in kernel 3.10.

When started with the "nomodeset" kernel option the display is no longer distorted but X doesn't start anymore but that might be related to Fedora 19 not handling the non-KMS fallback case well (Xorg aborts with no usable screen configuration).
Comment 1 Daniel Vetter 2013-09-09 08:11:14 UTC
We need a big pile of infomartion here first:
- What's "the monitor"? xrandr --verbose output from a working kernel is the best to get all info.
- Screenshot (with a camera or so) of the corruptions would be useful.
- Please boot the broken kernel with drm.debug=0xe and then grab the dmesg from the logfiles after rebooting (or ssh into the machine if you can).

Also properly marking as a regression.
Comment 2 Dennis Jacobfeuerborn 2013-09-09 11:44:46 UTC
Created attachment 107821 [details]
xrandr --verbose output
Comment 3 Dennis Jacobfeuerborn 2013-09-09 11:45:20 UTC
Created attachment 107831 [details]
lspci output for vga device
Comment 4 Dennis Jacobfeuerborn 2013-09-09 11:45:49 UTC
Created attachment 107841 [details]
boot log with drm.debug=0xe
Comment 5 Dennis Jacobfeuerborn 2013-09-09 11:48:02 UTC
On fedora-devel somebody pointed me to this bug which might be what I'm seeing:
https://bugzilla.kernel.org/show_bug.cgi?id=59841

The patches in this bug don't seem to have made it into any release yet though.
Comment 6 Jani Nikula 2013-09-09 11:49:21 UTC
Dell XPS13 eDP broken at 3.10, dithering 24->18 bpp, smells like dupe of bug 59841.

Do you use UEFI boot? Can you check if enabling CSM in the BIOS helps?
Comment 7 Dennis Jacobfeuerborn 2013-09-09 12:16:09 UTC
Looks like it. I enabled "Load Legacy Option ROM" (which I assume is CSM) and I can indeed boot the latest 3.10 Kernel normally.
Comment 8 Jani Nikula 2013-09-09 12:26:04 UTC
Interesting. Please attach /sys/kernel/debug/dri/0/i915_opregion for non-working and working setting of the BIOS option. Thanks.
Comment 9 Dennis Jacobfeuerborn 2013-09-09 13:22:51 UTC
Created attachment 107871 [details]
Load Legacy Option ROM => disabled
Comment 10 Dennis Jacobfeuerborn 2013-09-09 13:23:12 UTC
Created attachment 107881 [details]
Load Legacy Option ROM => enabled
Comment 11 Jani Nikula 2013-09-10 06:58:04 UTC
Duplicate. We are still trying to figure out the least ugly fix that doesn't break other machines. In the mean time, the workarounds are using legacy boot or patching your kernel. Thanks for the report.

*** This bug has been marked as a duplicate of bug 59841 ***

Note You need to log in before you can comment on or make changes to this bug.