Bug 6077 - Badness in send_IPI_mask_bitmask at arch/i386/kernel/smp.c:167
Badness in send_IPI_mask_bitmask at arch/i386/kernel/smp.c:167
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Other
Classification: Unclassified
Component: Other
i386 Linux
: P2 normal
Assigned To: other_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-15 06:54 UTC by Glenn Matthys
Modified: 2006-02-27 23:00 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.15.4
Tree: Mainline
Regression: ---


Attachments

Description Glenn Matthys 2006-02-15 06:54:13 UTC
Most recent kernel where this bug did not occur: 2.6.11.7
Distribution: CRUX

The computer is a:

Compaq DL 360
Dual P-III 1266 Mhz
512 MB SDRAM PC133 ECC
You can find a full dmesg here:
http://users.opengate.be/~glenn/smpcompaq/dmesg.txt

Upon "halt", after the rc scripts finish, the kernel seems to crash with this
message:
Badness in send_IPI_mask_bitmask at arch/i386/kernel/smp.c:167
Here's a screenshot of this:
http://users.opengate.be/~glenn/smpcompaq/dsc00268.jpg

This does not happen upon reboot.

If you want more information don't hesitate to contact me.

Glenn
Comment 1 Glenn Matthys 2006-02-15 06:56:32 UTC
You can find my kernel configuration here:

http://users.opengate.be/~glenn/kernconf/foo-2.6.15.4/kernconf-foo-2.6.15.4-1
Comment 2 Ashok Raj 2006-02-15 14:13:01 UTC
Could you check if you can start with no_broadcast=1 boot arg and see if it 
repeats itself?
Comment 3 Ashok Raj 2006-02-15 15:40:47 UTC
Looks like this got fixed after 2.6.15... 

http://marc.theaimsgroup.com/?l=linux-kernel&m=113314507315388&w=2

Could you try this patch instead.
Comment 4 Adrian Bunk 2006-02-27 15:54:57 UTC
This issue should already be fixed.

Please reopen this bug if it's still present in kernel 2.6.16-rc5.
Comment 5 Eric W. Biederman 2006-02-27 23:00:21 UTC
You can remove the -p option to halt to avoid this problem in earlier kernels.

Note You need to log in before you can comment on or make changes to this bug.