Bug 60767 - Support for rfkill on Fujitsu-Siemens Amilo L1310
Support for rfkill on Fujitsu-Siemens Amilo L1310
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Platform_x86
i386 Linux
: P1 normal
Assigned To: drivers_platform_x86@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 11:18 UTC by Jerome Meinke
Modified: 2013-09-04 13:29 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.10.7
Tree: Mainline
Regression: No


Attachments
Suggested patch (1.17 KB, patch)
2013-08-19 15:19 UTC, Jerome Meinke
Details | Diff

Description Jerome Meinke 2013-08-19 11:18:22 UTC
Problem:
"The FSC Amilo A1655G uses only software switch to turn the radio on/off." is stated on http://www.marvec.org/amilo/.

I own an Amilo L1310, which uses the same method. This Amilo L1310 notebook is listed on the website Martin Večeřa who wrote the fsaa1655g driver, BUT in the amilo-rfkill.c from Ben Hutchings, which enables support for rfkill on AMILO A1655 and AMILO M7440 and which is based on the information from Martin Večeřa, the L1310 is not included.

This leads to the radio on/off not working on the Amilo L1310, which is sad because linux just needs to allow to activating the module "amilo-rfkill" on the notebooks board. 

Solution:
Extend the amilo_rfkill_id_table[] with correct DMI_BOARD_NAME information.
Comment 1 Jerome Meinke 2013-08-19 15:19:58 UTC
Created attachment 107244 [details]
Suggested patch

If have submitted the attached patch to Matthew Garrett <matthew.garrett@nebula.com>.
Comment 2 Jerome Meinke 2013-09-04 13:29:20 UTC
Patch has been applied.

Note You need to log in before you can comment on or make changes to this bug.