Bug 60635 - Macbook Air 2013 boot stuck at smpboot: Booting Node 0, Processors #1
Macbook Air 2013 boot stuck at smpboot: Booting Node 0, Processors #1
Status: RESOLVED WILL_NOT_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
x86-64 Linux
: P1 blocking
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 22:44 UTC by x.gnata
Modified: 2014-02-15 22:43 UTC (History)
8 users (show)

See Also:
Kernel Version: At least 3.9.11, 3.10.2 and 3.11-rc2
Tree: Mainline
Regression: No


Attachments
dmesg output for succesful boot (64.02 KB, text/plain)
2013-08-11 22:27 UTC, sam.attwell
Details
signature.asc (199 bytes, application/pgp-signature)
2013-08-23 20:11 UTC, Miek Gieben
Details

Description x.gnata 2013-07-26 22:44:19 UTC
The boot on a Macbook Air 2013 (Haswell) is stuck after 
"smpboot: Booting Node 0, Processors #1"
After "smpboot: Booting Node 0, Processors #1", there is no error message but only a blinking cursor forever.

See https://launchpadlibrarian.net/145295798/3.11-rc1_boot_stuck.jpg
and
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1197451 for more details and the config files of this plateform.

With acpi=off, it crahses like this:
https://launchpadlibrarian.net/144944282/IMG_20130714_234357.jpg

What else could help to figure out where the bug comes from?

Xavier
Comment 1 Aaron Lu 2013-07-29 01:44:55 UTC
Perhaps x86_64 guys know better.
Comment 2 sam.attwell 2013-08-11 22:27:35 UTC
Created attachment 107179 [details]
dmesg output for succesful boot

Hi there,

I have a MacBook Air 6,2 that also experiences this problem.

Intel Core i7-4650U 1.7Ghz
8GB RAM
128GB SSD
Running 3.11.0-rc4

Appending nosmp allows successful boot.

Dmesg is attached.

I can also post output from fwts if necessary.
Comment 3 x.gnata 2013-08-16 12:48:10 UTC
Some more debug info with 3.11-rc5 without anyboot options like nosmp or acpi=off.
I have replaced all the pr_debug by pr_info in ./arch/x86/kernel/smpboot.c

I get this :
NMI watchdog: Disabled lockup detectors by default for full dynticks
NMI watchdog: you can reactivate it with 'sysctl -w kernel.watchdog=1'
smpboot: ++++++++++++++++++++=_---CPU UP 1
smpboot: smpboot: Booting Node 0, Processors #1"
smpboot: Setting warm reset code and vector.
smpboot: Assering INIT
smpboot: Waiting for send to finish 

and the machine is stuck forever with the cursor blinking.
Comment 4 Miek Gieben 2013-08-21 14:21:12 UTC
3.11-rc6 still does not boot without nosmp
Comment 5 H. Peter Anvin 2013-08-21 14:25:21 UTC
Has this ever worked?  If so a bisect would be most helpful.

bugzilla-daemon@bugzilla.kernel.org wrote:
>https://bugzilla.kernel.org/show_bug.cgi?id=60635
>
>--- Comment #4 from Miek Gieben <miek@miek.nl> ---
>3.11-rc6 still does not boot without nosmp
Comment 6 Miek Gieben 2013-08-21 15:21:00 UTC
The default ubuntu 13.04 install also needed this, so is at least happening since 3.8.0 (+ unknown ubuntu patches)
Comment 7 Miek Gieben 2013-08-21 23:45:21 UTC
I did some additional testing:

Kernels from: http://kernel.ubuntu.com/~kernel-ppa/mainline/

  Version      smp   nosmp
  --------- ------ -------
  3.8.13      hang       ?
  3.7.10      hang       ?
  3.6.11      hang       ?

I stopped there, the all hang with the symptom describe in this bug report.
Comment 8 Sean V Kelley 2013-08-22 04:48:54 UTC

On Fedora 19, using their current kernel on my MacBook Air 6,2:

seanvk@prairie ~$ cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-3.10.7-200.fc19.x86_64 root=UUID=20b0ee04-7a6e-4e24-8fe5-55185347f43d ro rootflags=subvol=root rd.md=0 rd.lvm=0 rd.dm=0 vconsole.keymap=us rd.luks=0 vconsole.font=latarcyrheb-sun16 rhgb quiet libata.force=1:noncg LANG=en_US.UTF-8

seanvk@prairie ~$ uname -a -m
Linux prairie 3.10.7-200.fc19.x86_64 #1 SMP Thu Aug 15 23:19:45 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I have also successfully booted 3.11-rc3, but I do grab a generated config file from rawhide as my starting point when working with 3.11.  Regardless, I don't see the issue with nosmp.  

I have a separate bug filed on fdo relating to suspend/resume backlight issues.  For reference on that bugzilla is:

https://bugs.freedesktop.org/show_bug.cgi?id=67454

Current issues for me relate primarily to backlight issues in above bugzilla and of course wl-6xx-kmod and broadcom-wl-6xx which I build locally but will hopefully get added to rpmfusion eventually.

Sean
Comment 9 Miek Gieben 2013-08-22 04:54:13 UTC
Note this MBA is a 6,1

% sudo dmidecode -s system-product-name
MacBookAir6,1
Comment 10 x.gnata 2013-08-22 07:59:25 UTC
"Macbook Air 2013 (Haswell)" is too vague, my mistake:

The boot sequence fails on mac books air 11" equiped with Intel(R) Core(TM) i5-4250U CPU @ 1.30GHz. The only way to boot on these machines is to use nosmp.

It looks like it works on 13" and/or i7 mac books air but is does not help a lot.

It does not work on 3.9.11 *vanilla*. I can test with older vanilla kernel if it helps.
Comment 11 Miek Gieben 2013-08-22 19:21:08 UTC
What can we do further to debug this, so it can be fixed?
Comment 12 Sean V Kelley 2013-08-23 19:31:01 UTC
(In reply to Miek Gieben from comment #11)
> What can we do further to debug this, so it can be fixed?

Miek,

Are you using Ubuntu 13.04/13.10 in your testing?

Are you using reFIND for the loader?

Could you humor me and simply boot a Fedora 19 ISO from a USB stick?  Do not modify the kernel cmd line.  Simply run the live image.

Sean
Comment 13 Sean V Kelley 2013-08-23 19:32:48 UTC
(In reply to x.gnata from comment #10)
> "Macbook Air 2013 (Haswell)" is too vague, my mistake:
> 
> The boot sequence fails on mac books air 11" equiped with Intel(R) Core(TM)
> i5-4250U CPU @ 1.30GHz. The only way to boot on these machines is to use
> nosmp.
> 
> It looks like it works on 13" and/or i7 mac books air but is does not help a
> lot.
> 
> It does not work on 3.9.11 *vanilla*. I can test with older vanilla kernel
> if it helps.

Please test with 3.11 rc 6 and attach your config file to this bugzilla.

Thanks,

Sean
Comment 14 Miek Gieben 2013-08-23 20:11:38 UTC
Created attachment 107295 [details]
signature.asc

[ Quoting <bugzilla-daemon@bugzilla.> in "[Bug 60635] Macbook Air 2013 boot s..." ]
> https://bugzilla.kernel.org/show_bug.cgi?id=60635
> 
> --- Comment #12 from Sean V Kelley <seanvk@ortracks.org> ---
> (In reply to Miek Gieben from comment #11)
> > What can we do further to debug this, so it can be fixed?
> 
> Miek,
> 
> Are you using Ubuntu 13.04/13.10 in your testing?

Yes, 13.10, but I'm running 3.11-rc6 (with nosmp) linus-tree kernel atm.

> Are you using reFIND for the loader?

Not, I'm holding the alt-key during boot, and select the Windows disk ->
grub from there.

> Could you humor me and simply boot a Fedora 19 ISO from a USB stick?  Do not
> modify the kernel cmd line.  Simply run the live image.

Ack will do and will report back.
Comment 15 Miek Gieben 2013-08-24 02:05:50 UTC
Took fedora xfce spin as that fitted on the USB disk I had handy. The system boots (see *all* CPU) and runs with kernel 3.9.5-301. However I failed to reach X, and my suspicion is that I was trapped in the initrd of systemd (if such a thing exists).

So...is it related that not using UEFI when booting Ubuntu?
Comment 16 Miek Gieben 2013-08-24 02:55:51 UTC
Got to a fullblown X env, everything works, i.e. CPUs are detected and the disk is also OK. Network is not detected (expected) and the touchpad is also not correctly detected (also expected). I'm trying to see if I can get a newer kernel on it.
Comment 17 Miek Gieben 2013-08-24 03:39:08 UTC
ahhhh, converting Ubuntu to EFI boot makes it see *all* CPUs and boot!
Comment 18 Sean V Kelley 2013-08-24 03:53:35 UTC
(In reply to Miek Gieben from comment #15)
> Took fedora xfce spin as that fitted on the USB disk I had handy. The system
> boots (see *all* CPU) and runs with kernel 3.9.5-301. However I failed to
> reach X, and my suspicion is that I was trapped in the initrd of systemd (if
> such a thing exists).
> 
> So...is it related that not using UEFI when booting Ubuntu?

That's why I asked you to test.  I suspected it was something external to the kernel.  Now I don't pretend to understand much about UEFI.  But I did not see the error as a kernel bug per se.
Comment 19 x.gnata 2013-08-24 20:55:54 UTC
It's a bug in the Compatibility Support Module that emulates a BIOS environment.
EFI boot makes it see *all* CPUs and boot.

Therefore, there is little interest left in fixing this bug.
It should work with the emulated BIOS environment but I'm not sure if it make sense to invest resources in trying to fix it.

Everyone ok with "won't fix"?
Comment 20 sam.attwell 2013-08-26 10:57:16 UTC
Tested with EFI boot and confirmed. I agree with Xavier, boot seems far less problematic using EFI than the CSM. I'm ok with "won't fix".
Comment 21 oytuneren 2013-10-18 19:39:52 UTC
I got same problem but also worked with EFI.
Comment 22 Sorin Sbarnea 2013-11-22 10:44:45 UTC
I think that this problem should be fixed there is quite a big change for anyone that is installing linux on *any* Apple hardware to encounter this.

I can confirm that the same problem appears on Mac Mini 4,2 (mid2010) models.

Also, it's a problem that will prevent your system from booting, and in case of hosted servers it can be quite costly to workaround the issue.
Comment 23 manoj 2014-02-15 22:43:21 UTC
I have a Mac book Air 6,2.
I was trying to install Ubuntu12.04 but its getting stuck after(In reply to x.gnata from comment #0)
> The boot on a Macbook Air 2013 (Haswell) is stuck after 
> "smpboot: Booting Node 0, Processors #1"
> After "smpboot: Booting Node 0, Processors #1", there is no error message
> but only a blinking cursor forever.
> 
> See https://launchpadlibrarian.net/145295798/3.11-rc1_boot_stuck.jpg
> and
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1197451 for more
> details and the config files of this plateform.
> 
> With acpi=off, it crahses like this:
> https://launchpadlibrarian.net/144944282/IMG_20130714_234357.jpg
> 
> What else could help to figure out where the bug comes from?
> 
> Xavier

HI,
What is the solution for this?
I installed both rEFIT and rEFIND but still its stuck!!

Note You need to log in before you can comment on or make changes to this bug.