Bug 6063 - /proc/cpufreq and /sys/devices/system/cpu/cpu0/cpufreq don't exist
/proc/cpufreq and /sys/devices/system/cpu/cpu0/cpufreq don't exist
Status: REJECTED INSUFFICIENT_DATA
Product: ACPI
Classification: Unclassified
Component: Power-Processor
i386 Linux
: P2 high
Assigned To: acpi_power-processor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-12 16:26 UTC by jieryn
Modified: 2007-02-24 09:11 UTC (History)
2 users (show)

See Also:
Kernel Version: vanilla-2.6.15.1
Tree: Mainline
Regression: ---


Attachments
linux config-2.6.15.1 (22.57 KB, text/plain)
2006-02-12 16:28 UTC, jieryn
Details
dmesg (14.90 KB, text/plain)
2006-02-12 16:44 UTC, jieryn
Details
dmesg acpi=off (13.62 KB, text/plain)
2006-02-23 05:26 UTC, jieryn
Details
new kconfig (6.19 KB, application/octet-stream)
2006-02-23 05:27 UTC, jieryn
Details
config-2.6.17-rc1 (25.15 KB, text/plain)
2006-04-16 11:58 UTC, jieryn
Details
dmesg (13.96 KB, text/plain)
2006-04-16 11:58 UTC, jieryn
Details

Description jieryn 2006-02-12 16:26:20 UTC
Most recent kernel where this bug did not occur: unknown
Distribution:         gentoo
Hardware Environment: amd64
Software Environment: vanilla-sources-2.6.15.1
Problem Description:  none of the following exist:

/sys/devices/system/cpu/cpu0/cpufreq
/proc/cpufreq
/proc/sys/cpu/*/speed
/proc/sys/cpu/*/speed-min
/proc/sys/cpu/*/speed-max


Steps to reproduce:   compile 2.6.15.1 kernel and enable CONFIG_CPUFREQD
Comment 1 jieryn 2006-02-12 16:28:42 UTC
Created attachment 7302 [details]
linux config-2.6.15.1
Comment 2 Dave Jones 2006-02-12 16:35:58 UTC
please attach dmesg output.
Comment 3 jieryn 2006-02-12 16:44:04 UTC
Created attachment 7303 [details]
dmesg
Comment 4 Dave Jones 2006-02-12 17:55:06 UTC
I think this is related to ACPI changes to how _PSS objects are handled.
Reassigning for now.
Comment 5 Thomas Renninger 2006-02-22 22:24:05 UTC
Did you boot with acpi=off? 
Full dmesg would be helpful. Better try more recent kernel (best 2.6.16-rc2 or 
higher, a lot ACPI changes came in there). 
Comment 6 jieryn 2006-02-23 05:26:34 UTC
Created attachment 7454 [details]
dmesg acpi=off
Comment 7 jieryn 2006-02-23 05:27:15 UTC
Created attachment 7455 [details]
new kconfig
Comment 8 jieryn 2006-02-23 05:29:14 UTC
okay, i tried again with vanilla kernel 2.6.16-rc4 with and without acpi=off and
neither have worked.. :-/
Comment 9 Henrik Brix Andersen 2006-03-02 12:49:15 UTC
Downstream bug report: http://bugs.gentoo.org/121694
Comment 10 jieryn 2006-04-09 12:11:55 UTC
bump
Comment 11 jieryn 2006-04-16 11:58:14 UTC
Created attachment 7884 [details]
config-2.6.17-rc1
Comment 12 jieryn 2006-04-16 11:58:45 UTC
Created attachment 7885 [details]
dmesg
Comment 13 jieryn 2006-04-16 11:59:42 UTC
this problem is still happening... :-( i'm so desperate for a fix that i've even
tried to do my own analysis, but am stuck.. someone, please help? :-)
Comment 14 Zhang Rui 2006-12-25 00:10:53 UTC
Can you try recent kernels and make sure if the problem still exists?
Comment 15 Adrian Bunk 2007-02-24 09:11:55 UTC
Please reopen this bug if it's still present with kernel 2.6.20.

Note You need to log in before you can comment on or make changes to this bug.