Bug 60572 - USB Keyboard Stopped Working In 3.10x
Summary: USB Keyboard Stopped Working In 3.10x
Status: RESOLVED DUPLICATE of bug 60507
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-18 00:46 UTC by KernelBug
Modified: 2013-11-13 16:47 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.10
Tree: Mainline
Regression: No


Attachments
config-3.10.1 (87.35 KB, application/octet-stream)
2013-07-18 00:46 UTC, KernelBug
Details
config-3.10.2 (87.35 KB, application/octet-stream)
2013-07-24 22:43 UTC, KernelBug
Details
config-3.9.11 (86.14 KB, application/octet-stream)
2013-07-24 22:45 UTC, KernelBug
Details
lspci -v (7.69 KB, application/octet-stream)
2013-08-06 21:38 UTC, KernelBug
Details

Description KernelBug 2013-07-18 00:46:54 UTC
Created attachment 106914 [details]
config-3.10.1

Hi,

I'm running Slackware64 14.0 and I noticed when I used an older from config from 3.9x and ran make oldconfig and upgraded, for compiling a 3.10x kernel my USB keyboard no longer worked.


My computer is a HP Envy 17, model 17-j013cl and all the ports are USB 3.0 and I'm using a Logitech K360.

At present I'm using 3.9.9 which is working fine...

I'll attach the config I used for 3.10 and 3.10.1

At first I thought the new option; CONFIG_USB_DEFAULT_PERSIST: was causing the problem so I removed it, but it didn't help, with or without it, nothing works...


THANKS
Comment 1 KernelBug 2013-07-24 22:42:04 UTC
Hi,

Has anyone had a chance to look at this? I really want to start using 3.10x but I can't...

I also compiled 3.10.2 and the keyboard still won't work, yet it worked just fine in 3.9.11 and I don't get this...
Comment 2 KernelBug 2013-07-24 22:43:16 UTC
Created attachment 107011 [details]
config-3.10.2
Comment 3 KernelBug 2013-07-24 22:45:25 UTC
Created attachment 107012 [details]
config-3.9.11
Comment 4 KernelBug 2013-08-06 20:48:50 UTC
I'm sorry if I have not submitted enough information, I forgot to mention this is for USB 3.0 and I'm going to attach the output of lspci -v

I would greatly appreciate it if someone can get back to me and let me know if you need any other information...

I'm surprised that almost one month later I have not heard any word from anyone over this, we are talking about BROKEN hardware support and I would of thought someone would of jumped on this ASAP to get this going...

I'm running the latest generation hardware on a laptop and I need to run the latest kernels for support and right now the hardware support is a little flaky and I need to run 3.10x and I can't....

I really need some support and help here, and I would truly appreciate it if someone could PLEASE take a moment out of the day to give me some time here, I really need this and I'm trying to do my best as a end-user submitting reports to help....

I truly think this is a poor example of open source that needs to change, meaning when someone makes a report, than no later then ONE WEEK a devloper should give a reply to at least make the person feel like some attention has been brought to the matter...

Remember it's a TWO WAY STREET, end-users are helping you too by submitting reports, but sometimes people are stuck in a situation and possibly need some help right away....

I'm a Geek, I know the deal, but the deal should also be to give prompt repiles on all bug reports, 3-4 weeks later to me is getting blown off...

THANKS
Comment 5 KernelBug 2013-08-06 21:13:06 UTC
My last reply was not meant to be rude towards anyone, I'm just not happy to be here with broke hardware and I can't do what I need to do and in almost 15 years of using Linux, I've never had anything broke till now, so I'm a bit frustrated, especially when I need this now...

And as they say; 'You get what you pay for' and since I'm not paying for anything, this situation is also making me feel like this is how it's being treated, we'll get to you whenever...

And especially when hardware has been broken I've always been under the assumption anytime anything ever broke, that became PRIORITY #1 for the developers to jump on and fix it, so I'm really at a loss here, 5 kernel versions later and still broke hardware and no word from anyone to get this fixed...

And also in this 15 year time frame, I've submitted mass amounts of bug reports over the years to individual developers and they all have promptly replied, in fact developers are HAPPY you take the time to report bugs and help them...

I truly hope there are not mass amounts of other end-users with problems that need some attention and they too are left empty handed, wondering and waiting also with broke hardware...

Anyhow, I'm not here to get on anyone or be rude, like I said I know the deal and how opensource works, but that's also no excuse for not being courteous and considerate towards people and that's what I'm really talking about here, the FACT something is broke, the kernel developers are the only ones that can fix this, and in close to one month in a 24 hour day, no one has had 10 stinking minutes of time to look this over and just give a word back? I'm sorry I don't buy it and there's no excuses for it... 

Courteous and Considerate is NOT about you getting it for what you've paid for, it's just being respectful back...

I'd really LOVE Linus to see this, because I haven't seen much of the Linux geek mentality changed much in 15 years, hanging people out to dry...

And please don't think this is about some high-minded Prince sitting around snapping his/her fingers demanding service now, it's nothing of the sort, I just personally feel that no matter what, not giving a word back in close to a month is just blowing people off, making them feel like who cares...

Anyhow enough steam, my ears are hurting!

I love Linux, but what goes around comes around, so don't ever think that just because you blow someone off in a bug report you won't have yourself handing one day too, oh no sorry, life works in mysterious ways and if you haven't been left hanging, then I promise, one day you will!

CHEERS
Comment 6 KernelBug 2013-08-06 21:16:36 UTC
TYPO before;

I love Linux, but what goes around comes around, so don't ever think that just because you blow someone off in a bug report you won't have yourself HANGING one day....
Comment 7 KernelBug 2013-08-06 21:38:23 UTC
Created attachment 107124 [details]
lspci -v
Comment 8 Peter Wu 2013-08-12 21:59:57 UTC
This is a duplicate of bug 60507.
Comment 9 KernelBug 2013-08-14 00:43:42 UTC
Did it really need to take this long ONLY to tell me there's a duplicate?

Seriously this isn't about me it's just about having some better efficency and this was one sad example of extereme inefficency....

I guess to many overburdened people and not even time...

What a waste of time!
Comment 10 Peter Wu 2013-08-14 12:26:56 UTC
Did it take that long ONLY to find out now that there is a duplicate? I am a volunteer and by searching the bug tracker, I found two related bugs, yours included. Since the other bug had more attention, it seems more logical to mark this bug as duplicate.

Google for "logitech linux 3.10" resulted in a lot of helpful results, including https://bbs.archlinux.org/viewtopic.php?id=167099. I suggest you to try that next time.

Can you please help relieving the already loaded bug tracker and close this bug as duplicate of the other?
Comment 11 Alan 2013-11-13 16:47:33 UTC
if you filed bugs in things rather than other/other they'd get seen

This a bug tracker, not a bug fixing service.

*** This bug has been marked as a duplicate of bug 60507 ***

Note You need to log in before you can comment on or make changes to this bug.