Bug 6056 - SATA problem on sata_nv (NFPIK8AA-8EKRS)
SATA problem on sata_nv (NFPIK8AA-8EKRS)
Status: REJECTED DUPLICATE of bug 6207
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
i386 Linux
: P2 high
Assigned To: Jeff Garzik
:
: 6015 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-11 07:59 UTC by tawa777
Modified: 2006-03-10 06:59 UTC (History)
0 users

See Also:
Kernel Version: 2.6.15.4
Tree: Mainline
Regression: ---


Attachments

Description tawa777 2006-02-11 07:59:55 UTC
Most recent kernel where this bug did not occur:

Distribution: 
FedoraCore4(x86-64)

Hardware Environment:
CPU: Opteron 140EE
Motherboard: NFPIK8AA-8EKRS
Memory: 512MB x 2 (ECC-Reg. DDR400)
HDD:HDS728080PLA380.

Software Environment:
Problem Description:

I have begun to use a PC with a Motherboard named NFPIK8AA-8EKRS.
http://www.foxconnchannel.com/products_motherboard_2.cfm?pName=NFPIK8AA-8EKRS

The Board has two on-board SATA controllers,
one is called Nforce4 Professional 2200(CK8-04)
other is called Nforce4 professional 2050(I/O-4).
And each controller has four SATA ports.
Thus this board has total 8 SATA ports.

I find when a SATA Disk which FC4 is installed
is connected to a SATA ports controlled by I/O-4,
the disk is not boot without the option of "acpi=noirq".
When the Disk is connected to CK8-04,
Boot process works fine.

I have took pictures of monitor
showing error message in booting without "acpi=noirq".
http://type-r.dnsalias.net/9usjs/a.jpg
http://type-r.dnsalias.net/9usjs/b.jpg
http://type-r.dnsalias.net/9usjs/c.jpg
http://type-r.dnsalias.net/9usjs/d.jpg
http://type-r.dnsalias.net/9usjs/e.jpg

I also put dmesg's
http://type-r.dnsalias.net/9usjs/dmesg.txt
http://type-r.dnsalias.net/9usjs/dmesg_noirq.txt.

Former shows the log when I connect the HDD to the port controlled by CK8-04,
latter shows one when I connect the HDD to the port controlled by I/O-4.

If further information is needed,
I will post it as much as possible.



Steps to reproduce:
1. Power off the PC
2. Connect the SATA disk to ports controlled by I/O-4. 
3. Power on the PC
Comment 1 tawa777 2006-02-11 08:02:10 UTC
*** Bug 6015 has been marked as a duplicate of this bug. ***
Comment 2 tawa777 2006-03-10 06:59:06 UTC

*** This bug has been marked as a duplicate of 6207 ***

Note You need to log in before you can comment on or make changes to this bug.