Bug 60527 - [IVB hybrid] Linux 3.10.0: black screen on Asus UX32VD, please revert -> Revert "drm/i915: revert eDP bpp clamping code changes"
[IVB hybrid] Linux 3.10.0: black screen on Asus UX32VD, please revert -> Reve...
Status: RESOLVED DUPLICATE of bug 59841
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: intel-gfx-bugs@lists.freedesktop.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-06 07:28 UTC by Fabio Erculiani
Modified: 2013-07-27 14:49 UTC (History)
7 users (show)

See Also:
Kernel Version: 3.10
Tree: Mainline
Regression: No


Attachments
kernel config used (150.14 KB, application/octet-stream)
2013-07-06 07:28 UTC, Fabio Erculiani
Details
lspci -vvv (22.44 KB, text/plain)
2013-07-06 07:28 UTC, Fabio Erculiani
Details
journalctl -xb (123.94 KB, text/plain)
2013-07-06 07:36 UTC, Fabio Erculiani
Details
dmesg (27.26 KB, text/plain)
2013-07-06 07:36 UTC, Fabio Erculiani
Details
dmesg from a broken kernel (3.10.2) (115.71 KB, text/plain)
2013-07-25 09:13 UTC, Fabio Erculiani
Details
dmesg from a working kernel (3.10.1) (115.72 KB, text/plain)
2013-07-25 09:14 UTC, Fabio Erculiani
Details

Description Fabio Erculiani 2013-07-06 07:28:10 UTC
Created attachment 106818 [details]
kernel config used

I upgraded from 3.9.7 to 3.10.0 and I'm getting a nice pearl black screen on my ASUS UX32VD. The system boots and works fine (I can login via ssh) but the screen stays black after intel drm and kms stuff is loaded by udev.
There is nothing interesting in dmesg, however I noticed that with 3.10, the agpgart and intel_agp modules are loaded by udev (wtf?) while on 3.9.7 they are not.

I will attach a full dmesg output as soon as I can collect it.
Attached is my kernel config. My kernel is almost vanilla (there is the BFQ patchset, aufs3 and fbcondecor) and I use systemd.
Comment 1 Fabio Erculiani 2013-07-06 07:28:52 UTC
Created attachment 106819 [details]
lspci -vvv
Comment 2 Fabio Erculiani 2013-07-06 07:36:23 UTC
Created attachment 106820 [details]
journalctl -xb
Comment 3 Fabio Erculiani 2013-07-06 07:36:49 UTC
Created attachment 106821 [details]
dmesg
Comment 4 Fabio Erculiani 2013-07-06 08:04:30 UTC
It looks like dmesg lost the first messages, let me know if you need them.
Comment 5 Fabio Erculiani 2013-07-13 12:09:30 UTC
I ran a git bisect and here's what I've found:

657445fe8660100ad174600ebfa61536392b7624 is the first bad commit
commit 657445fe8660100ad174600ebfa61536392b7624
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Sat May 4 10:09:18 2013 +0200

    Revert "drm/i915: revert eDP bpp clamping code changes"
    
    This reverts commit 57c219633275c7e7413f8bc7be250dc092887458.
    
    It's an ugly hack for a Haswell SDV platform where the vbt doesn't
    seem to fully agree with the panel. Since it seems to cause issues on
    real eDP platform let's just kill this hack again.
    
    Reported-and-tested-by: Josh Boyer <jwboyer@gmail.com>
    References: https://lkml.org/lkml/2013/5/3/467
    Cc: Paulo Zanoni <przanoni@gmail.com>
    Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Comment 6 Fabio Erculiani 2013-07-13 12:21:53 UTC
Reverting the commit fixes the problem for me.
Comment 7 Daniel Vetter 2013-07-23 15:48:13 UTC
Can you please boot both with a broken and working kernel with drm.debug=0xe added to your kernel cmdline and then grab the complete dmesg for both?
Comment 8 Fabio Erculiani 2013-07-25 09:13:26 UTC
Created attachment 107015 [details]
dmesg from a broken kernel (3.10.2)

This is from the "broken" kernel (without the commit reverted)
Comment 9 Fabio Erculiani 2013-07-25 09:14:26 UTC
Created attachment 107016 [details]
dmesg from a working kernel (3.10.1)

This is from a working kernel (with the commit reverted) and was captured on 3.10.1.
Comment 10 Chris Wilson 2013-07-27 14:49:32 UTC

*** This bug has been marked as a duplicate of bug 59841 ***

Note You need to log in before you can comment on or make changes to this bug.