Bug 60211 - intel_pstate driver missing ids for some supported CPUs
Summary: intel_pstate driver missing ids for some supported CPUs
Status: CLOSED CODE_FIX
Alias: None
Product: Power Management
Classification: Unclassified
Component: cpufreq (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: cpufreq
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-28 01:13 UTC by Nell Hardcastle
Modified: 2013-12-09 08:25 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.10rc7
Tree: Mainline
Regression: No


Attachments

Description Nell Hardcastle 2013-06-28 01:13:06 UTC
Running 3.10-rc7 on an i5-4200U, with either intel_pstate or the older cpufreq drivers the CPU was stuck at 800MHz. I added the model, 0x45, to intel_pstate_cpu_ids and frequency scaling seems to be working as intended now.
Comment 1 Viresh Kumar 2013-06-28 04:09:17 UTC
Hi Nell,

If this is already solved why not send a patch to dirk and list. And we can get it in quickly. Maybe for 3.11, before Rafael sends a pull request. :)
Comment 2 Aaron Lu 2013-07-01 02:23:30 UTC
Patch sent to mailing list:

https://patchwork.kernel.org/patch/2804671/
Comment 3 Aaron Lu 2013-12-09 08:25:08 UTC
commit 6cdcdb793791f776ea9408581b1242b636d43b37
Author: Nell Hardcastle <nell@spicious.com>
Date:   Sun Jun 30 15:58:57 2013 -0700

    intel_pstate: Add Haswell CPU models

upstreamed.

Note You need to log in before you can comment on or make changes to this bug.