Bug 59771 - mode selection on edp panel fails (dell xps 13 ivy bridge 1080p version)
mode selection on edp panel fails (dell xps 13 ivy bridge 1080p version)
Status: RESOLVED DUPLICATE of bug 59841
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 high
Assigned To: intel-gfx-bugs@lists.freedesktop.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-16 01:48 UTC by Ulf Winkelvos
Modified: 2013-06-25 08:26 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.10rc2 +
Tree: Mainline
Regression: Yes


Attachments
dmesg output 3.9.0 - good (111.76 KB, text/plain)
2013-06-16 23:25 UTC, Ulf Winkelvos
Details
dmesg output 3.10-rc6 - bad (97.39 KB, text/plain)
2013-06-16 23:25 UTC, Ulf Winkelvos
Details
dmesg output 3.10-rc6 reverted commit - good (106.35 KB, text/plain)
2013-06-16 23:26 UTC, Ulf Winkelvos
Details

Description Ulf Winkelvos 2013-06-16 01:48:36 UTC
The regression is exactly like Josh Boyer described it (https://lkml.org/lkml/2013/5/3/467), but on my system (dell xps 13 ivy bridge 1080p version) it only occurs after the reverted revert (657445fe8660100ad174600ebfa61536392b7624) [1] that fixed the problem on the macbook. I had to revert the reverted revert to regain an usable display. :)

[1] http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=657445fe8660100ad174600ebfa61536392b7624
Comment 1 Daniel Vetter 2013-06-16 11:32:25 UTC
Can you please boot with drm.debug=0xe added to your kernel cmdline and then attach the complete dmesg for
- working 3.9.x kernel
- broken 3.10-rc kernel
- working 3.10-rc kernel with the revert reverted

Let's see which kernel comes up with which exact eDP link config.
Comment 2 Ulf Winkelvos 2013-06-16 23:25:06 UTC
Created attachment 104881 [details]
dmesg output 3.9.0 - good
Comment 3 Ulf Winkelvos 2013-06-16 23:25:52 UTC
Created attachment 104891 [details]
dmesg output 3.10-rc6 - bad
Comment 4 Ulf Winkelvos 2013-06-16 23:26:59 UTC
Created attachment 104901 [details]
dmesg output 3.10-rc6 reverted commit - good
Comment 5 Ulf Winkelvos 2013-06-16 23:37:36 UTC
the 3.10-rc6 dmesg looks okay. The right modes get selected and it looks pretty similar to 3.10-rc-6-reverted, but without the revert, the screen is definetly messed up. It looks like if you selected a too high refreshrate on an old crt.
Comment 6 Ulf Winkelvos 2013-06-19 21:30:51 UTC
@Daniel: do you need any other logs or info?
Comment 7 Chris Wilson 2013-06-25 08:26:42 UTC

*** This bug has been marked as a duplicate of bug 59841 ***

Note You need to log in before you can comment on or make changes to this bug.