Bug 5975 - No Function keys -- Toshiba Satellite M45-S359
No Function keys -- Toshiba Satellite M45-S359
Status: REJECTED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Platform
i386 Linux
: P2 normal
Assigned To: Zhang Rui
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2006-01-29 08:52 UTC by Daniel Macedo
Modified: 2013-04-09 06:13 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.16-rc1
Tree: Mainline
Regression: ---


Attachments
output from the acpidump tool (133.93 KB, text/plain)
2006-01-29 08:53 UTC, Daniel Macedo
Details
Bios decode (1.13 KB, text/plain)
2006-01-29 08:54 UTC, Daniel Macedo
Details
dmesg (18.55 KB, text/plain)
2006-01-29 08:55 UTC, Daniel Macedo
Details
dmidecode output (11.32 KB, text/plain)
2006-01-29 08:56 UTC, Daniel Macedo
Details
/proc/interrupts (646 bytes, text/plain)
2006-01-29 08:56 UTC, Daniel Macedo
Details
lspci -vv (16.30 KB, text/plain)
2006-01-29 08:57 UTC, Daniel Macedo
Details

Description Daniel Macedo 2006-01-29 08:52:56 UTC
This model's function keys and other toshiba models (such as the m45-s331, see
page http://www.fedoraforum.org/forum/showthread.php?p=223328) do not work.  

The LCD is shut down when the lid is closed, however the dimming using the
function keys does not work. Attempts to load the toshiba_acpi module also do
not work.

I'm running a vanilla 2.6.16-rc1 kernel on fedora core 4, with the following
kernel options:  acpi=on pci=routeirq
Comment 1 Daniel Macedo 2006-01-29 08:53:56 UTC
Created attachment 7172 [details]
output from the acpidump tool
Comment 2 Daniel Macedo 2006-01-29 08:54:43 UTC
Created attachment 7173 [details]
Bios decode
Comment 3 Daniel Macedo 2006-01-29 08:55:14 UTC
Created attachment 7174 [details]
dmesg
Comment 4 Daniel Macedo 2006-01-29 08:56:12 UTC
Created attachment 7175 [details]
dmidecode output
Comment 5 Daniel Macedo 2006-01-29 08:56:39 UTC
Created attachment 7176 [details]
/proc/interrupts
Comment 6 Daniel Macedo 2006-01-29 08:57:16 UTC
Created attachment 7177 [details]
lspci -vv
Comment 7 Jo 2006-04-15 15:34:17 UTC
The problem is that we do not have support for Phoenix Bios.
The toshiba_acpi module is only for toshiba bios..
Comment 8 Zhang Rui 2007-09-19 23:08:21 UTC
Hi, Daniel,

Does the problem still exist in the latest kernel with a newer bios?
can the toshiba_acpi driver be loaded?
can you change the brightness level by manually writing to /sys/class/backlight/acpi_video0/brightness?
Comment 9 Daniel Macedo 2007-09-20 00:13:01 UTC
Mr. Zhang,

Due to this problem and other little integration and compatibility
things that Linux could never address, I will be changing soon to a
Mac. I do not have Linux installed anymore on my PC, however the last
time I checked the problem was still there. I believe it had a kernel
version 2.6.20 or 2.6.21.

Thanks,

Daniel

On 9/20/07, bugme-daemon@bugzilla.kernel.org
<bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=5975
>
>
> rui.zhang@intel.com changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>          AssignedTo|john@neggie.net             |rui.zhang@intel.com
>              Status|NEW                         |ASSIGNED
>
>
>
>
> ------- Comment #8 from rui.zhang@intel.com  2007-09-19 23:08 -------
> Hi, Daniel,
>
> Does the problem still exist in the latest kernel with a newer bios?
> can the toshiba_acpi driver be loaded?
> can you change the brightness level by manually writing to
> /sys/class/backlight/acpi_video0/brightness?
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.
>


Comment 10 Zhang Rui 2007-09-20 00:20:24 UTC
Oh, bad news :(
I'll reject this bug and mark it as unreproducible.
Please reopen it if you want to try Linux again. :)

Note You need to log in before you can comment on or make changes to this bug.