Bug 59691 - Bad connectivity with ath9k AR9485 when power management off
Bad connectivity with ath9k AR9485 when power management off
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 low
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 05:18 UTC by jkp
Modified: 2013-10-15 16:04 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.10-rc5
Tree: Mainline
Regression: No


Attachments

Description jkp 2013-06-14 05:18:09 UTC
Moved from https://bugzilla.kernel.org/show_bug.cgi?id=49201https://bugzilla.kernel.org/show_bug.cgi?id=49201 where it came up:

All works fine with power management off with fixes from bug 49201, but with power management off, when I look at the iwconfig bit rate every five
seconds, it's mostly 65 Mbps but about every once in 25 .. once in 50 it's 1
Mbps. Also, occasionally there are longer periods of low speed
(1..30 Mbps) and this affects also practical usability quite a lot.

Hardware: asus transformer book tx300 (4005)
Comment 1 Sujith 2013-06-17 20:40:26 UTC
Can you load the driver with debug=0x8f49 and post the kernel log when this issue happens ? Also the contents of the debugfs files, "rc_stats", "xmit".

If you can use the wireless-testing tree, that would be great since it contains the latest code and patches are posted against it, for John to pick up.
Comment 2 jkp 2013-06-18 07:29:57 UTC
OK, I try to do that but probably not in the next few days. It seems mostly this is not a big practical issue, had power management off for a long while and didn't notice any big problems.

To correct the description, I meant to write that all works fine power management on, but the problems are with power management off.
Comment 3 Sujith 2013-08-20 06:21:36 UTC
Are you still seeing this issue with the latest wireless-testing kernel ?
Comment 4 jkp 2013-08-23 11:36:28 UTC
I'll test, pulling the wireless-testing tree now.
Comment 5 jkp 2013-08-25 06:55:40 UTC
I can't repeat the reported issue with wireless-testing tree pulled at 2013-08-23.

Also, no significant difference observed with power on & off behaviour looking at the speed as reported by iwconfig and speedtest.net. 

With 3.11.0-rc6-wl+, compared to the earlier 3.10.0-rc6, I did have some more trouble getting the wlan connected. But that might well be slight differences in the location of the computer & base station & other wiring.
Comment 6 Sujith 2013-08-26 03:43:55 UTC
Ok, thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.