Bug 5938 - Boot stalls on loading ide-cd. Crashed with irqpoll.
Boot stalls on loading ide-cd. Crashed with irqpoll.
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Config-Interrupts
i386 Linux
: P2 normal
Assigned To: acpi_config-interrupts
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-22 16:16 UTC by Simon Waters
Modified: 2006-11-19 08:30 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.15-1-686
Tree: Mainline
Regression: ---


Attachments

Description Simon Waters 2006-01-22 16:16:40 UTC
Most recent kernel where this bug did not occur: 2.6.8 (last tested)
Distribution: Debian
Hardware Environment: Acer TravelMate 200 DX 
Software Environment: Debian Sarge (2006-01-23)
Problem Description:

Later Debian stock kernels cause boot to hang at ide-cd, until SysRq is pressed.
Tested 2.6.10 several, 2.6.14, all have similar problem.

Boot with irqpoll to work around this causes machine to become unstable.

Full details in Debian bug 333831

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=333831

Possibly similar to problem discussed here(?);

http://www.gossamer-threads.com/lists/linux/kernel/492182

Also saw similar bug reported in Redhat Bugzilla, assigned to Alan Cox.

Steps to reproduce:

Boot kernel.

Boot kernel with irqpoll, start playing CD, wait for reboot.
Comment 1 Andrew Morton 2006-01-22 16:45:16 UTC
Possibly an IDE thing, more likely an ACPI problem.
Comment 2 Simon Waters 2006-01-27 12:37:41 UTC
"acpi = off" seems to prevent the problem with later kernels. So I have an
excellent workaround, especially since several useful laptop features I'd
assumed were ACPI appear to be driven by things other than ACPI.

However the behaviour is such I think at the very least the hardware should be
identified, and the relevant ACPI functions disabled automatically if possible.
Will go read ACPI HowTo, and figure out what I can.
Comment 3 Adrian Bunk 2006-07-11 06:46:03 UTC
Is this issue still present with kernel 2.6.17?
Comment 4 Simon Waters 2006-08-06 13:44:20 UTC
bugme-daemon@bugzilla.kernel.org wrote:
> 
> Is this issue still present with kernel 2.6.17?

Yes, Debian package linux-image-2.6.17-1-686 exhibits similar
problematic behaviour.

It hangs during the boot in similar places (till SysRq is sent), reports
the same IRQ error when the CD is used, but didn't get past spinning the
disk up before the player process became a zombie, and no sound at all
was produced. So if anything somewhat worse.

Outstanding is for me to try the modified ACPI dump, made by following
the ACPI HOWTO for debugging ACPI problems.

Comment 5 Simon Waters 2006-08-07 13:58:33 UTC
bugme-daemon@bugzilla.kernel.org wrote:
> 
> Yes, Debian package linux-image-2.6.17-1-686 exhibits similar
> problematic behaviour.

I think 2.6.17 does fix this.

I have two boot logs with Debian kernel 2.6.17-1 the first had an
interrupt error immediately after identifying the CDROM, the second
doesn't. The difference being, I assume, that the second was a cold
reboot, where as the other was probably a warm reboot after loading a
kernel that does cause the problem.

The CD ROM play back via Totem has the odd glitch with the new kernel,
which appears to be activity related, but I think we can assume that
2.6.17-1 has resolved this specific problem.

Apologies for the misleading response. Suggest bug is closed, and I'll
reopen if I become aware of any anomalies. Thanks to all for your
attention and assistance in this matter.


Note You need to log in before you can comment on or make changes to this bug.