Bug 593 - fb.h has syntax errors
Summary: fb.h has syntax errors
Status: REJECTED UNREPRODUCIBLE
Alias: None
Product: Other
Classification: Unclassified
Component: Other (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Diego Calleja
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-04-16 14:14 UTC by Bret Towe
Modified: 2004-03-30 10:23 UTC (History)
0 users

See Also:
Kernel Version: 2.5.67
Tree: Mainline
Regression: ---


Attachments
syntax fixing patch (754 bytes, patch)
2003-08-08 16:36 UTC, Bret Towe
Details | Diff

Description Bret Towe 2003-04-16 14:14:50 UTC
Distribution: Gentoo
Hardware Environment:
Software Environment:
Problem Description: while trying to compile libsdl while using 2.5.67's kernel
headers i encountered this problem i did trace it down info and patch can be
found here: http://bugs.gentoo.org/show_bug.cgi?id=19307

Steps to reproduce:
Comment 1 Alan 2003-04-17 07:23:13 UTC
Headers should point at the headers with the C library not the kernel ones.

The patch goal seems ok, implementation not. Can you redo it to use __KERNEL__
define checks so that a user app only gets the objects it should be allowed to
know about
Comment 2 Bret Towe 2003-04-17 10:57:40 UTC
sorry aside from the fact im not sure what your asking
the fix i have is about as far as i know how to go
Comment 3 Bret Towe 2003-08-08 16:36:11 UTC
Created attachment 625 [details]
syntax fixing patch

this patch just fixes the syntax errors in fb.h

on a side note i have some other patchs for headers from the kernel
should i make another generic bug for them all?
Comment 4 Diego Calleja 2004-03-29 09:51:44 UTC
Can this bug be closed? It has been a while since the last resport, it's still
valid?
Comment 5 Bret Towe 2004-03-29 10:44:56 UTC
i havnet checked lately but i think i saw a commit to fix this
Comment 6 Diego Calleja 2004-03-30 10:23:24 UTC
Ok, so since this has been opened since a year or so, I don't think it has sense
to keep it open....however if someone detects the bug a new bug report should be
filed (or reopen this one)

Note You need to log in before you can comment on or make changes to this bug.