Bug 59091 - Toshiba A660 - random kernel panics when running without acpi=noirq
Summary: Toshiba A660 - random kernel panics when running without acpi=noirq
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: ACPI
Classification: Unclassified
Component: EC (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Lan Tianyu
URL:
Keywords:
: 59641 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-31 13:03 UTC by Mateusz
Modified: 2013-11-25 14:43 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.8, 3.9
Tree: Mainline
Regression: No


Attachments
DMESG, LSMOD and acpi dump of me device (297.95 KB, application/gzip)
2013-05-31 13:03 UTC, Mateusz
Details
debug.patch (652 bytes, patch)
2013-06-19 02:06 UTC, Lan Tianyu
Details | Diff

Description Mateusz 2013-05-31 13:03:34 UTC
Created attachment 103101 [details]
DMESG, LSMOD and acpi dump of me device

Already from 3.8.X tree my laptop gets randmon kernel panics when I run the system without acpi=noirq parameter. It is hard to get panics log because it happens complete random and often when the PC is running X server. Device
specification:
- Intel Core i3 330M
- Nvidia Geforce 330M
- 6GB RAM

The last panic with I can report was on 3.8 kernel, I have run on X server multiple glxgears and switched to console, the after few minutes I have a oops. I attached a screen image of it. The logs are from 3.9 kernel (but after few min when I was away the kernel crashes too).
Comment 1 Mateusz 2013-05-31 13:06:33 UTC
https://dl.dropboxusercontent.com/u/1664131/IMG_20130427_174954.jpg screen photo of the kernel panics, to big for an attachment
Comment 2 Aaron Lu 2013-06-04 06:16:35 UTC
From the panic, it looks kernel crashed in ec interrupt handler.
Comment 3 Lan Tianyu 2013-06-13 02:01:24 UTC
Could you use addr2line to locate which line cause this panic?
eg, add2line -a ffffffff812d4797 -e vmlinux

BTW, is this bug a regression?
Comment 4 Lan Tianyu 2013-06-17 06:45:46 UTC
*** Bug 59641 has been marked as a duplicate of this bug. ***
Comment 5 Lan Tianyu 2013-06-17 06:46:28 UTC
Any update?
Comment 6 Mateusz 2013-06-17 07:19:40 UTC
Sorry for the late replay, but I had some exams in last days. Well I don't already have the 3.8 kernel (moved to 3.9) but I will try to crash the 3.9 kernel today and run the add2line. I think this bug is a regression because on 3.7 kernel (or 3.6 I don't remember) the kernel runs stable without acpi=noirq. Well I will add a new kernel crash and the add2line in few hours.
Comment 7 Lan Tianyu 2013-06-18 03:22:45 UTC
Ok. Thanks for test. Just check the change log of driver/acpi/ec.c between v3.7 and v3.9. There is no obvious commit related with such issue.
Comment 8 Mateusz 2013-06-18 11:48:15 UTC
Here is a new crash log https://dl.dropboxusercontent.com/u/1664131/IMG_20130618_133650.jpg unfortunely the Call Trace is much longer so it overlapped the begin of the log, is the any chance to scroll the log up or log it to a file? It is hard to catch when the output is generated because it happens complete random, last time it happens after 5 min uptime, this time it happens after ~30min uptime.
Comment 9 Mateusz 2013-06-18 12:19:52 UTC
What about kdump? Could it help us to find where the kernel crashes?
Comment 10 Lan Tianyu 2013-06-18 13:07:04 UTC
What does "addr2line -a ffff8801bbc83db8 -e vmlinux" say under kernel source directory?
Comment 11 Mateusz 2013-06-18 13:16:52 UTC
Strange:
addr2line -a ffffffffbbc83db8 -e ./vmlinux
0xffffffffbbc83db8
??:0
Well I have uploaded the vmlinux file, here it is https://dl.dropboxusercontent.com/u/1664131/vmlinux
Comment 12 Mateusz 2013-06-18 13:18:17 UTC
Eee wrong command, but this shows the same:
addr2line -a ffff8801bbc83db8 -e vmlinux
0xffff8801bbc83db8
??:0
Comment 13 Lan Tianyu 2013-06-18 13:21:41 UTC
Sorrry, please use ffffffff812dda2b as address and try again.
Comment 14 Mateusz 2013-06-18 13:23:57 UTC
Well I already tried it, it shows that the kernel crashes in the ec.c:
addr2line -a ffffffff812dda2b -e vmlinux
0xffffffff812dda2b
ec.c:?
Comment 15 Lan Tianyu 2013-06-19 02:06:23 UTC
Created attachment 105291 [details]
debug.patch

Please try this patch.
Comment 16 Mateusz 2013-07-01 17:45:29 UTC
Sorry for the late replay, I was lite busy. Well I have patched latest 3.9 kernel with this path, it still crashes (but as I see this wasn't a fix just some debug, I am right?). Here is the latest crashes https://dl.dropboxusercontent.com/u/1664131/IMG_20130701_193702.jpg running  addr2line -a ffffffff812ddb85 -e vmlinux still only shows the ec.c:? nothing more, but hope the are some or info in this crash.
Comment 17 Lan Tianyu 2013-07-18 06:27:38 UTC
hi, sorry for later response. Could you please try the following patch?
https://bugzilla.kernel.org/attachment.cgi?id=106887
Comment 18 Lan Tianyu 2013-08-05 01:25:16 UTC
Any update?
Comment 19 Mateusz 2013-08-05 19:03:20 UTC
I am on holidays now, so sorry for the delay, I will be back on Friday, so expect an update on Friday or Saturday.
Comment 20 Mateusz 2013-08-10 09:10:41 UTC
Ok, this time the crash was much longer, unfortunately it doesn't fit the screen. Her is it https://dl.dropboxusercontent.com/u/1664131/IMG_20130810_105942.jpg I have uploaded my vmlinux and config here https://dl.dropboxusercontent.com/u/1664131/vmlinux-3.10.5 https://dl.dropboxusercontent.com/u/1664131/config-3.10.5 because I will be not online next ~two weeks.
Comment 21 Mateusz 2013-09-02 08:01:51 UTC
Any update?
Comment 22 Lan Tianyu 2013-11-18 01:49:31 UTC
Hi, Sorry for later response. I recently find the following patch maybe related with this bug. Please have a try.

https://git.kernel.org/cgit/linux/kernel/git/rafael/linux-pm.git/commit/?h=bleeding-edge&id=36b15875a7819a2ec4cb5748ff7096ad7bd86cbb
Comment 23 Mateusz 2013-11-23 12:59:47 UTC
After 23h uptime I think I can say this fixed it ;). I hope it is really this. So for now big thanks for helping my. BTW When will this fix be merged with mainline? In 3.13 or 3.14?
Comment 24 Lan Tianyu 2013-11-25 01:12:57 UTC
It has been merged into v3.13. So mark the bug as PATCH_ALREADY_AVAILABLE.
Comment 25 Mateusz 2013-11-25 14:43:59 UTC
I see it is already marked. Thanks for helping ;).

Note You need to log in before you can comment on or make changes to this bug.