Bug 59001 - Mute/unmute no longer works after upgrade from 3.8.11
Mute/unmute no longer works after upgrade from 3.8.11
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Jaroslav Kysela
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 22:04 UTC by excitablesnowball
Modified: 2013-08-19 18:20 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.9.2
Tree: Mainline
Regression: No


Attachments
3.8.11-1, muted (25.79 KB, text/plain)
2013-08-07 23:54 UTC, excitablesnowball
Details
alsa-info.txt.3.8.11-1.unmuted (25.80 KB, text/plain)
2013-08-07 23:54 UTC, excitablesnowball
Details
alsa-info.txt.3.10.5-1.unmuted (24.13 KB, text/plain)
2013-08-07 23:55 UTC, excitablesnowball
Details
alsa-info for kernel 3.10.5-1-ARCH (17.73 KB, text/plain)
2013-08-08 04:37 UTC, Dinh Hoang
Details
Fix patch (1.10 KB, patch)
2013-08-08 06:42 UTC, Takashi Iwai
Details | Diff
alsa-info.txt.3.10.6-2.unmuted.patched (23.67 KB, text/plain)
2013-08-17 19:27 UTC, excitablesnowball
Details
alsa-info.txt.3.10.6-2.unmuted.really-patched (24.40 KB, text/plain)
2013-08-17 19:39 UTC, excitablesnowball
Details

Description excitablesnowball 2013-05-29 22:04:19 UTC
Description:
After upgrading from 3.8.11 to 3.9.2, mute/unmute no longer works in amixer or alsamixer. (It doesn't work in 3.9.4, either.) It works again if I downgrade back to 3.8.11.


Hardware:
This is a Lenovo ThinkPad T500. Relevant hardware:

    [d@eighth ~]$ lspci | grep -i audio
    00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

    [d@eighth ~]$ cat /proc/asound/cards
    0 [Intel ]: HDA-Intel - HDA Intel
    HDA Intel at 0xfc020000 irq 46
    29 [ThinkPadEC ]: ThinkPad EC - ThinkPad Console Audio Control
    ThinkPad Console Audio Control at EC reg 0x30, fw 7VHT12WW-1.01


Steps to reproduce:
On 3.8.11, amixer behaves normally:

    [d@eighth ~]$ amixer set Master mute
    Simple mixer control 'Master',0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined
    Playback channels: Mono
    Limits: Playback 0 - 74
    Mono: Playback 35 [47%] [-39.00dB] [off]

After upgrading to 3.9.2 and rebooting, mute/unmute no longer works:

    [d@eighth ~]$ amixer set Master mute
    amixer: Invalid command!


(Originally reported on the Arch Linux bug tracker at https://bugs.archlinux.org/task/35256 )
Comment 1 Dinh Hoang 2013-08-07 08:58:48 UTC
Same problem here,

$ lspci |grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

Problem remains in 3.9.x, 3.10.x
Hope this would be fixed soon.
Comment 2 Takashi Iwai 2013-08-07 09:06:14 UTC
Please give alsa-info.sh outputs on both 3.8.x and 3.10.x kernels.
At best, take alsa-info.sh outputs at both mute and unmuted states to see the difference.

Run with --no-upload option and attach (don't paste) the outputs to the bugzilla.
Comment 3 excitablesnowball 2013-08-07 23:54:20 UTC
Created attachment 107150 [details]
3.8.11-1, muted
Comment 4 excitablesnowball 2013-08-07 23:54:47 UTC
Created attachment 107151 [details]
alsa-info.txt.3.8.11-1.unmuted
Comment 5 excitablesnowball 2013-08-07 23:55:15 UTC
Created attachment 107152 [details]
alsa-info.txt.3.10.5-1.unmuted
Comment 6 excitablesnowball 2013-08-07 23:57:03 UTC
Added alsa-info.sh for 3.8.11 and 3.10.5. (There's no 'muted' version for 3.10.5 because I can't mute.)
Comment 7 Dinh Hoang 2013-08-08 04:37:32 UTC
Created attachment 107153 [details]
alsa-info for kernel 3.10.5-1-ARCH

Issue: Cannot mute/unmute
$amixer set Master mute
amixer: Invalid command!
Comment 8 Takashi Iwai 2013-08-08 06:42:00 UTC
Thanks.  Could you try the patch below?
Comment 9 Takashi Iwai 2013-08-08 06:42:47 UTC
Created attachment 107154 [details]
Fix patch
Comment 10 excitablesnowball 2013-08-17 19:27:53 UTC
Created attachment 107226 [details]
alsa-info.txt.3.10.6-2.unmuted.patched

The patch didn't resolve the issue for me. Here's the alsa-info output after applying the patch.
Comment 11 excitablesnowball 2013-08-17 19:39:02 UTC
Created attachment 107227 [details]
alsa-info.txt.3.10.6-2.unmuted.really-patched

Correction: your patch worked perfectly. I had booted to the wrong kernel. Thanks!
Comment 12 Takashi Iwai 2013-08-19 07:53:40 UTC
Good to hear.  The patch was already merged to Linus tree with Cc to stable, so let's close this bug.

Note You need to log in before you can comment on or make changes to this bug.