Bug 58981 - [BISECTED] boot failure with Radeon 9250 PCI 256MB + KMS
Summary: [BISECTED] boot failure with Radeon 9250 PCI 256MB + KMS
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-29 18:43 UTC by James Dietrich
Modified: 2020-01-28 15:54 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.35,3.2.45,3.10-rc2
Tree: Mainline
Regression: Yes


Attachments
dmesg output from 2.6.35 with 6b8b1786 reverted (35.55 KB, text/plain)
2013-05-29 18:45 UTC, James Dietrich
Details
output from lspci -vv (12.41 KB, text/plain)
2013-05-29 18:46 UTC, James Dietrich
Details

Description James Dietrich 2013-05-29 18:43:38 UTC
I have a Radeon 9250 PCI 256MB video card in my machine. I discovered that this machine would not boot with 3.2.45 when KMS was enabled by default in the kernel config. Immediately after the grub menu, the screen would go black and nothing more would happen. Or sometimes columns of character-sized "marks" would appear on the screen. In either case, though, the machine would not boot.

So I went back to 2.6.33 and found that booting with KMS did work just fine there.

So I used git bisect to find where the problem arose, and that pointed to this commit which was merged for 2.6.35:
commit 6b8b1786a8c29ce6e32298b93ac8d4a18a2b11c4
Author: Jerome Glisse <jglisse@redhat.com>
Date:   Wed Apr 7 10:21:31 2010 +0000

    drm/radeon/kms: enable use of unmappable VRAM V2

I confirmed this result of git bisect by checking out 2.6.35 final and reverting that one commit, and the resulting kernel booted fine with KMS enabled by default.

I also tried 3.10-rc2 and that booted fine when I added radeon.modeset=0 to the kernel commandline.

I will attach files with dmesg output and lspci. Please let me know if there is anything else I can do. I'll be happy to test a proposed fix if that would be helpful.

Thank you,
James Dietrich
Comment 1 James Dietrich 2013-05-29 18:45:40 UTC
Created attachment 102861 [details]
dmesg output from 2.6.35 with 6b8b1786 reverted
Comment 2 James Dietrich 2013-05-29 18:46:22 UTC
Created attachment 102871 [details]
output from lspci -vv
Comment 3 Alex Deucher 2013-05-29 19:50:45 UTC
Does booting a modern kernel with radeon.vramlimit=128 work around the issue?
Comment 4 James Dietrich 2013-05-29 20:25:02 UTC
I just compiled 3.9.4 and tried booting with radeon.vramlimit=128 but that did not work around the issue. It failed to boot the same as before.

Note You need to log in before you can comment on or make changes to this bug.