Bug 58671 - Nvidia drivers fail compile
Summary: Nvidia drivers fail compile
Status: CLOSED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-22 21:02 UTC by Acidphase
Modified: 2013-11-12 15:03 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.10-rc*
Tree: Mainline
Regression: No


Attachments
Build Log from portage (120.40 KB, text/x-log)
2013-05-22 21:05 UTC, Acidphase
Details
NVIDIA-Linux-x86_64-319.17-no-compat32.patch (17.24 KB, patch)
2013-05-29 21:00 UTC, Acidphase
Details | Diff

Description Acidphase 2013-05-22 21:02:11 UTC
Since 3.10-rc1 the proprietary nvidia drivers fail to build against the kernels rc1 and rc2. Attached is the build log.

Running Gentoo x86_64 (amd64), Even though in this attempt I tried to merge the  
319.17 version I had also tried previous versions with the same result.
Comment 1 Acidphase 2013-05-22 21:05:09 UTC
Created attachment 102271 [details]
Build Log from portage
Comment 2 Acidphase 2013-05-29 21:00:15 UTC
Created attachment 102881 [details]
NVIDIA-Linux-x86_64-319.17-no-compat32.patch

Found working patch from the nvidia developers forum.

https://devtalk.nvidia.com/default/topic/543728/linux/building-nvidia-driver-on-kernel-3-9-0/post/3814531/#3814531

How to apply patch in Gentoo: 

Just let epatch_user do the work. All you need to do is create a nvidia-drivers dir in /etc/portage/patches/x11-drivers/

So download patch cp ~/Downloads/NVIDIA-Linux-x86_64-319.17-no-compat32.patch /etc/portage/patches/x11-drivers/nvidia-drivers

Then just emerge nvidia-drivers or module-rebuild rebuild

This patch works with 3.10-rc3 and nvidia drivers 319.23

Good luck,

Ron

Note You need to log in before you can comment on or make changes to this bug.