Bug 58661 - Battery life is too low
Summary: Battery life is too low
Status: CLOSED WILL_NOT_FIX
Alias: None
Product: Power Management
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Rafael J. Wysocki
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-22 20:58 UTC by Julien Jorge
Modified: 2013-12-27 01:08 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.8.0
Tree: Mainline
Regression: No


Attachments
PowerTop output, "Idle Stats" tab (1.57 KB, text/plain)
2013-11-17 08:52 UTC, Julien Jorge
Details
PowerTop output, "Device Stats" tab (3.07 KB, text/plain)
2013-11-17 08:52 UTC, Julien Jorge
Details
PowerTop output, "Overview" tab (2.31 KB, text/plain)
2013-11-17 08:53 UTC, Julien Jorge
Details
PowerTop output, "Frequency Stats" tab (2.61 KB, text/plain)
2013-11-17 08:53 UTC, Julien Jorge
Details

Description Julien Jorge 2013-05-22 20:58:58 UTC
I have a problem with the battery of my laptop, a Samsung 350V5C-S03FR with a 6-cells battery. When I boot Windows 7, I have something like 3 hours of work. When I boot Ubuntu, I have only 1 hour 20 minutes.

I tried to disable the bluetooth and the wifi and to reduce the brightness of the screen. I have now a battery life still near 1 h 20 min.

Then, to get the best of the best, I have run powertop and applied its advices to push the battery life to the unbelievable duration of 1 h 20 min.

I tried to use the non free drivers for my graphics card too. It did not change anything except that I did not have any graphic effect on my desktop.

Actually, even if I boot Ubuntu in rescue mode to display a simple root terminal, the battery life is still under 1 hour and a half.

I have this problem since Ubuntu 12.04 (kernel version was 3.2.0), it was still there in Ubuntu 12.10 (kernel was 3.5.0) and in 13.04 (kernel version is now 3.8.0).

When I let the laptop idling, just displaying the desktop during 1 hour and 20 minutes, cpufreq-info tells me:

analyse du CPU 0 :
  pilote : acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1 2 3
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  limitation matérielle : 1.20 GHz - 2.50 GHz
  plage de fréquence : 2.50 GHz, 2.50 GHz, 2.40 GHz, 2.30 GHz, 2.20 GHz, 2.10 GHz, 2.00 GHz, 1.90 GHz, 1.80 GHz, 1.70 GHz, 1.60 GHz, 1.50 GHz, 1.40 GHz, 1.30 GHz, 1.20 GHz
  régulateurs disponibles : conservative, ondemand, userspace, powersave, performance
  tactique actuelle : la fréquence doit être comprise entre 1.20 GHz et 2.50 GHz.
                  Le régulateur "ondemand" est libre de choisir la vitesse
                  dans cette plage de fréquences.
  la fréquence actuelle de ce CPU est 1.20 GHz.
  des statistique concernant cpufreq:2.50 GHz:0,99%, 2.50 GHz:0,00%, 2.40 GHz:0,01%, 2.30 GHz:0,01%, 2.20 GHz:0,00%, 2.10 GHz:0,01%, 2.00 GHz:0,01%, 1.90 GHz:0,00%, 1.80 GHz:0,00%, 1.70 GHz:0,01%, 1.60 GHz:0,00%, 1.50 GHz:0,01%, 1.40 GHz:0,01%, 1.30 GHz:0,00%, 1.20 GHz:98,94%  (479)

The output is similar for the three other cores. 

Someone told me to check the status of ASPM with lcpci -vvv. I have kept only the lines that tell something about it:

00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09) (prog-if 00 [Normal decode])
        LnkCap: Port #2, Speed 8GT/s, Width x16, ASPM L0s L1, Latency L0 <256ns, L1 <8us
        LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
    LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
    LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4) (prog-if 00 [Normal decode])
    LnkCap: Port #1, Speed 5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <16us
    LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4) (prog-if 00 [Normal decode])
    LnkCap: Port #2, Speed 5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <16us
    LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Thames XT [Radeon HD 7670M] (prog-if 00 [VGA controller])
    LnkCap: Port #0, Speed 5GT/s, Width x16, ASPM L0s L1, Latency L0 <64ns, L1 <1us
    LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 09)
    LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 unlimited, L1 <64us
    LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
03:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
    LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <4us, L1 <64us
    LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+

What can I do to help you to find why the consumption is so high?
Comment 1 Aaron Lu 2013-07-11 07:05:27 UTC
What's the idle status? powertop should tell you this.
Comment 2 Julien Jorge 2013-11-17 08:52:05 UTC
Created attachment 114921 [details]
PowerTop output, "Idle Stats" tab
Comment 3 Julien Jorge 2013-11-17 08:52:55 UTC
Created attachment 114931 [details]
PowerTop output, "Device Stats" tab
Comment 4 Julien Jorge 2013-11-17 08:53:22 UTC
Created attachment 114941 [details]
PowerTop output, "Overview" tab
Comment 5 Julien Jorge 2013-11-17 08:53:51 UTC
Created attachment 114951 [details]
PowerTop output, "Frequency Stats" tab
Comment 6 Julien Jorge 2013-11-17 09:04:05 UTC
The output of PowerTop is attached in previous comments. Ubuntu's version is 13.10, kernel is 3.11.

Also, it seems that there is a fan rotating faster when the laptop is on battery than when it is plugged in.
Comment 7 Aaron Lu 2013-12-09 07:45:42 UTC
Are you aware of any kernel that gives you a long battery life?
Comment 8 Julien Jorge 2013-12-17 21:33:43 UTC
Unfortunately I never had a longer battery life since I have bought this computer. I tried to install older distributions but they all failed to boot, so it is of no help.

I have another laptop which is almost the same hardware, except for the graphic card (NVidia for this one, driver is nouveau, ATI for the other, free drivers too). This other laptop lasts 3 hours on battery (the batteries are the same).

My first guess is that the cause is in the ATI drivers, but the battery life is low even if I do not start X. Also, the proprietary drivers do not work on my laptop (I have no acceleration at all).

For information, the details of the laptops (in French, I could not find the english page):
 - Mine, Samsung NP35075C-S06FR: http://www.samsung.com/fr/consumer/it/notebook/essential/NP350V5C-S06FR-spec
 - The other, Samsung NP270E5E-X06FR: http://www.samsung.com/fr/consumer/it/notebook/high-performance/NP270E5E-X06FR-spec
Comment 9 Aaron Lu 2013-12-19 07:03:57 UTC
I know very little about graphics, but one thing is that if a device doesn't have a proper driver, it may consume more power as no code will be in charge of putting various unused parts of the GPU to off state, but that's only my guess. Considering no progress can be made here, I'll close it as won't fix. If you found something new feel free to re-open it.
Comment 10 Julien Jorge 2013-12-26 21:16:20 UTC
I have finally found a workaround for my problem.

First of all, I learned that my laptop has some kind of hybrid Intel/Radeon graphic card. When turning the radeon off with the following command, I can use the laptop on battery for more than 3 hours :)

  echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

That's the best solution I have found. Another solution is to remove either the intel driver or the radeon driver; then the lifetime on battery is 2 h.

So, the problem was in the drivers not being able to switch a card off. As far as I know it was a well known problem.

Thanks for the help.
Comment 11 Aaron Lu 2013-12-27 01:08:14 UTC
Glad to know this, thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.