Bug 58531 - lenovo X220i, sometimes after suspend, cpu is very hot
Summary: lenovo X220i, sometimes after suspend, cpu is very hot
Status: CLOSED DOCUMENTED
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: acpi_power-sleep-wake
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-20 12:03 UTC by Account Disabled
Modified: 2013-06-05 13:44 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.8.3
Tree: Mainline
Regression: No


Attachments
some info: uname, lspci -vvv, lsmod, lshw (27.57 KB, application/octet-stream)
2013-05-20 12:03 UTC, Account Disabled
Details

Description Account Disabled 2013-05-20 12:03:10 UTC
Created attachment 102041 [details]
some info: uname, lspci -vvv, lsmod, lshw

OS: Debian sid/testing (7.0)
PROBLEM ON KERNELs: <=3.8.3

Description:
I always suspend (command pm-suspend) system instead shut it down. Sometimes (1 of 10 times) when I wake my computer, the temperature of CPU is high. It is ~60°C instead ~48°C (normally). htop shows that every processes is less then 4% usage of CPU so this is not problem with system (I think).

I also upgrade my bios to the newest version (download from lenovo website) but problem is still enable. I don't use another OS so I can't detect a source of problem (hardware or software).

How to fix:
Suspend and wake system again.

Sorry if I double bug but I didn't find any similar problem with this.
Sorry about my bad English...
Comment 1 Aaron Lu 2013-05-29 01:21:48 UTC
Which cpu frequency driver are you using, acpi_cpufreq or intel_pstate? Thanks.
Comment 2 Account Disabled 2013-05-29 10:22:22 UTC
I use acpi_cpufreq driver, I think. In my previous attachments there is output of lsmod command.
Comment 3 Lan Tianyu 2013-05-29 11:27:08 UTC
Please try the intel_pstate driver which is normally recommended.
Comment 4 Account Disabled 2013-05-29 16:38:01 UTC
Thank you for advice. I didn't upgrade my kernel for a long time and I didn't know about this module. Now I have 3.9.3 kernel with set intel_pstate and I see the difference of scaling my processor. It is more flexible.

If it doesn't solve my problem, I will write about this (I hope so not). Now I have to observe this for a while...
Comment 5 Account Disabled 2013-06-05 12:45:09 UTC
I think that one week is enough and I can say that intel_pstate is module which solves my problem. Once, when I woke my laptop, the power button started blink, but of course this is another problem and I heard that this is popular bug in mainline 3.9.

I have a one question. Which processor family I should use: 'Generic-x86-64' or 'Core 2' to this laptop? I have i3-2310M processor.

Thanks a lot!
Comment 6 Lan Tianyu 2013-06-05 13:44:37 UTC
Ok. So close this bug since intel_pstate driver work normally.
From my opinion, it should be Generic-x86-64.

Note You need to log in before you can comment on or make changes to this bug.