Bug 5836 - USB disconnect/connect continuously
USB disconnect/connect continuously
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 high
Assigned To: Greg Kroah-Hartman
:
Depends on: 6078
Blocks: USB
  Show dependency treegraph
 
Reported: 2006-01-05 11:21 UTC by Luigi Carlotto
Modified: 2014-03-21 09:20 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.14-1.1653_FC4
Tree: Mainline
Regression: ---


Attachments

Description Luigi Carlotto 2006-01-05 11:21:05 UTC
Most recent kernel where this bug did not occur: ?

Distribution: Fedora 4

Hardware Environment: MB Asus P4B533-E, Intel Pentium 4 2.4GHz, 6 x usb2

Software Environment:

Problem Description: 

In order to begin I make excuses myself for my English bad one.

My system is an Intel 486 2.4GHz on the motherboard Asus P4B533-E, with
operating system Fedora 4 - kernel 2.6.14-1.1653_FC4 not ricompiled (default). I
have a problem with a harddisk external usb2, than sconnette continuously. On an
other connector usb I have an other harddisk that instead it works without
problems. The harddisk that creates the error, comes mounted automatically from
automount, but after approximately 30 second ones it happens the logoff.
Immediately after the same one harddisk it comes autoremounting and to the
device it comes assigned an increasing and always various number: es.
/proc/scsi/usb-storage/0, 1, 2 etc...
The files in issue they contain:

/proc/scsi/usb-storage/0 (OK):
   Host scsi0: usb-storage
       Vendor: Prolific Technology Inc.
      Product: ATAPI-6 Bridge Controller
Serial Number: 200000002115
     Protocol: Transparent SCSI
    Transport: Bulk
       Quirks:

/proc/scsi/usb-storage/? (NOK):
   Host scsi3: usb-storage
       Vendor: Unknown
      Product: USB 2.0 Storage Device
Serial Number: 03669562100000000230
     Protocol: Transparent SCSI
    Transport: Bulk
       Quirks:

System log (dmesg):

usbcore: registered new driver usbfs
usbcore: registered new driver hub
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
usb 1-3: new high speed USB device using ehci_hcd and address 2
usb 4-2: new low speed USB device using uhci_hcd and address 2
usb 4-2: new low speed USB device using uhci_hcd and address 3
usb 4-2: new low speed USB device using uhci_hcd and address 5
usb 4-2: new low speed USB device using uhci_hcd and address 6
usb 4-2: new low speed USB device using uhci_hcd and address 7
usb 4-2: device not accepting address 7, error -71
usb 4-2: new full speed USB device using uhci_hcd and address 8
usb 4-2: device not accepting address 8, error -71
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new driver usb-storage
usb-storage: device scan complete
usb 1-1: new high speed USB device using ehci_hcd and address 4
usb-storage: device found at 4
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
usb 1-1: USB disconnect, address 4
usb 1-1: new high speed USB device using ehci_hcd and address 5
usb-storage: device found at 5
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
usb 1-1: USB disconnect, address 5
usb 1-1: new high speed USB device using ehci_hcd and address 6
usb-storage: device found at 6
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
usb 1-1: USB disconnect, address 6
...
...
...

Instead on a system slackware 10.2 with kernel 2,4 the harddisk it works well.
Same thing on systems Windows XP. Unfortunately I do not have possibility to
test this problem on kernel 2.6.x various ones.

Steps to reproduce:
Enough to connect the cable usb and to ignite the external device.

If necessary I can supply ulterior information.
Thanks
Comment 1 Greg Kroah-Hartman 2006-01-16 10:18:22 UTC
Does this happen on 2.6.15?

If only on a fedora kernel, please file this in a fedora bugzilla.
Comment 2 Luigi Carlotto 2006-01-17 03:26:46 UTC
I have placed the same question also on fedora.bugzilla, but I have still not
had resolution. Thanks however.
Comment 3 amth 2006-01-28 05:40:48 UTC
This bug is valid on Mandriva cooker with kernel-2.6.16.rc1, so not just with  
Fedora. 
 
Mandriva bug: http://qa.mandriva.com/show_bug.cgi?id=20756 
Comment 4 Luigi Carlotto 2006-01-28 16:14:19 UTC
Thanks,
Scusami for my English bad one, unfortunately I use a translator software, for
which the result protrebbe not perfect being.

I have read the bugs as you have suggested to me, but the only test that I had
still not made is that one to replace the cable usb. I will try also to change
usb controller, even if creed to have already made it.
Thanks to my retailer, I have made many tests with several containers usb and,
except that ATAPI that works, all had the same problem.
A question: why external disc "ATAPI-6 Bridge Controller" works perfectly? I
must not have the same problem also with this?
In the case it must install a patch, like indicated in some of the bug that you
have indicated to me, like making it?

Thanks still.
Comment 5 amth 2006-01-28 16:48:55 UTC
Well, it seems that this is a bug on ECHI/OCHI as I not able to reproduce this 
bug when my USB Storage Devices are connected to UCHI Host Controllers, no 
matter in what combination, as long as there is no ECHI/OCHI Host Controller 
with both USB Storage Device with a real storage drive (filesystem with an 
partition) _and_ a storage device _without_ a filesystem/partition. 
 
Just read about it from those other bug reports linked to 
http://bugzilla.kernel.org/show_bug.cgi?id=5089 
 
So it seems that the only way for the moment is to not use more than one USB 
Storage device on ECHI/OCHI Host Controller, and keep other USB Storage Devices 
on either UCHI, or possibly systems with UCHI-based ECHI, like chipsets from 
Intel or Nec seem to work like they should, but not OCHI-based ECHI chipsets 
like found of all VIA/Nvidia/ALi and others. :-( 
 
I surely hope that this kind of pretty severe bug would get fixed as soon as 
possible as it renders quite a few systems unstable to use any USB Storage 
Devices on their systems. 
Comment 6 Luigi Carlotto 2006-01-29 06:03:16 UTC
Thanks to you very of the answer, and the confirmation of my doubt that the
problem was a bug of the usb driver. I will follow your council, also why forced
from the circumstances. If I have understood well, I will have to try hub usb or
one storage device compatible UCHI Intel/Nec.

Thanks still
Comment 7 Greg Kroah-Hartman 2006-02-14 17:36:41 UTC
Should be fixed in 2.6.16-rc3 now.  Please reopen if not.
Comment 8 Luigi Carlotto 2006-02-15 03:21:54 UTC
I have modernized Fedora kernel to the 2.6.15-1.1831_FC4 but unfortunately the
problem is remained.
At the moment I have not had way to try a hub of characteristics similar to
those advising.
Comment 9 amth 2006-02-15 03:27:31 UTC
I can confirm this is still a valid bug with Mandriva cooker's 
kernel-linus-2.6.16-rc3.9mdk that is a vanilla kernel off the kernel.org. 
Comment 10 Greg Kroah-Hartman 2006-03-05 15:26:47 UTC
Ok, found the problem, should be fixed in 2.6.16-rc5.  If not, please let me
know.
Comment 11 Keef 2014-03-21 07:06:36 UTC
Still seems to be present in 2.6-32-5-686 :(
Comment 12 Keef 2014-03-21 09:20:20 UTC
root@hpt:~# uname -a
Linux hpt 2.6.32-5-686 #1 SMP Mon Sep 23 23:00:18 UTC 2013 i686 GNU/Linux

root@hpt:~# less /var/log/syslog | grep "USB disconnect, address" | wc -l
132

root@hpt:~# lsusb
Bus 001 Device 091: ID 05a9:a511 OmniVision Technologies, Inc. OV511+ Webcam
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

root@hpt:~# lspci
00:00.0 Host bridge: Broadcom GCNB-LE Host Bridge (rev 32)
00:00.1 Host bridge: Broadcom GCNB-LE Host Bridge
00:02.0 RAID bus controller: Silicon Image, Inc. SiI 0649 Ultra ATA/100 PCI to ATA Host Controller (rev 02)
00:03.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5702X Gigabit Ethernet (rev 02)
00:04.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
00:05.0 System peripheral: Compaq Computer Corporation Advanced System Management Controller
00:09.0 Ethernet controller: Accton Technology Corporation SMC2-1211TX (rev 10)
00:0f.0 ISA bridge: Broadcom CSB6 South Bridge (rev a0)
00:0f.1 IDE interface: Broadcom CSB6 RAID/IDE Controller (rev a0)
00:0f.2 USB Controller: Broadcom CSB6 OHCI USB Controller (rev 05)
00:0f.3 Host bridge: Broadcom GCLE-2 Host Bridge

Note You need to log in before you can comment on or make changes to this bug.