Bug 58021 - [BISECTED] nouveau, nv50: External VGA not detected anymore
[BISECTED] nouveau, nv50: External VGA not detected anymore
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
i386 Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-12 09:25 UTC by wippbox
Modified: 2013-06-20 07:40 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.7.0-rc4+ - 3.9
Tree: Mainline
Regression: No


Attachments
dmesg for last good commit (58.50 KB, application/octet-stream)
2013-05-12 09:25 UTC, wippbox
Details
dmesg for first bad commit (58.43 KB, application/octet-stream)
2013-05-12 09:26 UTC, wippbox
Details
Dmesg using kernel 3.8.11 (59.36 KB, text/plain)
2013-05-29 13:26 UTC, Per Arnold Blåsmo
Details
Dmesg using kernel 3.9.4 (bad) (60.70 KB, text/plain)
2013-05-29 13:27 UTC, Per Arnold Blåsmo
Details

Description wippbox 2013-05-12 09:25:53 UTC
Created attachment 101211 [details]
dmesg for last good commit

I have a lenove thinkpad T61p with a NVIDIA Corporation G84GLM [Quadro FX 570M].
When connecting my external VGA monitor my monitor is no more detected properly:
> cat /sys/class/drm/card0-VGA-1/status
gives now "disconnected"

Last good commit is
ef22c8bb7b3fac45919b7fde412d36d1a8367d51
drm/nv50/disp: call into core to handle dac/sor power state changes

First bad commit is
7ebb38b556485449bfaa506a196439f6a6fd6ebd
drm/nv50/disp: call into core for dac load detection

The responsible function is
nv50_dac_detect in drivers/gpu/drm/nouveau/nv50_dac.c (moved to drivers/gpu/drm/nouveau/nv50_display.c in more recent kernels).

Also tried a 3.9.1 kernel. The problem still remains.

However, replacing nv50_dac_detect with the corresponding version from the last good commit fixed the problem (tried a 3.8.10 kernel).
Comment 1 wippbox 2013-05-12 09:26:26 UTC
Created attachment 101221 [details]
dmesg for first bad commit
Comment 2 Per Arnold Blåsmo 2013-05-29 13:15:11 UTC
I seem to have much of the same problem.
I am running a Dell desktop with  NVIDA Quadro NVS 295 graphic card and two identical Dell monitors attache via DisplayPort.

I run Fedora 18 with all latest updates and using Nouveau drivers.

Starting with Kernel 3.8.11 it boots OK and both monitors works as expected.
Starting with Kernel 3.9.2, 3.9.3 or 3.9.4 boots and when trying to display anything on monitor two it gets into problems.

It boots until its tries to start the Xorg server and then monitor 2 starts flickering on and off. Monitor 1 stays with the boot logo of fedora.

Also during boot when booting I only have the boot logo of fedora on monitor 1 when running kernel 3.9.x while I have it on both screens when running kernel 3.8.11

I am able to hit CTRL+f2 to get a text login.

I will attache my dmesg output for both kernels.
Comment 3 Per Arnold Blåsmo 2013-05-29 13:26:24 UTC
Created attachment 102831 [details]
Dmesg using kernel 3.8.11
Comment 4 Per Arnold Blåsmo 2013-05-29 13:27:03 UTC
Created attachment 102841 [details]
Dmesg using kernel 3.9.4 (bad)
Comment 5 wippbox 2013-05-29 14:50:19 UTC
I don't that this is related to this bug. Here the monitor stays blank as soon as the nouveau driver is loaded.

For more info:
https://bugs.freedesktop.org/show_bug.cgi?id=64904
Comment 6 wippbox 2013-06-20 07:40:23 UTC
Solved in https://bugs.freedesktop.org/show_bug.cgi?id=64904

Note You need to log in before you can comment on or make changes to this bug.