Bug 5793 - can't wake on ASUS P5LD2-VM 64-bit
Summary: can't wake on ASUS P5LD2-VM 64-bit
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Shaohua
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-28 09:42 UTC by Oleksij Rempel (fishor)
Modified: 2007-03-07 23:33 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.15-mm3 >
Tree: Mainline
Regression: ---


Attachments
dsdt (31.86 KB, application/octet-stream)
2005-12-28 09:43 UTC, Oleksij Rempel (fishor)
Details
lspci (9.37 KB, text/plain)
2005-12-28 09:44 UTC, Oleksij Rempel (fishor)
Details
dmesg-2.6.15-rc7 (14.60 KB, text/plain)
2005-12-28 09:45 UTC, Oleksij Rempel (fishor)
Details
kernel 2.6.14 oops + function disassm (6.71 KB, text/plain)
2005-12-29 02:24 UTC, Oleksij Rempel (fishor)
Details
lspci after resume (11.69 KB, text/plain)
2006-01-05 02:16 UTC, Oleksij Rempel (fishor)
Details
lspci before sleep (11.69 KB, text/plain)
2006-01-05 02:17 UTC, Oleksij Rempel (fishor)
Details

Description Oleksij Rempel (fishor) 2005-12-28 09:42:22 UTC
Most recent kernel where this bug did not occur: tested with 2.6.12 and 2.6.15-rc7
Distribution:ubuntu breezy 64-bit
Hardware Environment: Board ASUS P5LD2-VM (i945g + Celeron D)

Problem Description:
after 
echo mem > /sys/power/state
computer go down but on wake hardware waked up but no image on monitor and no
reaktion on eny buttons, SysRq too.
Comment 1 Oleksij Rempel (fishor) 2005-12-28 09:43:44 UTC
Created attachment 6896 [details]
dsdt
Comment 2 Oleksij Rempel (fishor) 2005-12-28 09:44:15 UTC
Created attachment 6897 [details]
lspci
Comment 3 Oleksij Rempel (fishor) 2005-12-28 09:45:47 UTC
Created attachment 6898 [details]
dmesg-2.6.15-rc7
Comment 4 Shaohua 2005-12-28 16:44:39 UTC
Does any hardware work after resume, such as NIC, keyboard?
So you think this is a recent regression. IS it possible you can try kernel 
between 2.6.12 and 2.6.15-rc7?
Comment 5 Oleksij Rempel (fishor) 2005-12-28 17:29:09 UTC
> So you think this is a recent regression.
No no. I mean i tested two kernels and it's didn't worked with both of them.

> Does any hardware work after resume, such as NIC, keyboard?
NIC ???
After resume hdd make some thing like power test. CPU fun begin working with max
speed (looks like ec is corrupted), normally min. On serial-console no output.
VGA no output. Keyboard: i tryed ctrl+alt+del it's not working and  alt+sysrq+b
- some times rebooted some times not.
Comment 6 Oleksij Rempel (fishor) 2005-12-28 17:42:21 UTC
With kernel 2.6.14 is same issue. I tested with different bios options:
ACPI version 2 (yes/no)
Suspend Mode (auto/s1/s3)
but didn't get positiv result.
Comment 7 Oleksij Rempel (fishor) 2005-12-28 17:47:13 UTC
With S1 it's generate falowing output with oops

echo 1 ? > /proc/acpi/sleep 
Stopping tasks: ==========|
[ACPI Debug]  String: [0x04] "SIOS"
ACPI: PCI interrupt for device 0000:04:00.0 disabled
ACPI: PCI interrupt for device 0000:00:1d.7 disabled
acpi_bus-0201 [02] bus_set_power         : Device is not power manageable
ACPI: PCI interrupt for device 0000:00:1d.3 disabled
ACPI: PCI interrupt for device 0000:00:1d.2 disabled
ACPI: PCI interrupt for device 0000:00:1d.1 disabled
ACPI: PCI interrupt for device 0000:00:1d.0 disabled
ACPI: PCI interrupt for device 0000:00:1b.0 disabled
PM: Entering standby sleep
 hwsleep-0284 [03] enter_sleep_state     : Entering sleep state [S1]
Back to C!
PM: Finishing wakeup.
BUG: soft lockup detected on CPU#0!
CPU 0:
Modules linked in: af_packet snd_hda_intel snd_hda_codec snd_pcm_oss
snd_mixer_oss snd_pcm snd_timer snd snd_page_alloc unix
Pid: 3138, comm: bash Not tainted 2.6.15-rc7-debug #2
RIP: 0010:[<ffffffff8012cf97>] <ffffffff8012cf97>{release_console_sem+296}
RSP: 0018:ffff81003df91cd8  EFLAGS: 00000246
RAX: 0000000000000000 RBX: ffffffff803a7140 RCX: 0000000000003ff6
RDX: 00000000ffffff01 RSI: 0000000000003ff6 RDI: 0000000000003ff6
RBP: 000000058025720b R08: 0000000000000005 R09: 00000000ffffffff
R10: ffff81003f5ce520 R11: 0000000000000000 R12: ffffffff80257397
R13: ffff81003df91c48 R14: ffff81003df91d08 R15: 0000003000000010
FS:  00002aaaab0576d0(0000) GS:ffffffff80438800(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 000000000060c000 CR3: 000000003f071000 CR4: 00000000000006e0

Call Trace:<ffffffff8012d246>{vprintk+571}
<ffffffff80201f8b>{acpi_hw_low_level_read+299}
       <ffffffff8012d2f4>{printk+141} <ffffffff8012d2f4>{printk+141}
       <ffffffff80118a9a>{setup_apic_nmi_watchdog+446}
<ffffffff80118b4b>{lapic_nmi_resume+16}
       <ffffffff80259265>{__sysdev_resume+22} <ffffffff80259507>{sysdev_resume+62}
       <ffffffff80143f98>{enter_state+442} <ffffffff80218399>{acpi_suspend+70}
       <ffffffff802184a3>{acpi_system_write_sleep+107}
<ffffffff8016519f>{vfs_write+199}
       <ffffffff80165299>{sys_write+69} <ffffffff8010e57e>{system_call+126}
       
ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 169
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 19 (level, low) -> IRQ 193
PCI: Setting latency timer of device 0000:00:1b.0 to 64
ACPI: PCI Interrupt 0000:00:1c.0[A] -> GSI 16 (level, low) -> IRQ 169
PCI: Setting latency timer of device 0000:00:1c.0 to 64
ACPI: PCI Interrupt 0000:00:1c.1[B] -> GSI 17 (level, low) -> IRQ 177
PCI: Setting latency timer of device 0000:00:1c.1 to 64
ACPI: PCI Interrupt 0000:00:1c.2[C] -> GSI 18 (level, low) -> IRQ 185
PCI: Setting latency timer of device 0000:00:1c.2 to 64
ACPI: PCI Interrupt 0000:00:1c.3[D] -> GSI 19 (level, low) -> IRQ 193
PCI: Setting latency timer of device 0000:00:1c.3 to 64
ACPI: PCI Interrupt 0000:00:1d.0[A] -> GSI 20 (level, low) -> IRQ 50
PCI: Setting latency timer of device 0000:00:1d.0 to 64
ACPI: PCI Interrupt 0000:00:1d.1[B] -> GSI 17 (level, low) -> IRQ 177
PCI: Setting latency timer of device 0000:00:1d.1 to 64
ACPI: PCI Interrupt 0000:00:1d.2[C] -> GSI 18 (level, low) -> IRQ 185
PCI: Setting latency timer of device 0000:00:1d.2 to 64
ACPI: PCI Interrupt 0000:00:1d.3[D] -> GSI 19 (level, low) -> IRQ 193
PCI: Setting latency timer of device 0000:00:1d.3 to 64
acpi_bus-0201 [03] bus_set_power         : Device is not power manageable
PCI: Enabling device 0000:00:1d.7 (0000 -> 0002)
ACPI: PCI Interrupt 0000:00:1d.7[A] -> GSI 20 (level, low) -> IRQ 50
PCI: Setting latency timer of device 0000:00:1d.7 to 64
PCI: Setting latency timer of device 0000:00:1e.0 to 64
ACPI: PCI Interrupt 0000:00:1f.1[A] -> GSI 18 (level, low) -> IRQ 185
ACPI: PCI Interrupt 0000:04:00.0[A] -> GSI 17 (level, low) -> IRQ 177
PCI: Setting latency timer of device 0000:04:00.0 to 64
e1000: eth0: e1000_watchdog_task: NIC Link is Up 100 Mbps Full Duplex
[ACPI Debug]  String: [0x04] "SIOW"
Restarting tasks... done 
Comment 8 Oleksij Rempel (fishor) 2005-12-29 02:24:23 UTC
Created attachment 6900 [details]
kernel 2.6.14 oops + function disassm
Comment 9 Oleksij Rempel (fishor) 2006-01-04 09:15:08 UTC
It's looks like you have some thing chenget. Now It can wake if Xorg is on and
CAN'T if init 1 with out x-server. 
Comment 10 Oleksij Rempel (fishor) 2006-01-04 09:16:27 UTC
Comment #7 i'll report as separet bug.
Comment 11 Oleksij Rempel (fishor) 2006-01-04 09:18:30 UTC
One problem more after wake with x-server ewery thing working but NIC not working.
Comment 12 Shaohua 2006-01-04 17:26:02 UTC
So only NIC can't work after resume, right? Could you please give me 
the 'lspci -vv' output after resume. Thanks!
Comment 13 Oleksij Rempel (fishor) 2006-01-05 02:16:56 UTC
Created attachment 6939 [details]
lspci after resume

NIC before sleep
Address: 00000000fee00000  Data: 403a
NIC after sleep
Address: 0000000000000000  Data: 0000
Comment 14 Oleksij Rempel (fishor) 2006-01-05 02:17:48 UTC
Created attachment 6940 [details]
lspci before sleep

This is correct one
Comment 15 Shaohua 2006-01-05 17:02:17 UTC
You are using MSI for NIC, right?
I already sent a patch out for such issue. please try.
http://marc.theaimsgroup.com/?l=linux-kernel&m=113642387900264&w=2
Comment 16 Oleksij Rempel (fishor) 2006-01-06 04:00:46 UTC
The patch is working. Thenks a lot.
Comment 17 Oleksij Rempel (fishor) 2006-01-11 14:05:20 UTC
With 2.6.15-mm3 is the same issue.
Comment 18 Shaohua 2006-01-11 18:57:43 UTC
Resolved means we already have patch.
If the patch goes base kernel, I'll mark it closed.
This one could bemarked as resolved.
Comment 19 Oleksij Rempel (fishor) 2006-01-12 02:20:33 UTC
OK. Sorry.
Comment 20 Len Brown 2007-03-07 23:33:20 UTC
Shaohua's patch in comment #15 shipped in Linux-2.6.17
closed.

Note You need to log in before you can comment on or make changes to this bug.