Bug 5725 - Boot error message "Failed to allocate IO resource #7:1000@10000"
Boot error message "Failed to allocate IO resource #7:1000@10000"
Status: REJECTED INVALID
Product: Drivers
Classification: Unclassified
Component: PCI
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 5829
  Show dependency treegraph
 
Reported: 2005-12-11 06:11 UTC by Vince C.
Modified: 2006-01-04 14:50 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.15_rc[12345]
Tree: Mainline
Regression: ---


Attachments

Description Vince C. 2005-12-11 06:11:30 UTC
Most recent kernel where this bug did not occur: 2.6.12.xx
Distribution: Gentoo Linux
Hardware Environment: Dell Inspiron 6000 (i915GM, 512 MB RAM, 60GB SATA HD)
Software Environment: 

Problem Description:
PCI Boot error message "Failed to allocate IO resource #7:1000@10000"
Checking dmesg also shows there are bogus resources:
PCI: Ignore bogus resource 6 [0:0] of 0000:00:02.0
PCI: Failed to allocate I/O resource #7:1000@10000 for 0000:00:1e.0

$ lspci | egrep '00:02.0|00:1e.0'
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML
Express Graphics Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
Steps to reproduce:
1. Boot with recent kernels

Actual Results:  
PCI resource Error message but the system continues to boot normally. No crash
occurs.

Expected Results:  
No error message

More information:
I have a Dell Inspiron 6000 and other users also reported that message with
kernels >2.6.13. I have tried workarouds for HP (i.e. patching
drivers/acpi/scan.c as of https://bugzilla.novell.com/show_bug.cgi?id=116763)
but that didn't work.

On my Dell machine, the resource IO error messages are about the PCI bridge and
the graphics adapter, i915GM. I didn't try kernel argument pci=noacpi.
Comment 1 Vince C. 2005-12-31 11:18:34 UTC
I tried Ubuntu Dapper Flight 2 ( https://wiki.ubuntu.com/DapperFlight2 ) and it
exhibits the same behaviour - it's also based on 2.6.15 series.
Comment 2 Greg Kroah-Hartman 2006-01-04 14:40:42 UTC
The message can be safely ignored.
Comment 3 Vince C. 2006-01-04 14:50:31 UTC
If the error message can be safely ignored, isn't it some way to have it
disappear - by tuning kernel config for instance? I'm just curious about what
triggered it; is it due to a BIOS bug? Does it have something to do with the
DSDT for instance?

Anyway thanks for having taken your time to investigate.

Note You need to log in before you can comment on or make changes to this bug.