Bug 5722 - Buffer I/O error on device sr0, logical block 1
Buffer I/O error on device sr0, logical block 1
Status: REJECTED INVALID
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
i386 Linux
: P2 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-11 03:22 UTC by Nicolas Mailhot
Modified: 2006-05-03 07:38 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.14-1.1750_FC5 (2.6.15-rc5-git1)
Tree: Mainline
Regression: ---


Attachments
dmesg command output (22.92 KB, text/plain)
2005-12-11 03:24 UTC, Nicolas Mailhot
Details
lspci -vv output (20.40 KB, text/plain)
2005-12-11 03:24 UTC, Nicolas Mailhot
Details
grep -i sda /var/log/messages* (17.38 KB, text/plain)
2006-04-30 05:03 UTC, Jarno
Details

Description Nicolas Mailhot 2005-12-11 03:22:17 UTC
Most recent kernel where this bug did not occur:

This was working very recently, maybe a week ago (rawhide kernels which follow
mainline closely)


Distribution:
Fedora Core Devel


Hardware Environment:
PLEXTOR   Model: DVDR   PX-716A    Rev: 1.09 on nVidia Corporation CK804 Serial
ATA Controller


Problem Description:
Accesses to the DVD drive are failing this week (worked fine with the same disk
a week ago) and dmesg shows :

end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0
end_request: I/O error, dev sr0, sector 8
Buffer I/O error on device sr0, logical block 1
Buffer I/O error on device sr0, logical block 2
Buffer I/O error on device sr0, logical block 3
Buffer I/O error on device sr0, logical block 4
Buffer I/O error on device sr0, logical block 5
Buffer I/O error on device sr0, logical block 6
Buffer I/O error on device sr0, logical block 7
Comment 1 Nicolas Mailhot 2005-12-11 03:24:16 UTC
Created attachment 6794 [details]
dmesg command output
Comment 2 Nicolas Mailhot 2005-12-11 03:24:43 UTC
Created attachment 6795 [details]
lspci -vv output
Comment 3 Adrian Bunk 2005-12-18 17:46:08 UTC
Please confirm whether
- it still works in 2.6.14.4 and
- it is still broken in 2.6.15-rc6.

Comment 4 Nicolas Mailhot 2005-12-29 10:00:13 UTC
Thank you very much for looking into this. I'm sorry I couldn't follow up on
this quickly - Christmas time you know.

I'll try to re-test with an earlier kernel and the latest Raw Hide kernel by jan
2nd. I've realized since the report the test disk is one of the new drm-ed
silver disks, so maybe something changed which makes the "protection" effective
when it wasn't before.

Or maybe the problem is in the userspace updates that happened in Rawhide at
about the same time.

Anyway, re-testing with an older kernel should show whether it's an userspace
(udev ?) or kernel problem.

Happy New Year!
Comment 5 Jarno 2006-04-30 05:03:59 UTC
Created attachment 7997 [details]
grep -i sda /var/log/messages*

Kernel Version	2.6.15-1.1833_FC4
Distro Name	Fedora Core release 4 (Stentz)
Comment 6 Martin J. Bligh 2006-05-03 07:38:08 UTC
Please file fedora bugs in their own bugzilla, or reproduce on mainline

Note You need to log in before you can comment on or make changes to this bug.