Bug 5709 - sata_promise: missing pci id for FastTrak S300 TX2plus
sata_promise: missing pci id for FastTrak S300 TX2plus
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
i386 Linux
: P2 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-07 13:35 UTC by dev
Modified: 2006-10-05 14:43 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.14-2
Tree: Mainline
Regression: ---


Attachments

Description dev 2005-12-07 13:35:36 UTC
The FastTrak S300 TX2Plus seems to be just a S150 with higher transfer speed and
works fine with the sata_promise driver. Original Promise GPL drivers use same
driver for both without modification too. A humble request that the device id
will be added to the driver.
trivial diff:
211,212d210
<       { PCI_VENDOR_ID_PROMISE, 0x3d73, PCI_ANY_ID, PCI_ANY_ID, 0, 0,
<         board_2037x },

Regards
Comment 1 Adrian Bunk 2006-10-05 14:43:20 UTC
Fixed since 2.6.15.

Note You need to log in before you can comment on or make changes to this bug.