Bug 5702 - Oops: Kernel panics if usb-mouse is attached during boot
Oops: Kernel panics if usb-mouse is attached during boot
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 blocking
Assigned To: David Brownell
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2005-12-05 11:37 UTC by Emil Karlson
Modified: 2006-01-05 08:22 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.15-rc5-mm1
Tree: Mainline
Regression: ---


Attachments
lspci -vvv on appropriate system (9.60 KB, text/plain)
2005-12-05 11:39 UTC, Emil Karlson
Details
my hardware info (15.69 KB, text/plain)
2005-12-05 11:44 UTC, Emil Karlson
Details

Description Emil Karlson 2005-12-05 11:37:12 UTC
Most recent kernel where this bug did not occur:
2.6.15-rc-5-mm1

Distribution:
Gentoo-linux x86

Hardware Environment:
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge
(rev 80)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:09.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller
(rev 80)
00:0b.0 CardBus bridge: O2 Micro, Inc. OZ601/6912/711E0 CardBus/SmartCardBus
Controller (rev 20)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237
AC97 Audio Controller (rev 50)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller
(rev 80)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf [FireGL
9000] (rev 01)



Problem Description:

may be a duplicate of http://bugzilla.kernel.org/show_bug.cgi?id=5503
but problem is only present in mm-series

Oops: 0000 [#1]
last sysfs file:
Modules linked in:
CPU:    0
EIP:    0060:[<c030a5d8>]       Not tainted VLI
EFLAGS: 00010202        (2.6.15-rc5-mm1)
EIP is at echi_irq+0xb8/0x1c0
eax:    00000000        ebx:    00000004        ecx:    f8806710        edx:   
f7eb0200
esi:    00000000        edi:    f7eb02d0        ebp:    00000000        esp:   
c1b01d84
ds: 007b        es: 007b        ss: 0068
Process Swapper (pid: 1 threadinfo=c1b00000 task=c1afca70)
Stack:  <0>000023b3 000023b3 ffffffff 00000000 f7e83200 00000000 c1b01e04 00000000
        <0>c02f8ba9 f7e83200 c1b01e04 f7d63ec0 c013963d 0000000a f7e83200 c1b01e04
        <0>0000000a c046bcc0 0000000a f7d63ec0 c1b01e04 c01396d3 0000000a c1b01e54
Call Trace:
 [<c02f8ba9>] usb_hcd_irq+0x39/0x70
 [<c013963d>] handle_IRQ_event+0x3d/0x70
 [<c01396d3>] __do_IRQ+0x63/0xc0
 [<c021de2b>] vsnprintf+0x31b/0x5e0
 [<c0104699>] do_IRQ+0x19/030
 [<c0102ea2>] common_interrupt+0x1a/0x20
 [<c02f4c73>] usb_set_device_state+0x3/0x90
 [<c02f7f44>] register_root_hub+0x54/0x170
 [<c02f8f6c>] usb_add_hcd+0x22c/0x410
 [<c0301fc7>] usb_hcd_pci_probe+0x1f5/0x340
 [<c0125ea0>] __call_usermodehelper+0x0/0x70
 [<c022c366>] __pci_device_probe+0x56/0x70
 [<c022c4af>] pci_device_probe+0x2f/0x50
 [<c02a42e3>] driver_probe_device+0x43/0xd0
 [<c03afd1a>] klist_dec_and_del+0x1a/0x20
 [<c02a4400>] __driver_attach+0x0/0x90
 [<c02a447f>] __driver_attach+0x7f/0x90
 [<c02a37ed>] bus_for_each_dev+0x5d/0x80
 [<c02a44b6>] driver_attach+0x26/0x30
 [<c02a4400>] __driver_attach+0x0/0x90
 [<c02a3cf3>] bus_add_driver+0x83/0xf0
 [<c022c642>] __pci_register_driver+0x72/0xa0
 [<c016646b>] printk+0x1b/0x20
 [<c0487b45>] ehci_hcd_pci_init+0x25/0x30
 [<c0470807>] do_initcalls+0x57/0xd0
 [<c0100290>] init+0x0/0x160
 [<c01002b5>] init+0x25/0x160
 [<c0100fe3>] kernel_thread_helper+0x0/0xc
 [<c0100fe9>] kernel_thread_helper+0x5/0xc
Code: 3c 24 89 44 24 04 e8 18 fb ff ff 8b 5c 24 10 8b 74 24 14 b8 01 00 00 00 8b
7c 24 18 8b 6c 24 1c 83 c4 20 c3 8b 54 24 24 8b
 42 28 <0f> b6 80 44 01 00 00 83 e0 03 3c 03 75 av 8b 57 0c 8b 19 83 8a
 <0>Kernel panic - not syncing: Fatal exception in interrupt


Steps to reproduce:
boot 2.6.14-rc4-mm1 with mouse (logitech Mx310, usb) attached
Comment 1 Emil Karlson 2005-12-05 11:39:03 UTC
Created attachment 6772 [details]
lspci -vvv on appropriate system
Comment 2 Emil Karlson 2005-12-05 11:44:50 UTC
Created attachment 6773 [details]
my hardware info
Comment 3 Emil Karlson 2005-12-06 02:12:26 UTC
>> Steps to reproduce:
>> boot 2.6.14-rc4-mm1 with mouse (logitech Mx310, usb) attached

should be 2.6.15-rc5-mm1

also any mm-kernel later than 2.6.14-mm1 can reproduce the bug
Comment 4 Emil Karlson 2005-12-11 15:04:12 UTC
Most recent kernel where this bug did not occur:
2.6.15-rc-5-mm1

this obviously was the 2.6.14-rc4-mm1
Comment 5 Emil Karlson 2006-01-05 08:03:35 UTC
2.6.15-mm1 seems to work for me.

Note You need to log in before you can comment on or make changes to this bug.