Bug 5697 - Input via atkbd.c and psmouse.c becomes sporattic
Input via atkbd.c and psmouse.c becomes sporattic
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Input Devices
i386 Linux
: P2 normal
Assigned To: Dmitry Torokhov
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-03 21:12 UTC by Dan Serban
Modified: 2006-04-22 08:41 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.14
Tree: Mainline
Regression: ---


Attachments
Dmesg output from one of the computers. (30.61 KB, text/plain)
2005-12-27 22:34 UTC, Dan Serban
Details

Description Dan Serban 2005-12-03 21:12:19 UTC
Most recent kernel where this bug did not occur: 2.6.11
Distribution: Debian sid
Hardware Environment: Athlon XP 1800+ Single Processor, Startech 4port KVM switch.
Software Environment: Current sid base.
Problem Description: On boot with with vanilla kernel 2.6.1[2,3,4] my ps/2
devices start acting sporattically.  dmesg and /var/log/kern.log contains the
following message:

atkbd.c: Keyboard on isa0060/serio0 reports too many keys pressed.

There doesn't seem to be any warnings regarding the mouse itself, though I'm
sure the KVM is causing the mouse to act strangely as well (it works fine before
I switch to a different computer or for the first 30secs - 2 mins of operation
after a boot).

Seems that others are experiencing this "phenomenon" with other KVM switches
such as Belkin. (from searches via Google).

Steps to reproduce: Compile vanilla 2.6.12, 2.6.13, 2.6.14 and boot the system,
within seconds/minutes the keys start lagging out and the mouse goes crazy in
both gpm and X.org when you send input (ie. use it).  To specifically trigger
the effect, either use the machine for a few minutes, or switch ports via
(Ctrl+Ctrl+[1-4]) then switch back to the original machine with either the
hotkeys or via the front KVM button and the above warning messages are produced.
Comment 1 Dan Serban 2005-12-20 09:58:17 UTC
Is there any more information I can provide, or anything else I can try to
further bump this bug?  I'm at a loss, there is no information I can find on the
net regarding this specific issue, except that most people with startech/belkin
kvm's are experiencing the same problems.
Comment 2 Vojtech Pavlik 2005-12-20 11:53:28 UTC
Hmm, does "sporattic" meen something between "sporadic" and "erratic"?

Anyway, passing i8042.debug=1 on the kernel command line will add enough
debugging into your 'dmesg' output for us to be able to figure it out, hopefully.
Comment 3 Dan Serban 2005-12-27 22:34:04 UTC
Created attachment 6895 [details]
Dmesg output from one of the computers.

After enabling the debugging switch, this is what the dmesg output looks like
after a clean boot.  This is under kernel 2.6.14, about 20 seconds after the
system finished booting.
Comment 4 Dan Serban 2005-12-27 22:36:31 UTC
Is there a switch I can enable for debugging the mouse driver?  The mouse goes
nuts (as described in other bugs here), though admittedly I have not tried some
of the provided solutions or patches.  I'm under the impression that this KVM
switch seems to be the root of the problem overall, though only affected in
kernels after 2.6.11.
Comment 5 Dan Serban 2005-12-27 22:51:42 UTC
Ok, I've tried adding psmouse.proto=imps and it fixed the mouse issues.  The odd
part of all of this, is that it fixed the keyboard problems as well.  Which I'm
sure anyone would find quite odd.

Fixing the mouse fixed both the mouse and keyboard.  I can successfully switch
between any of the attached computers, and the one with the above kernel command
responds instantly and constantly well.

*shrug*
Comment 6 Dmitry Torokhov 2005-12-28 07:16:43 UTC
Ok, so your KVM gets confused by extended probes. Could you please try the 
first patch from bug 5703 - hopefully requesting a full reset before doing 
intellimouse/explorer probes will get KVM back to its senses. 
Comment 7 Adrian Bunk 2006-04-22 08:41:40 UTC
I'm assuming the patch from bug 5703 fixed this issue.

Please reopen this bug if it's still present in kernel 2.6.16.

Note You need to log in before you can comment on or make changes to this bug.