Bug 5692 - disable INPUT_WISTRON_BTNS when ACPI enabled
disable INPUT_WISTRON_BTNS when ACPI enabled
Status: REJECTED INVALID
Product: Drivers
Classification: Unclassified
Component: Platform
i386 Linux
: P2 normal
Assigned To: Zhang Rui
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2005-12-02 07:22 UTC by Luming Yu
Modified: 2013-04-09 06:13 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.15-rc3
Tree: Mainline
Regression: ---


Attachments
disabel INPUT_WISTRON_BTNS when ACPI enabled (477 bytes, patch)
2005-12-02 07:23 UTC, Luming Yu
Details | Diff
acpidump of Fujitsu-Siemens Amilo Pro V200 (86.45 KB, text/plain)
2005-12-07 06:33 UTC, Miloslav Trmac
Details
patch-add-warning-message-when-loading-wistron-driver (978 bytes, patch)
2007-11-06 23:05 UTC, Zhang Rui
Details | Diff

Description Luming Yu 2005-12-02 07:22:02 UTC
INPUT_WISTRON_BTNS should be disabled when ACPI enabled
Comment 1 Luming Yu 2005-12-02 07:23:05 UTC
Created attachment 6751 [details]
disabel INPUT_WISTRON_BTNS when ACPI enabled
Comment 2 Miloslav Trmac 2005-12-04 17:00:10 UTC
Quoting lkml mail:

Yu, Luming wrote:

>> I just tested module wistron_btn on  one Acer Aspire laptop after 
>> adding one dmi entry.  The wistron_btn found BIOS interfaces.
>> One visible error is the bluetooth light won't turn on upon 
>> stroking bluetooth button.
>> Without wistron_btn module, the bluetooth light works.
>>  with acpi enabled, I didn't try acpi disabled)
>> 
>> wistron_btn polls a cmos address to detect hotkey event.  It 
>> is not necessary, because there do have ACPI interrupt triggered upon 
>> hotkeys.

There are many different laptops using similar interfaces.
It is a mess  :( 

If your laptop provides the hotkey events via ACPI, simply don't use
wistron_btns.

>> So, my suggestion is to disable this module when ACPI enabled.

I have a laptop that needs this module (hotkeys are not supported via
ACPI), but supports ACPI.
	Mirek
Comment 3 Miloslav Trmac 2005-12-07 06:33:32 UTC
Created attachment 6778 [details]
acpidump of Fujitsu-Siemens Amilo Pro V200
Comment 4 Len Brown 2007-08-18 23:52:08 UTC
since ACPI is a run-time mode,
doesn't this need to be a run-time check,
rather than a build-time check?
Comment 5 Fu Michael 2007-10-24 01:36:14 UTC
Len, any idea of how to do the run-time check?
Comment 6 Zhang Rui 2007-11-06 19:54:28 UTC
So the problem is that there may be some potential conflicts between ACPI and wistron driver.
The laptops listed in the wistron dmi_ids table may also route the hotkey events to ACPI.
This can't be detected by ACPI or wistron driver.
Can we add a warning message when wistron driver is loaded?
Just tell the users to send an email with dmidecode attached if wistron driver breaks the laptop (some keys doesn't work like described in comment #2) so that we can remove the dmi entry for this box.
Comment 7 Zhang Rui 2007-11-06 23:05:43 UTC
Created attachment 13433 [details]
patch-add-warning-message-when-loading-wistron-driver
Comment 8 Miloslav Trmac 2007-11-06 23:12:35 UTC
I'm sorry, I don't see the point of warning users like this - is it at all likely that such a conflict will occur?

Was there ever a conflict between ACPI and the DMI mappings in winstron_btns?   Or are you going to add such a warning message to every non-ACPI driver that provides similar functionality to a separate ACPI driver?
Comment 9 Zhang Rui 2007-11-13 01:51:59 UTC
Well, I did some tests on an acer aspire 1520.
All the hotkey events are routed to the i8042 driver although the wireless and bluetooth are recognized as unknown key press. But the wireless and bluetooth lights are turned on while pressing them.
IMO, it works well with atkbd driver, and the wireless and bluetooth hotkey are probably handled by the bios, so there is no need to support this latop in wistron driver.

I didn't find any conflicts between ACPI and the current DMI mappings in winstron_btns. So you're right and please ignore the patch in comment #7. :)

I think we can close this bug and mark it as INVALID. Thanks.

Note You need to log in before you can comment on or make changes to this bug.