Bug 5674 - ACPI errors for Twinhead F10D (store into alias)
ACPI errors for Twinhead F10D (store into alias)
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Other
i386 Linux
: P2 low
Assigned To: Robert Moore
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-29 03:04 UTC by Felix Braun
Modified: 2006-02-02 15:03 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.14.3
Tree: Mainline
Regression: ---


Attachments
output of acpidump (100.02 KB, text/plain)
2005-11-29 03:05 UTC, Felix Braun
Details
output of dmidecode (13.97 KB, text/plain)
2005-11-29 03:06 UTC, Felix Braun
Details
/var/log/dmesg (12.23 KB, text/plain)
2005-11-29 03:12 UTC, Felix Braun
Details
output of lspci -vv (11.96 KB, text/plain)
2005-11-29 03:13 UTC, Felix Braun
Details

Description Felix Braun 2005-11-29 03:04:37 UTC
I have bought a new Twinhead F10D laptop (identical to Averatec AV1050). During
boot the ACPI subsystem reports these errors for all kernel versions that I have
tried (extracted from dmesg):

ACPI: Sleep Button (CM) [SLPB]
ACPI: Power Button (CM) [PWRB]
    ACPI-0140: *** Error: Store into Alias - should never happen
    ACPI-0508: *** Error: Method execution failed [\_SB_.PCI0.IGFX._DOS] (Node
c146c360), AE_AML_INTERNAL
ACPI: Video Device [IGFX] (multi-head: yes  rom: no  post: no)
ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
ACPI: Processor [CPU1] (supports 8 throttling states)
    ACPI-0140: *** Error: Store into Alias - should never happen
    ACPI-0508: *** Error: Method execution failed [\_TZ_.RTMP] (Node c146e400),
AE_AML_INTERNAL
    ACPI-0508: *** Error: Method execution failed [\_TZ_.THRM._TMP] (Node
c146e2e0), AE_AML_INTERNAL

I guess that as a result, the directory /proc/acpi/thermal_zone is left empty.
Apart from these error messages, I have not encoutered any functional problems.
Do these errors point to a bug in the ACPI subsystem, or is it rather the BIOS
implementation that is buggy?

I'll attach additional information. If you need any more information, please let
me know.
Comment 1 Felix Braun 2005-11-29 03:05:41 UTC
Created attachment 6710 [details]
output of acpidump
Comment 2 Felix Braun 2005-11-29 03:06:40 UTC
Created attachment 6711 [details]
output of dmidecode
Comment 3 Felix Braun 2005-11-29 03:12:08 UTC
Created attachment 6712 [details]
/var/log/dmesg
Comment 4 Felix Braun 2005-11-29 03:13:36 UTC
Created attachment 6713 [details]
output of lspci -vv
Comment 5 Robert Moore 2005-11-29 12:51:58 UTC
Problem reproduced from the acpidump. Seems to be an issue with the GDGS alias 
when executing this instruction:
 
   Method [RTMP] executing: [RTMP] @0008A #0070:  Store (NVGA, \GDGS)

Investigating.
Comment 6 Robert Moore 2006-01-25 13:26:54 UTC
Problem has been identified and will be fixed for the next release of ACPICA
Comment 7 Robert Moore 2006-01-27 14:18:02 UTC
Fixed in ACPICA version 20060127
Comment 8 Felix Braun 2006-01-31 03:51:36 UTC
Thanks for the fix. Will the new ACPICA code make it into kernel 2.6.16?
Comment 9 Len Brown 2006-02-02 14:42:59 UTC
ACPICA 20050127 shipped in Linux-2.6.16-rc1-git6 -- closing.
Comment 10 Len Brown 2006-02-02 15:03:16 UTC
20060127 that is

Note You need to log in before you can comment on or make changes to this bug.