Bug 5664 - Data Corruption with Kernel Version greater 2.6.10 on S-ATA System
Data Corruption with Kernel Version greater 2.6.10 on S-ATA System
Status: RESOLVED DUPLICATE of bug 6845
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
i386 Linux
: P2 high
Assigned To: Tejun Heo
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-26 16:51 UTC by Christian Buchberger
Modified: 2007-07-10 20:04 UTC (History)
2 users (show)

See Also:
Kernel Version: > 2.6.10
Tree: Mainline
Regression: ---


Attachments

Description Christian Buchberger 2005-11-26 16:51:33 UTC
Most recent kernel where this bug did not occur: 
    2.6.13 (SUSE 10 OSS) 2.6.12-10 (Ubuntu 5.10) 

Distribution: 
    SUSE 10 OSS / Ubuntu 5.10 / Fedora 4

Hardware Environment:
    Shuttle XPC SN85Gv2
    Motherboard FN85 
    NVIDIA nForce3 

    AMD Athlon(tm) 64 Processor 2800+

    RAID bus controller: Silicon Image, Inc. (formerly CMD Technology Inc) SiI
3512 (rev 1)
    Harddisk
    Vendor: ATA       Model: SAMSUNG SP1614C   Rev: SW10
    Type:   Direct-Access                      ANSI SCSI revision: 05


Software Environment: 

Problem Description:
Dear all,

writing data on SATA harddisk (Silicon Image 3512A Onboard-RAID) with kernel
versions greater than 2.6.10 cause sometimes errors in md5sum check espeacially
when large files are copied or moved. 

The same problem occurs under Ubuntu 5.10 Fedora Core 4, SuSE 9.3 with different
kernel versions. 

Memory and harddisk have been checked without any evidence.

With Ubuntu Hoary Hedgehog kernel 2.6.10-5-amd64-k8 everything work fine (libata
version 1.10 loaded; sata_sil version 0.8). Some x86 kernels (e.g. Knoppix) also
works without problems as well as Debian Sarge AMD64 (not really suprising,
isn't it?).

I guess I have tried nearly everything to figure out where the problem is
located - so I may give any additional information on request.

System description:
  Shuttle XPC SN85Gv2
  Motherboard FN85 
  NVIDIA nForce3 

  AMD Athlon(tm) 64 Processor 2800+

  RAID bus controller: Silicon Image, Inc. (formerly CMD Technology Inc) SiI
3512 (rev 1)
  Harddisk
  Vendor: ATA       Model: SAMSUNG SP1614C   Rev: SW10
  Type:   Direct-Access                      ANSI SCSI revision: 05

Steps to reproduce:

Copying a 700MB CD-ROM image with following script produce sometimes (50%) md5
checksum errors.

#!/bin/sh
cp mega_test.iso mega_test_01.iso
md5sum -c mega_test.md5
Comment 1 Natalie Protasevich 2007-07-08 16:50:37 UTC
Christian,
Have you tried latest kernels, was your problem fixed?
Thanks.
Comment 2 Christian Buchberger 2007-07-10 12:14:34 UTC
Dear Natalie,

I tried a lot of kernels and of cause the latest one. 

Bug 6845 describes a similar problem.

In my case the problem was solved by changing the main memory modules last week (from two Infineon 512MB to two 1GB Infineon/Quimoda modules).

This was more than surprising cause memtest86+ didn't report any error (and I tried it more than once over more than 10 hours).  

So I guess we could close this topic.

Thanks for your assistance,
ciao
Christian
Comment 3 Tejun Heo 2007-07-10 20:04:31 UTC
Okay, rejecting as duplicate of 6845.

*** This bug has been marked as a duplicate of bug 6845 ***

Note You need to log in before you can comment on or make changes to this bug.