Bug 56451 - Samsung NP530U3B and NP535U3C: Resume from suspend when lid is open doesn't work
Samsung NP530U3B and NP535U3C: Resume from suspend when lid is open doesn't work
Status: CLOSED DUPLICATE of bug 45461
Product: ACPI
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Lan Tianyu
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-10 08:55 UTC by mephisto
Modified: 2013-04-12 09:00 UTC (History)
3 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments
acpi_listen (197 bytes, application/octet-stream)
2013-04-10 08:55 UTC, mephisto
Details
/proc/acpi/wakeup (822 bytes, application/octet-stream)
2013-04-10 08:56 UTC, mephisto
Details
acpidump (201.21 KB, application/octet-stream)
2013-04-11 08:45 UTC, mephisto
Details

Description mephisto 2013-04-10 08:55:01 UTC
I attach acpi_listen when close lid, open lid and press power button.

And attach /proc/acpi/wakeup too.
Comment 1 mephisto 2013-04-10 08:55:38 UTC
Created attachment 97961 [details]
acpi_listen
Comment 2 mephisto 2013-04-10 08:56:11 UTC
Created attachment 97971 [details]
/proc/acpi/wakeup
Comment 3 Aaron Lu 2013-04-11 06:20:52 UTC
acpidump please:
# acpidump > acpidump.out

Thanks.
Comment 4 Lan Tianyu 2013-04-11 06:32:30 UTC
Hi Aaron:
         All info in the bug45461 "Samsung NP530U3B and NP535U3C lid close does not suspend". They are sister bugs ...
        I have found a strange things about the lids state..
Comment 5 Aaron Lu 2013-04-11 07:47:29 UTC
I just disassembled this acpidump attached there:
https://bugzilla.kernel.org/attachment.cgi?id=82311

And the LID device does not have any _PRW method indicating it is able to wake up the system from a sleeping state, so I think this "problem" is expected.

Hi mephisto,
Did you used to be able to resume the system on LID open? Or if you have windows, can windows resume from suspend on LID open? Thanks.
Comment 6 mephisto 2013-04-11 08:43:02 UTC
Aaron, yes, it can.
Comment 7 mephisto 2013-04-11 08:45:06 UTC
Created attachment 98091 [details]
acpidump

root@mephisto-book:/home/mephisto# acpidump > acpidump.out
Wrong checksum for FADT!
Comment 8 Aaron Lu 2013-04-11 08:55:08 UTC
From which kernel you start to have this problem?
Comment 9 mephisto 2013-04-11 08:58:45 UTC
All kernels. Now, i'm on Ubuntu 13.04 (3.8 kernel).
Comment 10 Aaron Lu 2013-04-11 08:59:49 UTC
So by "it can", you mean under windows, right?
Comment 11 mephisto 2013-04-11 09:06:47 UTC
Yes. Under Windows all work perfectly.
Comment 12 Aaron Lu 2013-04-11 09:13:40 UTC
Then perhaps you can try to enable wakeup for the devices listed in /proc/acpi/wakeup, one by one see if any of them makes a difference.
Comment 13 mephisto 2013-04-11 09:19:58 UTC
Nothing works.
Comment 14 Lan Tianyu 2013-04-12 06:46:16 UTC
Hi:
    Sorry for late response. Does this issue happen after following operations?

 - power off the laptop
 - press the button at the bottom for 10 seconds
 - boot in linux
 - should work

Your machine is NP530U3B, right?

BTW, we try to fixing all acpi related bugs but for some bios issues, specially some machines' manufacture only care Windows. We really have no good way. Please understand. Thanks.
Comment 15 mephisto 2013-04-12 08:48:46 UTC
This is fix it, but for a short time. 4-5 days.
Comment 16 Lan Tianyu 2013-04-12 08:56:04 UTC
Ok. So this is as same as bug45461. So close this bug as duplicate. Ok?
Comment 17 mephisto 2013-04-12 08:58:06 UTC
I agree, but https://bugzilla.kernel.org/show_bug.cgi?id=45461#c68
Comment 18 Lan Tianyu 2013-04-12 09:00:28 UTC
No problem, I will explain :)

*** This bug has been marked as a duplicate of bug 45461 ***

Note You need to log in before you can comment on or make changes to this bug.