Bug 56381 - ideapad-laptop driver does not unblock the wireless card form hard block
Summary: ideapad-laptop driver does not unblock the wireless card form hard block
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Platform_x86 (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: drivers_platform_x86@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-08 12:20 UTC by zdravakost
Modified: 2015-04-06 23:14 UTC (History)
5 users (show)

See Also:
Kernel Version: all
Tree: Mainline
Regression: No


Attachments
dmesg output (53.70 KB, text/plain)
2013-11-20 09:04 UTC, zdravakost
Details
dmesg | grep -E 'cfg|ath9k' output (712 bytes, text/plain)
2013-11-20 09:08 UTC, zdravakost
Details
rfkill list (194 bytes, text/plain)
2013-11-20 09:09 UTC, zdravakost
Details
cat /sys/class/rfkill/rfkill[0-9]*/* before fn+f5 (265 bytes, text/plain)
2013-11-20 09:10 UTC, zdravakost
Details
cat /sys/class/rfkill/rfkill[0-9]*/* after fn+f5 (265 bytes, text/plain)
2013-11-20 09:11 UTC, zdravakost
Details

Description zdravakost 2013-04-08 12:20:43 UTC
When press Fn+F5 (wireless hardware switch) on laptop Lenovo G585 it does not
unblock the wireless card (ath9k) from hard block, just changes the software
block from yes to no so I cannot use the wifi. The only way to unblock the
card is to use other OS for example Windows.
Comment 1 Tomáš Pružina 2013-04-18 17:16:26 UTC
Works for me on Z570 (iwlwifi), could you please provide relevant output from dmesg?
Comment 2 Tomáš Pružina 2013-04-18 19:19:44 UTC
ideapad platform code seems ok, judging by other reports, i'd say there is problem with ath9k rfkill unblock.

Try this workaround for the moment:
# rmmod ath9k && modprobe ath9k
Comment 3 zdravakost 2013-06-13 11:53:59 UTC
I will provide dmesg output soon.
Anyway rmmod ath9k && modprobe ath9k does not help.
The problem is that the command rfkill cannot unblock the wifi card (ath9k) from hardware lock. (The same result with Fn+F5). Maybe the problem is in the rfkill but I'm not sure.
Comment 4 zdravakost 2013-11-20 09:04:52 UTC
Created attachment 115181 [details]
dmesg output
Comment 5 zdravakost 2013-11-20 09:08:15 UTC
Created attachment 115191 [details]
dmesg | grep -E 'cfg|ath9k' output
Comment 6 zdravakost 2013-11-20 09:09:23 UTC
Created attachment 115201 [details]
rfkill list
Comment 7 zdravakost 2013-11-20 09:10:56 UTC
Created attachment 115211 [details]
cat /sys/class/rfkill/rfkill[0-9]*/* before fn+f5
Comment 8 zdravakost 2013-11-20 09:11:30 UTC
Created attachment 115221 [details]
cat /sys/class/rfkill/rfkill[0-9]*/* after fn+f5
Comment 9 zdravakost 2013-11-20 09:12:48 UTC
Let me know if you need additional info. THX for you effort.
Comment 10 zdravakost 2013-11-20 09:18:30 UTC
All info is taken from SystemRescueCd but the results are the same with all other distros (Centos, Debian, Ubuntu)
Comment 11 Miguel 2013-12-27 05:15:33 UTC
The bug:

https://bugzilla.kernel.org/show_bug.cgi?id=42898

Is it the same?
Comment 12 Alan 2013-12-27 11:30:43 UTC
No.. 42898 is about an HP device
Comment 13 Miguel 2013-12-27 15:26:42 UTC
Ok, sorry.
Comment 14 Miguel 2013-12-27 15:45:18 UTC
I care about getting this fixed, so I'm offering USD 50,00 via FreedomSponsors to the first person who fix it.

Offer link: http://www.freedomsponsors.org/core/issue/423/ideapad-laptop-driver-does-not-unblock-the-wireless-card-form-hard-block

You can also join me and throw in a few bucks there and we'll get it fixed faster :)
					
If you fix this issue (see my acceptance criteria there) please use that site to request your payment.
Comment 15 zdravakost 2014-01-15 08:58:11 UTC
I consider to close this bug because the combination fn+f5 on this Lenovo laptop model is related to Wireless and Bluetooth hardware switch and in Windows OS it pops up a graphical menu where you can choose Wireless or Bluetooth to enable or disable. I think that in Linux console fn+f5 will not have straight function and makes the things unclear. Maybe a separate key combination for Wireless and Bluetooth is needed as is in some other laptops.  What do you think about this ?
Comment 16 Miguel 2014-01-15 22:53:09 UTC
Hi.

The wifi switch (in one side) is on.

And I have been trying with your key combination (fn + f5) and the wifi is not run yet.

$ rfkill list all
0: ideapad_wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
1: ideapad_bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: yes
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes


Bye.
Comment 17 zdravakost 2014-01-16 08:53:58 UTC
Yes you cannot unblock the wifi card on this and similar laptop models so you can not use wifi under Linux if it is blocked (of course you can unblock it on other OS and use it under Linux after). 
The problem is that fn+f5 is related to Bluetooth and Wireless so maybe the proper behavior is to disable/enable both Wireless and Bluetooth because you can't have graphical menu under linux console for example. This is just what I think.
Comment 18 me 2014-07-31 03:02:15 UTC
On kernel 3.15.7 (gentoo patches), if I rmmod ideapad-laptop, it works properly. The moment ideapad-laptop module is loaded, wifi/bt gets hardblocked. There's really something wrong with the module.
Comment 19 Anthony O'Brien 2015-02-19 14:49:06 UTC
How many of you are dual booting? This problem Windows hard blocking the device, as well as a BIOS bug on some devices.
Comment 20 zdravakost 2015-04-06 10:53:16 UTC
I will close this bug because cannot test it anymore (obsolete).
Comment 21 Miguel 2015-04-06 23:14:02 UTC
But, What do you need?

I can help you.

Note You need to log in before you can comment on or make changes to this bug.