Bug 56081 - Kernel doesn't produce any power related uevents on Samsung NP535U3C
Kernel doesn't produce any power related uevents on Samsung NP535U3C
Status: CLOSED DUPLICATE of bug 45461
Product: ACPI
Classification: Unclassified
Component: Power-Battery
All Linux
: P1 normal
Assigned To: Lan Tianyu
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-01 20:26 UTC by Francescodario Cuzzocrea
Modified: 2013-04-02 10:05 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.9.0
Tree: Mainline
Regression: No


Attachments
acpidump.out output (203.94 KB, text/plain)
2013-04-02 06:06 UTC, Francescodario Cuzzocrea
Details
output of 'grep . /sys/firmware/acpi/interrupts/*' (on battery) (2.26 KB, text/plain)
2013-04-02 06:20 UTC, Francescodario Cuzzocrea
Details
output of 'grep . /sys/firmware/acpi/interrupts/*' (on AC) (2.26 KB, text/plain)
2013-04-02 06:22 UTC, Francescodario Cuzzocrea
Details

Description Francescodario Cuzzocrea 2013-04-01 20:26:17 UTC
I have a Samsung NP535U3C laptop.
When I'm plugging the ac adapter in or out I don't see any power
related uevents from the kernel with 'udevadm monitor' or 'udevadm monitor
--kernel'.

I've tried the solution proposed by Lan Tianye for bug #54621 but with no luck. Feel free to close my bug report, if you think that this symptoms are caused by the same bug. 
Tell me if you need more information. 

Thank you.
Comment 1 Lan Tianyu 2013-04-02 00:11:37 UTC
Please attach the output of acpidump.
Comment 2 Francescodario Cuzzocrea 2013-04-02 06:06:12 UTC
Created attachment 96941 [details]
acpidump.out output

Hello and thank you for your reply ! Here is my acpidump.out.
Comment 3 Francescodario Cuzzocrea 2013-04-02 06:20:38 UTC
Created attachment 96951 [details]
 output of 'grep . /sys/firmware/acpi/interrupts/*' (on battery)
Comment 4 Francescodario Cuzzocrea 2013-04-02 06:22:34 UTC
Created attachment 96961 [details]
 output of 'grep . /sys/firmware/acpi/interrupts/*' (on AC)
Comment 5 Lan Tianyu 2013-04-02 09:35:05 UTC
Comment #3 and Comment #4 are the output before and after plugging AC, right?
I see there is a log gpe.

How about acpi_list to catch acpi event? I am not very familiar with "udevadm monitor"?
Comment 6 Francescodario Cuzzocrea 2013-04-02 09:45:00 UTC
Yes about comment 3 and 4 ! acpi_listen doesn't give me output when I plug and unplug AC.
Comment 7 Lan Tianyu 2013-04-02 09:51:02 UTC
Does you lid work? I also see some Sunsamg machine have same problems with lid not work.
https://bugzilla.kernel.org/show_bug.cgi?id=45461
Comment 8 Francescodario Cuzzocrea 2013-04-02 09:58:00 UTC
Uhm, now that you tell it to me, also the lid close\open doesn't produce any udev event to acpi_listen or udevadm monitor. The simptoms are the same of bug #45461
Comment 9 Lan Tianyu 2013-04-02 10:03:29 UTC
Ok. Thanks for. mark this as duplicate to 45461. EC doesn't work smoothly on these  SunSamng machine.

*** This bug has been marked as a duplicate of bug 45461 ***

Note You need to log in before you can comment on or make changes to this bug.