Bug 5606 - usb stick not recognized, oops error
usb stick not recognized, oops error
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2005-11-14 01:49 UTC by Dominik Werder
Modified: 2005-12-21 19:16 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.13.2
Tree: Mainline
Regression: ---


Attachments

Description Dominik Werder 2005-11-14 01:49:37 UTC
Problem Description:

usb subsystem fails to recognize my new mp3 player. Can't figure out the vendor, 
it's the player tchibo (tcm) sold 11/5 2005 in germany, noname.

I tried to provide all of the useful information, but if it's not sufficient 
(probably?) please tell me what you could need!


Most recent kernel where this bug did not occur: unknown

Distribution: Kernel from kernel.org, original install Slackware 10.2

Log Messages from /var/log/messages:

Oct 27 19:01:52 dominik kernel: usbcore: registered new driver usbfs
Oct 27 19:01:52 dominik kernel: usbcore: registered new driver hub
Oct 27 19:01:52 dominik kernel: agpgart: Detected an Intel 440BX Chipset.
Oct 27 19:01:52 dominik kernel: usbmon: debugfs is not available
Oct 27 19:01:52 dominik kernel: USB Universal Host Controller Interface driver 
v2.3
Oct 27 19:01:52 dominik kernel: ACPI: PCI Interrupt 0000:00:07.2[D] -> Link 
[LNKD] -> GSI 10 (level, low) -> IRQ 10
Oct 27 19:01:52 dominik kernel: uhci_hcd 0000:00:07.2: Intel Corporation 
82371AB/EB/MB PIIX4 USB
Oct 27 19:01:52 dominik kernel: uhci_hcd 0000:00:07.2: new USB bus registered, 
assigned bus number 1
Oct 27 19:01:52 dominik kernel: uhci_hcd 0000:00:07.2: irq 10, io base 
0x0000d000
Oct 27 19:01:52 dominik kernel: hub 1-0:1.0: USB hub found
Oct 27 19:01:52 dominik kernel: hub 1-0:1.0: 2 ports detected
Oct 27 19:01:52 dominik kernel: usb 1-2: new low speed USB device using uhci_hcd 
and address 2
Oct 27 19:01:52 dominik kernel: usbcore: registered new driver usblp
Oct 27 19:01:52 dominik kernel: drivers/usb/class/usblp.c: v0.13: USB Printer 
Device Class driver
Oct 27 19:01:52 dominik kernel: Initializing USB Mass Storage driver...
Oct 27 19:01:52 dominik kernel: usbcore: registered new driver usb-storage
Oct 27 19:01:52 dominik kernel: USB Mass Storage support registered.
Oct 27 19:01:52 dominik kernel: input: USB HID v1.10 Mouse [Logitech USB Mouse] 
on usb-0000:00:07.2-2
Oct 27 19:01:52 dominik kernel: usbcore: registered new driver usbhid
Oct 27 19:01:52 dominik kernel: drivers/usb/input/hid-core.c: v2.01:USB HID core 
driver
Oct 27 19:01:52 dominik kernel: mice: PS/2 mouse device common for all mice
Oct 27 19:02:31 dominik kernel: usb 1-1: new full speed USB device using 
uhci_hcd and address 3
Oct 27 19:02:31 dominik usb.agent[2553]: ... no modules for USB product 10d6/
2200/100
Oct 27 19:02:31 dominik kernel: scsi1 : SCSI emulation for USB Mass Storage 
devices
Oct 27 19:02:33 dominik udev[2593]: removing device node '/dev/vcs1'
Oct 27 19:02:33 dominik udev[2595]: removing device node '/dev/vcsa1'
Oct 27 19:02:36 dominik kernel: usb 1-1: reset full speed USB device using 
uhci_hcd and address 3
Oct 27 19:02:36 dominik kernel: usb 1-1: device firmware changed
Oct 27 19:02:36 dominik kernel: usb 1-1: USB disconnect, address 3


Log from /var/log/syslog:

Oct 27 19:02:36 dominik kernel: Unable to handle kernel NULL pointer dereference 
at virtual address 00000008
Oct 27 19:02:36 dominik kernel:  printing eip:
Oct 27 19:02:36 dominik kernel: c019b13b
Oct 27 19:02:36 dominik kernel: *pde = 00000000
Oct 27 19:02:36 dominik kernel: Oops: 0000 [#1]
Oct 27 19:02:36 dominik kernel: PREEMPT
Oct 27 19:02:36 dominik kernel: Modules linked in: ne2k_pci 8390 snd_emu10k1 
snd_rawmidi snd_ac97_codec snd_util_mem snd_hwdep nvidia sr_mod aic7xxx 
scsi_transport_spi
Oct 27 19:02:36 dominik kernel: CPU:    0
Oct 27 19:02:36 dominik kernel: EIP:    0060:[<c019b13b>]    Tainted: P      VLI
Oct 27 19:02:36 dominik kernel: EFLAGS: 00010282   (2.6.13.2)
Oct 27 19:02:36 dominik kernel: EIP is at sysfs_hash_and_remove+0xb/0x10b
Oct 27 19:02:36 dominik kernel: eax: 00000000   ebx: d2feae9c   ecx: d2fead90   
edx: c042a04b
Oct 27 19:02:36 dominik kernel: esi: d2feae94   edi: c04ccb24   ebp: c04ccac0   
esp: d7c1bdb0
Oct 27 19:02:36 dominik kernel: ds: 007b   es: 007b   ss: 0068
Oct 27 19:02:36 dominik kernel: Process khubd (pid: 66, threadinfo=d7c1a000 
task=d7f1d550)
Oct 27 19:02:36 dominik kernel: Stack: 00000246 d2feac00 d2feae9c d2feae94 
c04ccb24 c04ccac0 c02a9800 00000000 
Oct 27 19:02:36 dominik kernel:        c042a04b d2feae94 d2fead90 d7156c00 
d7156c00 c02a9823 d2feae94 d2feac00 
Oct 27 19:02:36 dominik kernel:        c02efba7 d2feae94 00000003 d2feac00 
d7156bf8 d70fe200 c02efcdb d2feac00 
Oct 27 19:02:36 dominik kernel: Call Trace:
Oct 27 19:02:36 dominik kernel:  [<c02a9800>] class_device_del+0xd0/0xe0
Oct 27 19:02:36 dominik kernel:  [<c02a9823>] class_device_unregister+0x13/0x30
Oct 27 19:02:36 dominik kernel:  [<c02efba7>] scsi_remove_device+0x47/0xb0
Oct 27 19:02:36 dominik kernel:  [<c02efcdb>] __scsi_remove_target+0xcb/0xf0
Oct 27 19:02:36 dominik kernel:  [<c02eeb67>] scsi_forget_host+0x47/0x90
Oct 27 19:02:36 dominik kernel:  [<c02e75a9>] scsi_remove_host+0x19/0x80
Oct 27 19:02:36 dominik kernel:  [<c03fd477>] __down_failed+0x7/0xc
Oct 27 19:02:36 dominik kernel:  [<c0339443>] storage_disconnect+0x63/0x87
Oct 27 19:02:36 dominik kernel:  [<c0319c16>] usb_unbind_interface+0x86/0x90
Oct 27 19:02:36 dominik kernel:  [<c02a86c6>] __device_release_driver+0x86/0xa0
Oct 27 19:02:36 dominik kernel:  [<c02a86ff>] device_release_driver+0x1f/0x40
Oct 27 19:02:36 dominik kernel:  [<c02a7e36>] bus_remove_device+0x76/0x90
Oct 27 19:02:36 dominik kernel:  [<c02a6e32>] device_del+0x32/0x90
Oct 27 19:02:36 dominik kernel:  [<c0321c1b>] usb_disable_device+0xfb/0x130
Oct 27 19:02:36 dominik kernel:  [<c031c2d6>] usb_disconnect+0xa6/0x150
Oct 27 19:02:36 dominik kernel:  [<c031d78f>] hub_port_connect_change+0x3bf/
0x3f0
Oct 27 19:02:36 dominik kernel:  [<c031c6b9>] hub_port_status+0x29/0xa0
Oct 27 19:02:36 dominik kernel:  [<c031da8e>] hub_events+0x2ce/0x430
Oct 27 19:02:36 dominik kernel:  [<c031dc15>] hub_thread+0x25/0x120
Oct 27 19:02:36 dominik kernel:  [<c012d650>] autoremove_wake_function+0x0/0x60
Oct 27 19:02:36 dominik kernel:  [<c012d650>] autoremove_wake_function+0x0/0x60
Oct 27 19:02:36 dominik kernel:  [<c031dbf0>] hub_thread+0x0/0x120
Oct 27 19:02:36 dominik kernel:  [<c012d17a>] kthread+0xaa/0xb0
Oct 27 19:02:36 dominik kernel:  [<c012d0d0>] kthread+0x0/0xb0
Oct 27 19:02:36 dominik kernel:  [<c010137d>] kernel_thread_helper+0x5/0x18
Oct 27 19:02:36 dominik kernel: Code: 24 10 83 c4 14 e9 a6 29 26 00 e8 a1 29 26 
00 eb cb eb 0d 90 90 90 90 90 90 90 90 90 90 90 90 90 55 57 56 53 83 ec 08 8b 44 
24 1c <8b> 50 08 8b 48 48 85 d2 74 55 ff 4a 70 0f 88 ed 00 00 00 8b 51
Oct 27 19:02:36 dominik kernel:  <7>usb-storage: device scan complete



Hardware Environment: PII, intel BX440 board, USB 1 controller (board is about 8 
years old)

Software Environment:

Linux dominik 2.6.13.2 #2 Mon Oct 3 10:03:50 CEST 2005 i686 unknown unknown GNU/
Linux
 
Gnu C                  3.3.4
Gnu make               3.80
binutils               2.15.90.0.3
util-linux             2.12a
mount                  2.12a
module-init-tools      3.0
e2fsprogs              1.35
jfsutils               1.1.6
reiserfsprogs          3.6.17
reiser4progs           line
xfsprogs               2.6.13
pcmcia-cs              3.2.7
quota-tools            3.09.
PPP                    2.4.2
nfs-utils              1.0.6
Linux C Library        2.3.5
Dynamic linker (ldd)   2.3.5
Linux C++ Library      5.0.6
Procps                 3.2.1
Net-tools              1.60
Kbd                    1.12
Sh-utils               5.2.1
udev                   026
Modules Loaded         ne2k_pci 8390 snd_emu10k1 snd_rawmidi snd_ac97_codec 
snd_util_mem snd_hwdep nvidia sr_mod aic7xxx scsi_transport_spi




Steps to reproduce:

plugin the stick ;)
Comment 1 Greg Kroah-Hartman 2005-11-14 21:36:11 UTC
There was a patch somewhere to prevent the oops from happening, right?

Can someone send it to me?
Comment 2 Greg Kroah-Hartman 2005-11-14 21:38:30 UTC
Does 2.6.14 still cause the oops to happen?
Comment 3 Dominik Werder 2005-11-15 04:52:41 UTC
It'll take some days to check 2.6.14 because the boxes are busy at the moment..
Comment 4 Adrian Bunk 2005-12-05 18:19:48 UTC
Dominik, does this Oops still happen in a 2.6.14.3 kernel without the nvidia
module ever loaded since booting?
Comment 5 Dominik Werder 2005-12-06 09:08:09 UTC
I tried yesterday with 2.6.14.2 and the oops didnt happen anymore :)
but I couldnt access the device, dont know why, but the problem seems to be 
solved, thanks!
I dont know if I should close the bug?

Note You need to log in before you can comment on or make changes to this bug.