Bug 5604 - S3: no resume - IDE - HP nx6130
S3: no resume - IDE - HP nx6130
Status: CLOSED DUPLICATE of bug 2039
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 high
Assigned To: Shaohua
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-13 21:10 UTC by Austin Yuan
Modified: 2007-09-05 15:07 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.14-2
Tree: Mainline
Regression: ---


Attachments
hardware configuration (18.64 KB, text/plain)
2005-11-13 21:18 UTC, Austin Yuan
Details
result of "cat /proc/acpi/dsdt| iasl -d" (244.70 KB, application/octet-stream)
2005-11-13 21:30 UTC, Austin Yuan
Details
result of acpidump (146.21 KB, text/plain)
2005-11-13 21:36 UTC, Austin Yuan
Details
dmesg (9.50 KB, text/plain)
2005-11-13 22:33 UTC, Austin Yuan
Details
dmesg of kernel 2.6.14-2 (9.09 KB, text/plain)
2005-11-13 23:39 UTC, Austin Yuan
Details
kernel configuration file (12.28 KB, text/plain)
2005-11-13 23:46 UTC, Austin Yuan
Details
dmidecode (7.84 KB, text/plain)
2005-11-13 23:48 UTC, Austin Yuan
Details
biosdecode (1.16 KB, text/plain)
2005-11-13 23:49 UTC, Austin Yuan
Details
madt (381 bytes, text/plain)
2005-11-13 23:50 UTC, Austin Yuan
Details
vpddecode (49 bytes, text/plain)
2005-11-13 23:55 UTC, Austin Yuan
Details
gcc version (444 bytes, text/plain)
2005-11-13 23:57 UTC, Austin Yuan
Details
/proc/acpi/wakeup (186 bytes, text/plain)
2005-11-14 00:00 UTC, Austin Yuan
Details
Dell Inspiron 9300 DSDT (77.41 KB, text/plain)
2005-12-12 22:55 UTC, Ben Gamari
Details
Dell Inspiron 9300 lspci output (1.70 KB, text/plain)
2005-12-12 22:56 UTC, Ben Gamari
Details

Description Austin Yuan 2005-11-13 21:10:23 UTC
Most recent kernel where this bug did not occur:
Distribution:Redflag 5.0
Hardware Environment:HP NX6130 Laptop
Software Environment:Redflag 5.0, single user, text console mode
Problem Description: can't resume from S3, LCD is blank, caps lock/num lock 
have reaction, but can't shutdown/reboot when typing "halt/reboot" commands 
under the blank console. Also can't use sys rq to shutdown/reset of the machine 
(Alt+Sysrq+O)

Steps to reproduce:
1. compile 2.6.14-2 kernel on Redfalg5.0, remove almose all unnecessary 
components, including module support, usb, network, etc. Only enable IDE disk 
driver, and compile the kernel to a very small image
2. boot the new 2.6.14-2 kernel image with single user and text console mode
3. execut the scripts below:
#!/bin/sh 

vbetool vbestate save > /tmp/delme; 

echo "begin s3..." > /tmp/log
date >> /tmp/log

echo "mem" > /sys/power/state
sleep 5 

echo "now, come back" >> /tmp/log
date >> /tmp/log

vbetool post;
vbetool vbestate restore < /tmp/delme; 
setfont
halt -p

4. machine enters into sleep state, the power button light flickers. CPU 
fan/IDE device shutdown

5. press power button to resume, IDE/fan begin to run, when press 
capslock/numlock, they all have reaction

6. but LCD is blank, and can't see the text console, type "halt"/"shutdown", 
but no reaction.

7. press alt+sysrq+o hasn't reaction too.
Comment 1 Austin Yuan 2005-11-13 21:18:00 UTC
Created attachment 6563 [details]
hardware configuration
Comment 2 Shaohua 2005-11-13 21:26:12 UTC
Did S3 even work under the machine before? I mean if this is a recent 
regression. How about not do the vbe restore in the script?
Comment 3 Austin Yuan 2005-11-13 21:30:48 UTC
Created attachment 6564 [details]
result of "cat /proc/acpi/dsdt| iasl -d"
Comment 4 Austin Yuan 2005-11-13 21:33:49 UTC
Only test kernel 2.6.9,2.6.13,2.6.14 and 2.6.14-2, and they all can't work. 
Even I remove vbetool lines from the scripts, it still can't resume.
Comment 5 Austin Yuan 2005-11-13 21:36:24 UTC
Created attachment 6565 [details]
result of acpidump
Comment 6 Austin Yuan 2005-11-13 22:33:25 UTC
Created attachment 6566 [details]
dmesg
Comment 7 Austin Yuan 2005-11-13 23:39:28 UTC
Created attachment 6567 [details]
dmesg of kernel 2.6.14-2
Comment 8 Austin Yuan 2005-11-13 23:46:39 UTC
Created attachment 6568 [details]
kernel configuration file
Comment 9 Austin Yuan 2005-11-13 23:48:04 UTC
Created attachment 6569 [details]
dmidecode
Comment 10 Austin Yuan 2005-11-13 23:49:09 UTC
Created attachment 6570 [details]
biosdecode
Comment 11 Austin Yuan 2005-11-13 23:50:23 UTC
Created attachment 6571 [details]
madt
Comment 12 Austin Yuan 2005-11-13 23:55:58 UTC
Created attachment 6572 [details]
vpddecode
Comment 13 Austin Yuan 2005-11-13 23:57:47 UTC
Created attachment 6573 [details]
gcc version
Comment 14 Austin Yuan 2005-11-14 00:00:03 UTC
Created attachment 6574 [details]
/proc/acpi/wakeup
Comment 15 Austin Yuan 2005-11-18 04:38:52 UTC
boot nx6130 with USB hard disc, and remove IDE and unnecessary modules, it can 
do S3 perfectly. Of course, I am under text console mode and use vbetool to 
repost graphics card. The kernel is 2.6.14 and distro is Debian
Comment 16 Austin Yuan 2005-11-18 04:46:24 UTC
tried the patch on http://www.codon.org.uk/~mjg59/tmp/external-drivers-
ide_sleep.dpatch, when sleep, show message:
"IDE device ACPI handler is NULL"
and can't resume too.

also tried hdparm -y /dev/hda, and no good result.
Comment 17 Luming Yu 2005-11-18 07:49:04 UTC
The ide patch mentioned in comment#16 is not complete yet.
That is the reason for ACPI HANDLE IS NULL.

So, It's not surprise it doesn't work.
Could you try to remove error detecting code before invoking _GTM and _STM
And hardcode with :

For invoking _GTM:

{
acpi_handle tmp;
acpi_get_handle(NULL, \\_SB.C002.C0A6.C1D5, &tmp);
status = acpi_evaluate_object(tmp, "_GTM", NULL, &buffer);
...
}

For invoking _STM:

{
acpi_handle tmp;
acpi_get_handle(NULL, \\_SB.C002.C0A6.C1D5, &tmp);
status = acpi_evaluate_object(stat->handle, "_STM", &input, NULL);
..
}
Comment 18 Luming Yu 2005-11-18 07:52:33 UTC
sorry, it shoud be:
acpi_get_handle(NULL, "\\_SB.C002.C0A6.C1D5", &tmp);
Comment 19 Yuan Hang 2005-11-18 14:58:30 UTC
S3 works now in both console mode and x window. Thanks everyone!

Here is the conclusion of the method:
1. Update ide.c according the patch and Luming's comments.
2. Use vbetool to restore the graphics. 
Comment 20 Shaohua 2005-11-18 23:02:05 UTC
Then the patch at http://bugzilla.kernel.org/show_bug.cgi?id=2039 should work 
for you. Please try.
Comment 21 Shaohua 2005-12-06 10:45:12 UTC
Austin confirmed the patch fixed his issue 
(http://bugzilla.kernel.org/show_bug.cgi?id=2039)
Comment 22 Shaohua 2005-12-07 09:34:24 UTC
Hi Austin, is there any chance you can try the piix driver instead of the 
generic the IDE driver? The IDE mantainer thought the piix driver should work 
for you without the patch. Thanks!
Comment 23 Austin Yuan 2005-12-08 21:27:37 UTC
Shaohua,We will try it soon. Thanks for your help. -- Austin
Comment 24 Ben Gamari 2005-12-12 22:54:25 UTC
I seem to have a similar problem with my Dell Inspiron 9300. Suspend to RAM
worked up to 2.6.12, after which point it ceased to function, freezing due to an
apparent IDE failure on resume (usually the console comes up and remains
interactive until I try to run a command, at which point the harddrive light
remains continuously on). The machine uses the ICH6 SATA controller with an SATA
hard drive. I am presently running the 2.6.15-rc5 kernel. I have attached the
output of dmesg, lspci and a dump of the machine's DSDT. I hope this will
provide another data point to this bug. Thanks.
Comment 25 Ben Gamari 2005-12-12 22:55:23 UTC
Created attachment 6807 [details]
Dell Inspiron 9300 DSDT
Comment 26 Ben Gamari 2005-12-12 22:56:43 UTC
Created attachment 6808 [details]
Dell Inspiron 9300 lspci output
Comment 27 Ben Gamari 2005-12-12 23:00:22 UTC
I forgot to mention that the aforementioned patch works with neither the piix
nor the generic IDE driver. Don't hesitate to email with any further questions
(S3 suspend is quite nice to have in between lectures).
Comment 28 Yuan Hang 2005-12-18 23:33:19 UTC
Shaohua, could you tell more about using the piix driver? I want to try it but 
am not clear about how to use it. Thanks. -Henry 
Comment 29 Zhao, Forrest 2006-05-17 20:45:56 UTC
The ata_piix in 2.6.16-rc6 can resume from S3 on Thinkpad T43P and NAPA sdv.
Please try if it can work for HP nx6130.

Note: please only try 2.6.16-rc6, not the latest stock kernel.
Comment 30 Cliff Albert 2006-06-18 14:03:04 UTC
Same bug also appears on my HP nc6220. This patch fixes the problem for me! ->
http://oisec.net/~cliff/linux-2.6.15_ide-gtm-stm.diff
Comment 31 Rafael J. Wysocki 2006-09-29 03:03:41 UTC
Can anyone please verify if the problem still occurs on 2.6.18?
Comment 32 honkkis 2006-11-11 03:53:21 UTC
I am still having this problem with HP nx8220 with 2.6.18.2 kernel, but this
patch helps:

http://bugzilla.kernel.org/show_bug.cgi?id=2039
Comment 33 Len Brown 2007-08-18 23:45:23 UTC
The failure for the original submitter is gone with the IDE fixes in bug #2039
closing as a duplicate.

If the other submitters have issues not fixed by bug #2039
please submit a sighting specific to your system.


*** This bug has been marked as a duplicate of bug 2039 ***

Note You need to log in before you can comment on or make changes to this bug.