Bug 5602 - processor_get_info : Error getting cpuindex for acpiid 0x2
processor_get_info : Error getting cpuindex for acpiid 0x2
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Power-Processor
i386 Linux
: P2 low
Assigned To: acpi_power-processor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-13 08:41 UTC by Pavel Kysilka
Modified: 2006-12-26 21:11 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.15-rc1
Tree: Mainline
Regression: ---


Attachments
cpuinfo+kernel.log (10.00 KB, application/octet-stream)
2005-11-13 08:46 UTC, Pavel Kysilka
Details
DSDT table (50.00 KB, application/octet-stream)
2005-12-14 07:09 UTC, Pavel Kysilka
Details

Description Pavel Kysilka 2005-11-13 08:41:59 UTC
Most recent kernel where this bug did not occur:
Distribution: Debian testing
Hardware Environment: P4-2.4GHz, Intel 865GBF motherboard,1GB RAM
motherboard do(?) not support Hyperthreading
Software Environment:
kernel with (disabled) SMP support. enabled SMP support in kernel do not work.
Problem Description:
I have 1 CPU with HT support. Motherboard propably(?) do not support HT.

In the kernel log I see this:

 grep -ai 'CPU' kernel.log 
Nov 12 15:45:27 prog3 kernel: ACPI: CPU0 (power states: C1[C1])
Nov 12 15:45:27 prog3 kernel: ACPI: Processor [CPU1] (supports 8 throttling states)
Nov 12 15:45:27 prog3 kernel: acpi_processor-0507 [06] processor_get_info    :
Error getting cpuindex for acpiid 0x2

in the filesystem:

prog3:~# find /proc/ /sys/ -iname 'CPU*'
/proc/acpi/processor/CPU1
/proc/cpuinfo
/sys/firmware/acpi/namespace/ACPI/CPU2
/sys/firmware/acpi/namespace/ACPI/CPU1
/sys/class/pci_bus/0000:02/cpuaffinity
/sys/class/pci_bus/0000:01/cpuaffinity
/sys/class/pci_bus/0000:00/cpuaffinity
/sys/devices/system/cpu
/sys/devices/system/cpu/cpu0
prog3:~# 

Steps to reproduce:
boot pc, use command find.

In the attachment another information(cpuinfo, kernel.log).
Comment 1 Pavel Kysilka 2005-11-13 08:46:31 UTC
Created attachment 6557 [details]
cpuinfo+kernel.log

bzip2 attachment
Comment 2 Andi Kleen 2005-12-14 04:52:58 UTC
I see these warnings on lots of different systems. It seems to be a common
BIOS mistake to refer to non existing CPUs. Perhaps just disable it?
Comment 3 Pavel Kysilka 2005-12-14 07:09:43 UTC
Created attachment 6822 [details]
DSDT table

There are DSDT table from my pc.

output after compilation with intel compiler. No error, no warnings.

iasl -tc dsdt.dsl 

Intel ACPI Component Architecture
ASL Optimizing Compiler version 20051117 [Nov 27 2005]
Copyright (C) 2000 - 2005 Intel Corporation
Supports ACPI Specification Revision 3.0

ASL Input:  dsdt.dsl - 4657 lines, 153516 bytes, 1908 keywords
AML Output: DSDT.aml - 16508 bytes 611 named objects 1297 executable opcodes

Compilation complete. 0 Errors, 0 Warnings, 0 Remarks, 555 Optimizations
prog3:~/acpi_table#
Comment 4 Pavel Kysilka 2005-12-14 07:34:25 UTC
I found this in motherboard documentation (Page 107):

url: http://www.intel.com/design/motherbd/bf/bf_documentation.htm

--------------------------------

Hyper-Threading                     Disables/enables Hyper-Threading Technology.
This
Technology                          option is present only when a processor that
supports
                
Comment 5 Pavel Kysilka 2005-12-17 08:03:09 UTC
Problem resolved. I look on internet for problem solution.

Intel was made line of processor.

There is example:
- Intel 2.40A (NO HT support)
- Intel 2.40C (HT support)

My CPU 2.40A has hardware disabled HT capability.

My motherboard support HT technology.

decoded ACPI table:

  Scope (\_PR)
    {
        Processor (CPU1, 0x01, 0x00000410, 0x06) {}
        Processor (CPU2, 0x02, 0x00000410, 0x06) {}
    }


from kernel.log

Dec 17 14:48:52 prog3 kernel: CPU: After vendor identify, caps: bfebfbff 0000000
0 00000000 00000000 0000441d 00000000 00000000
Dec 17 14:48:52 prog3 kernel: monitor/mwait feature present.
Dec 17 14:48:52 prog3 kernel: using mwait in idle threads.
Dec 17 14:48:52 prog3 kernel: CPU: Trace cache: 12K uops, L1 D cache: 16K
Dec 17 14:48:52 prog3 kernel: CPU: L2 cache: 1024K
Dec 17 14:48:52 prog3 kernel: CPU: Hyper-Threading is disabled
                                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Dec 17 14:48:52 prog3 kernel: CPU: After all inits, caps: bfebfbff 0


but /proc/cpuinfo says:
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe pni monitor ds_cpl cid
xtpr
                                              ^^^^^^
bogomips        : 4795.26

Sorry for my bad english.
Comment 6 Pavel Kysilka 2006-04-18 07:00:46 UTC
There are some info from kernel.log .May be usefull.


Apr 17 10:25:37 prog3 kernel: ACPI: PM-Timer IO Port: 0x408
Apr 17 10:25:37 prog3 kernel: ACPI: Local APIC address 0xfee00000
Apr 17 10:25:37 prog3 kernel: ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
Apr 17 10:25:37 prog3 kernel: Processor #0 15:4 APIC version 20
Apr 17 10:25:37 prog3 kernel: ACPI: LAPIC (acpi_id[0x02] lapic_id[0x81] disabled)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
                
Apr 17 10:25:37 prog3 kernel: ACPI: LAPIC_NMI (acpi_id[0x01] dfl dfl lint[0x1])
Apr 17 10:25:37 prog3 kernel: ACPI: LAPIC_NMI (acpi_id[0x02] dfl dfl lint[0x1])
Apr 17 10:25:37 prog3 kernel: ACPI: IOAPIC (id[0x01] address[0xfec00000]
gsi_base[0])
Apr 17 10:25:37 prog3 kernel: IOAPIC[0]: apic_id 1, version 32, address
0xfec00000, GSI 0-23
Apr 17 10:25:37 prog3 kernel: ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2
dfl dfl)
Apr 17 10:25:37 prog3 kernel: ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9
high level)
Comment 7 Pavel Kysilka 2006-12-26 14:18:20 UTC
Problem seems solved. Bug may be closed.

Dec 25 22:53:30 prog3 kernel: ACPI: Sleep Button (CM) [SLPB]
Dec 25 22:53:30 prog3 kernel: ACPI: Processor [CPU1] (supports 8 throttling stat
es)
Dec 25 22:53:30 prog3 kernel: ACPI: Getting cpuindex for acpiid 0x2
Dec 25 22:53:30 prog3 kernel: PM: Adding info for No Bus:pnp1

Note You need to log in before you can comment on or make changes to this bug.