Bug 55941 - Hybrid graphics i915/radeon. Switch to radeon results to black screen
Hybrid graphics i915/radeon. Switch to radeon results to black screen
Status: CLOSED DOCUMENTED
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-29 18:52 UTC by Dimitris Damigos
Modified: 2013-11-13 21:22 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.8.4
Tree: Mainline
Regression: No


Attachments
lspci (23.25 KB, text/plain)
2013-03-29 18:52 UTC, Dimitris Damigos
Details
dmesg (57.25 KB, text/plain)
2013-03-29 18:53 UTC, Dimitris Damigos
Details

Description Dimitris Damigos 2013-03-29 18:52:55 UTC
Created attachment 96611 [details]
lspci

I have installed Arch Linux on a Dell Inspiron R15 with hybrid Intel/AMD graphics. vga_switcheroo is enabled and I can control radeon power with "echo ON/OFF > /sys/kernel/debug/vgaswitcheroo/switch".
But when I try to switch to radeon in console with "echo DIS > /sys/kernel/debug/vgaswitcheroo/switch" the screen turns off.
I can switch back to intel with "echo IGD > /sys/kernel/debug/vgaswitcheroo/switch" by blind typing it, and then the screen turns back on.
Comment 1 Dimitris Damigos 2013-03-29 18:53:19 UTC
Created attachment 96621 [details]
dmesg
Comment 2 Dimitris Damigos 2013-03-29 18:54:12 UTC
I also tried 3.0.70 lts and instead of the screen turning off, it just freezes.
Comment 3 Alex Deucher 2013-03-29 20:59:13 UTC
You have a muxless powerxpress system so there are no displays physically connected to the radeon card.  The only way to utilize the radeon card is for offscreen rendering (radeon renders application frame and the frame is copied to the intel card for display).  You need the new gpu hotplug features in xserver 1.13.x or 1.14 to utilize the card in that manner.
Comment 4 Aximab 2013-04-06 01:55:28 UTC
I have  been very puzzled when reading your last message Alex, since I got (on debian) the exact same problem with a Mux system intel Ironlake/radeon Hd5650.
The same issue occurs with kernel 3.7.6 (compiled by me) while the switch works correctly one the "distrib" kernel 3.2.0-4-ppae. Another issue 
appears with kernel 3.8.5 (with the NEW default modesetting bla for radeon..) but in that case  X seems to crash (well i don't really now what's happening only got the little  "-" on the top left of my screen)
I would be glad to give any addiotionnal infos relevant or to file a bug myself.


(In reply to comment #3)
> You have a muxless powerxpress system so there are no displays physically
> connected to the radeon card.  The only way to utilize the radeon card is for
> offscreen rendering (radeon renders application frame and the frame is copied
> to the intel card for display).  You need the new gpu hotplug features in
> xserver 1.13.x or 1.14 to utilize the card in that manner.
Comment 5 Aximab 2013-04-06 02:03:48 UTC
By the way this it should be the duplicated of Bug 55311.
Comment 6 Alex Deucher 2013-04-07 16:30:00 UTC
(In reply to comment #4)
> I have  been very puzzled when reading your last message Alex, since I got (on
> debian) the exact same problem with a Mux system intel Ironlake/radeon Hd5650.

On mux-less systems you can't switch the displays since there are no displays connected to the dGPU.

Note You need to log in before you can comment on or make changes to this bug.