Bug 5587 - Toshiba M200 PCI fails to allocate memory hence no PCI power related stuff works
Toshiba M200 PCI fails to allocate memory hence no PCI power related stuff works
Status: REJECTED WILL_NOT_FIX
Product: Drivers
Classification: Unclassified
Component: PCI
i386 Linux
: P2 high
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 5829
  Show dependency treegraph
 
Reported: 2005-11-10 11:10 UTC by Alireza Ali
Modified: 2006-08-30 01:15 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.14
Tree: Mainline
Regression: ---


Attachments
dmesg dump after boot (15.27 KB, text/plain)
2005-11-10 11:11 UTC, Alireza Ali
Details

Description Alireza Ali 2005-11-10 11:10:55 UTC
Most recent kernel where this bug did not occur:
Right after uncompressing Kernel image this error happens:
PCI: Failed to allocate mem resource #6:20000@e0000000 for 0000:01:00.0

Distribution: Ubuntu but using latest kernel (2.6.14) from kernel.org

Hardware Environment: Toshiba M200  with NVIDIA GeForce Go 5200

Software Environment: N/A

Problem Description: When booting to 2.6.14 the above message will appear right
after loading kernel to memroy  which results in prevention to adjust brightness
and power related option with regard to graphic card.
I am sure that this issue did not happen using 2.6.12 because I am dual booting
and I have no problem with 2.6.12. In addition when compiling kernel I used my
older 2.6.12 config file and I answered "NO" to all the new featrues in 2.6.14


Steps to reproduce:
1) boot 2.6.14 on a Toshiba M200
Comment 1 Alireza Ali 2005-11-10 11:11:52 UTC
Created attachment 6527 [details]
dmesg dump after boot
Comment 2 Len Brown 2005-11-10 19:49:42 UTC
punting this over to the PCI sub-system.
IIR they had some regressions recently and this may be a duplicate.

It would be interesting to test 2.6.13.stable to isolate
if the regression happened before or after 2.6.13.
Comment 3 Alireza Ali 2005-11-11 11:07:42 UTC
I compiled and installed 2.6.13 and the same issue was happened again.
Comment 4 Greg Kroah-Hartman 2006-02-14 17:29:18 UTC
Can you please try 2.6.16-rc3, or at the least, 2.6.15.  This should be fixed
by now.  Please let us know.
Comment 5 Alireza Ali 2006-02-14 20:42:19 UTC
I installed 2.6.15.4 but the problem is this time when i try to reboot using the
reboot command. the computer does not restart. it seem the goes successfullt to
shutdown stage but it wont go back up. 
Comment 6 Alireza Ali 2006-02-17 10:59:47 UTC
After more investigation it looks like that kernel can't initilize the ipw2100
after a reboot. I dont know if this helps but after a reboot , If i go to
windows  same thing happens on windows and it hangs on slpash scree. rather than
something in start up it seems something is not getting shut down properly.
Comment 7 Greg Kroah-Hartman 2006-03-06 11:22:02 UTC
As Windows has the same issues, I would really blame your hardware/BIOS here.

Make sure you have the latest BIOS update from your manufacturer.

So I'm going to close this for now, if there's anything that we can 
help out with, please reopen this.
Comment 8 Alireza Ali 2006-04-18 19:43:17 UTC
The problem is why this situation does not happen when I'm restarting the Windows? 
I never had any problem like this with windows and my BIOS. Moreover, I always
keep the BIOS to the latest version. Now I am running BIOS 1.70 for Toshiba M200. 

I think there is something in linux kernel rather than BIOS. 


Comment 9 Greg Kroah-Hartman 2006-08-30 01:15:48 UTC
But as this does not cause any problems with your machine, I'm just going
to close it out.

Sorry, I don't know what else to do.  If this does cause a problem with it
working properly, please feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.