Bug 5525 - usb scanner doesn't work with >= 2.6.13
usb scanner doesn't work with >= 2.6.13
Status: REJECTED DUPLICATE of bug 5063
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2005-10-29 13:12 UTC by Dariusz Brzezinski
Modified: 2005-10-29 16:30 UTC (History)
2 users (show)

See Also:
Kernel Version: >= 2.6.13
Tree: Mainline
Regression: ---


Attachments

Description Dariusz Brzezinski 2005-10-29 13:12:47 UTC
Most recent kernel where this bug did not occur:2.6.12   
Distribution:Gentoo 2005.1   
Hardware Environment:AMD Athlon64 3000+   
Software Environmet: xorg-x11-6.8.2-r4, gcc-3.4.4-r1, glibc-2.3.5-r2,  
libusb-0.1.10a, sane-backends-1.0.15, xsane-0.97  
Problem Description: With gentoo-sources-2.6.12 scanner works fine. After 
upgrade to 2.6.13 the scanner is recognized proprely but xsane faild with 
message:   
"Failed to open device `sm3600:3/1`: Error during device I/O."   
The fault is present for normal user and root.   
Also kooka failed with complaining about sane-backends instalation.  
The sane-backends and xsane was reemerged. More details see: 
http://bugs.gentoo.org/show_bug.cgi?id=109355 
   
Steps to reproduce: Always
Comment 1 Daniel Drake 2005-10-29 13:38:46 UTC
Summary should be updated; this has been reproduced on unpatched 2.6.14-rc5 so
it is not a gentoo-specific bug.
Comment 2 Alan Stern 2005-10-29 16:23:28 UTC
Does SANE use libusb?  If it does, this probably indicates that you need to
upgrade your copy of libusb.
Comment 3 Greg Kroah-Hartman 2005-10-29 16:30:05 UTC
Does no one search for old bugs these days? ...

*** This bug has been marked as a duplicate of 5063 ***

Note You need to log in before you can comment on or make changes to this bug.