Bug 55171 - ath9k randomly loses communication with the AP (O2box6431) and requires reboot of AP
ath9k randomly loses communication with the AP (O2box6431) and requires reboo...
Status: CLOSED DUPLICATE of bug 49201
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-13 19:21 UTC by sick_soul
Modified: 2013-10-15 16:02 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.6.6
Tree: Mainline
Regression: No


Attachments

Description sick_soul 2013-03-13 19:21:37 UTC
Hello,

I just acquired a new DSL router / wireless AP O2 box 6431,
and a new ASUS N76V laptop with an Atheros network adapter.
I use Slackware 14.

I built kernel 3.6.6 from source, after experiencing bad wireless problems with the default slackware (vanilla) kernel, with no improvement. The problem:

wireless communication with the AP works for a while, but after a random amount of time (sometimes a few seconds, sometimes hours of happy internet browsing), the communication with the wireless AP is lost, and all subsequent attempts to reauthenticate with the AP time out.

The adapter as reported by lspci is an Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)

Here's the successful association in messages:

Mar 13 18:00:47 asus kernel: [   46.868455] wlan0: authenticate with 1c:c6:3c:a5:9e:9e
Mar 13 18:00:47 asus kernel: [   46.876996] wlan0: send auth to 1c:c6:3c:a5:9e:9e (try 1/3)
Mar 13 18:00:47 asus kernel: [   46.879064] wlan0: authenticated
Mar 13 18:00:47 asus kernel: [   46.883602] wlan0: associating with AP with corrupt beacon
Mar 13 18:00:47 asus kernel: [   46.883854] wlan0: associate with 1c:c6:3c:a5:9e:9e (try 1/3)
Mar 13 18:00:47 asus kernel: [   46.911910] wlan0: RX AssocResp from 1c:c6:3c:a5:9e:9e (capab=0x411 status=0 aid=1)
Mar 13 18:00:47 asus kernel: [   46.912004] wlan0: associated

The syslog captures the following errors:

Mar 13 18:27:16 asus kernel: [ 1635.368218] WARNING: at drivers/net/wireless/ath/ath9k/hw.c:786 ar9003_get_pll_sqsum_dvc+0x66/0xb1 [ath9k_hw]()
Mar 13 18:27:16 asus kernel: [ 1635.368220] Hardware name: N76VZ
Mar 13 18:27:16 asus kernel: [ 1635.368300] Pid: 127, comm: kworker/u:7 Tainted: P           O 3.6.6 #4
Mar 13 18:27:16 asus kernel: [ 1635.368302] Call Trace:
Mar 13 18:27:16 asus kernel: [ 1635.368313]  [<ffffffff81033f1d>] warn_slowpath_common+0x7e/0x97
Mar 13 18:27:16 asus kernel: [ 1635.368332]  [<ffffffff81033f4b>] warn_slowpath_null+0x15/0x17
Mar 13 18:27:16 asus kernel: [ 1635.368341]  [<ffffffffa019ca47>] ar9003_get_pll_sqsum_dvc+0x66/0xb1 [ath9k_hw]
Mar 13 18:27:16 asus kernel: [ 1635.368350]  [<ffffffffa00ca727>] ath_hw_pll_work+0x37/0xa5 [ath9k]
Mar 13 18:27:16 asus kernel: [ 1635.368356]  [<ffffffff81046dab>] process_one_work+0x1c1/0x310
Mar 13 18:27:16 asus kernel: [ 1635.368363]  [<ffffffffa00ca6f0>] ? ath_tx_complete_poll_work+0xbc/0xbc [ath9k]
Mar 13 18:27:16 asus kernel: [ 1635.368368]  [<ffffffff8104718d>] worker_thread+0x269/0x346
Mar 13 18:27:16 asus kernel: [ 1635.368373]  [<ffffffff81046f24>] ? process_scheduled_works+0x2a/0x2a
Mar 13 18:27:16 asus kernel: [ 1635.368378]  [<ffffffff8104ae5f>] kthread+0x86/0x8e
Mar 13 18:27:16 asus kernel: [ 1635.368385]  [<ffffffff813c0ab4>] kernel_thread_helper+0x4/0x10
Mar 13 18:27:16 asus kernel: [ 1635.368391]  [<ffffffff8104add9>] ? kthread_freezable_should_stop+0x4d/0x4d
Mar 13 18:27:16 asus kernel: [ 1635.368397]  [<ffffffff813c0ab0>] ? gs_change+0xb/0xb


After disconnection from the AP, the following loop repeats itself to no successful end (from messages):


Mar 13 18:23:49 asus kernel: [ 1428.606888] wlan0: authenticate with 1c:c6:3c:a5:9e:9e
Mar 13 18:23:49 asus kernel: [ 1428.615646] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 1/3)
Mar 13 18:23:49 asus kernel: [ 1428.816365] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 2/3)
Mar 13 18:23:50 asus kernel: [ 1429.017230] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 3/3)
Mar 13 18:23:50 asus kernel: [ 1429.218153] wlan0: authentication with 1c:c6:3c:a5:9e:9e timed out
Mar 13 18:24:08 asus kernel: [ 1447.799035] wlan0: authenticate with 1c:c6:3c:a5:9e:9e
Mar 13 18:24:08 asus kernel: [ 1447.807795] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 1/3)
Mar 13 18:24:09 asus kernel: [ 1448.008477] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 2/3)
Mar 13 18:24:09 asus kernel: [ 1448.209405] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 3/3)
Mar 13 18:24:09 asus kernel: [ 1448.410270] wlan0: authentication with 1c:c6:3c:a5:9e:9e timed out
Mar 13 18:24:16 asus kernel: [ 1454.869365] wlan0: authenticate with 1c:c6:3c:a5:9e:9e
Mar 13 18:24:16 asus kernel: [ 1454.878226] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 1/3)
Mar 13 18:24:16 asus kernel: [ 1455.078881] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 2/3)
Mar 13 18:24:16 asus kernel: [ 1455.279777] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 3/3)
Mar 13 18:24:16 asus kernel: [ 1455.480677] wlan0: authentication with 1c:c6:3c:a5:9e:9e timed out
Mar 13 18:24:41 asus kernel: [ 1480.115510] wlan0: authenticate with 1c:c6:3c:a5:9e:9e
Mar 13 18:24:41 asus kernel: [ 1480.124238] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 1/3)
Mar 13 18:24:41 asus kernel: [ 1480.324888] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 2/3)
Mar 13 18:24:41 asus kernel: [ 1480.525781] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 3/3)
Mar 13 18:24:41 asus kernel: [ 1480.726712] wlan0: authentication with 1c:c6:3c:a5:9e:9e timed out
Mar 13 18:25:06 asus kernel: [ 1505.363526] wlan0: authenticate with 1c:c6:3c:a5:9e:9e
Mar 13 18:25:06 asus kernel: [ 1505.372266] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 1/3)
Mar 13 18:25:06 asus kernel: [ 1505.572958] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 2/3)
Mar 13 18:25:06 asus kernel: [ 1505.773855] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 3/3)
Mar 13 18:25:07 asus kernel: [ 1505.974750] wlan0: authentication with 1c:c6:3c:a5:9e:9e timed out
Mar 13 18:26:38 asus kernel: [ 1597.258367] wlan0: authenticate with 1c:c6:3c:a5:9e:9e
Mar 13 18:26:38 asus kernel: [ 1597.267099] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 1/3)
Mar 13 18:26:38 asus kernel: [ 1597.467749] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 2/3)
Mar 13 18:26:38 asus kernel: [ 1597.668672] wlan0: direct probe to 1c:c6:3c:a5:9e:9e (try 3/3)
Mar 13 18:26:39 asus kernel: [ 1597.869574] wlan0: authentication with 1c:c6:3c:a5:9e:9e timed out
Mar 13 18:27:15 asus kernel: [ 1634.628146] wlan0: authenticate with 1c:c6:3c:a5:9e:9e

...

Rebooting linux does not solve, 
the only way to solve is to power cycle the AP, or to push the WLAN button on the AP (thus disabling the WLAN), and reenabling it.
Comment 1 Sujith 2013-06-03 02:17:15 UTC
Please try with a recent backports package:
https://www.kernel.org/pub/linux/kernel/projects/backports/2013/03/28/

Also, disable PowerSave (iw dev wlan0 set power_save off) and check if the connection stability improves.
Comment 2 Sujith 2013-06-14 02:39:38 UTC
This is similar to https://bugzilla.kernel.org/show_bug.cgi?id=49201
Comment 3 John W. Linville 2013-10-15 16:02:22 UTC

*** This bug has been marked as a duplicate of bug 49201 ***

Note You need to log in before you can comment on or make changes to this bug.