Bug 5502 - hotkey sysfs interface
Summary: hotkey sysfs interface
Status: REJECTED DUPLICATE of bug 5749
Alias: None
Product: Drivers
Classification: Unclassified
Component: Platform (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Luming Yu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-26 09:26 UTC by Luming Yu
Modified: 2010-10-08 18:17 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.13
Tree: Mainline
Regression: ---


Attachments
hotkeylib.c --take 1 (5.85 KB, patch)
2005-10-26 09:27 UTC, Luming Yu
Details | Diff
sys fs interrface support for generic hotkey driver (6.52 KB, patch)
2005-10-26 23:38 UTC, Luming Yu
Details | Diff
scratch patch: ibm_acpi hotkey sysfs support (1.49 KB, patch)
2005-11-23 01:03 UTC, Luming Yu
Details | Diff
scratch patch: toshiba_acpi hotkey sysfs support (1.24 KB, patch)
2005-11-23 01:04 UTC, Luming Yu
Details | Diff
scratch patch : for asus laptop support in generic hotkey driver and sysfs support (3.71 KB, patch)
2005-11-24 00:06 UTC, Luming Yu
Details | Diff
scratch patch : hotkey sysfs support for pcc_acpi.c (1.72 KB, patch)
2005-12-01 06:49 UTC, Luming Yu
Details | Diff

Description Luming Yu 2005-10-26 09:26:12 UTC
we need to use a unified sysfs interface to simplify hotkey support for various 
hotkey drivers including generic hotkey driver and specific hotkey driver...
Comment 1 Luming Yu 2005-10-26 09:27:37 UTC
Created attachment 6394 [details]
hotkeylib.c --take 1
Comment 2 Luming Yu 2005-10-26 23:38:28 UTC
Created attachment 6396 [details]
sys fs interrface support for generic hotkey driver
Comment 3 Luming Yu 2005-11-23 01:03:11 UTC
Created attachment 6648 [details]
scratch patch: ibm_acpi hotkey sysfs support

Just scratch. No compile, NO test.
Comment 4 Luming Yu 2005-11-23 01:04:41 UTC
Created attachment 6649 [details]
scratch patch: toshiba_acpi hotkey sysfs support

Just scratch patch, No compile, No test
Comment 5 Luming Yu 2005-11-24 00:06:36 UTC
Created attachment 6673 [details]
scratch  patch : for asus laptop support in generic hotkey driver and sysfs support
Comment 6 Luming Yu 2005-12-01 06:49:47 UTC
Created attachment 6735 [details]
scratch patch : hotkey sysfs support for pcc_acpi.c

Just scratch patch , no compile, no test, just for MEMO
Comment 7 Luming Yu 2005-12-16 01:05:55 UTC

*** This bug has been marked as a duplicate of 5749 ***

Note You need to log in before you can comment on or make changes to this bug.